summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorWilliam Gathoye2019-11-30 22:30:52 +0100
committerWilliam Gathoye2019-12-02 15:28:15 +0100
commit7c431c52fe908123ccfe7f7dcd107bcad4d7cf8f (patch)
tree34dfc891309e05a074adc084d2bffd357d6fbc2e
parentef5da8dc28d0fca76e5de28cdcf9e4ada8330bf8 (diff)
downloadaur-7c431c52fe908123ccfe7f7dcd107bcad4d7cf8f.tar.gz
Prepare work for using system spellcheck instead
-rw-r--r--PKGBUILD15
1 files changed, 15 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 047c40612478..9e1eda8eb106 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -13,6 +13,7 @@ url="https://github.com/mattermost/desktop"
license=('Apache')
depends=("electron${_electronMajorVersion}")
makedepends=('npm' 'git' 'jq')
+#optdepends=('hunspell: spell checking')
source=(
"${pkgname}-${pkgver}.tar.gz"::"${url}/archive/${pkgver}.tar.gz"
"${pkgname}.sh"
@@ -49,6 +50,20 @@ prepare() {
--arg electronVersion "$electronVersion" \
electron-builder.json > electron-builder-new.json
mv electron-builder-new.json electron-builder.json
+
+ # Mattermost Desktop is using simple-spellchecker which prevents to bind on
+ # the system Arch Linux hunspell dictionnaries. This is due to the fact
+ # simple-spellchecker comes with its own set of dictionnaries. They differ
+ # from the hunspell dictionnaries in the sense of, hunspell's dictionnaries
+ # have additional pieces of info attributed to each line.
+ # e.g. in /usr/share/hunspell/fr_FR.dic, "ordinateur" (computer in English)
+ # ordinateur/S*() po:nom is:mas
+ # simple-spellcheck expects a line with:
+ # ordinateur
+ # instead
+ #
+ # Asking upstream to switch to electron-spellchecker will fix the issue.
+ # https://github.com/electron-userland/electron-spellchecker
}
build() {