summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorWilliam Gathoye2019-10-19 13:05:38 +0200
committerWilliam Gathoye2019-10-19 13:19:02 +0200
commita844427047aa8adf58a5eb4f34001db070b721b2 (patch)
tree00e62b9a021a8a0f51c574580cdccc5514e2a7d9
parent897620d1b6db909d9516d10ed1e52ee01f6788df (diff)
downloadaur-a844427047aa8adf58a5eb4f34001db070b721b2.tar.gz
Upgrade to 4.3.0
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD21
-rw-r--r--mattermost-desktop.sh2
-rw-r--r--mattermost-package-json.patch49
-rw-r--r--mattermost.desktop9
5 files changed, 28 insertions, 71 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 443bd633745e..32aa7fdfd3c3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,20 @@
pkgbase = mattermost-desktop
- pkgdesc = Mattermost Desktop application for Linux (Beta)
- pkgver = 4.2.3
- pkgrel = 2
+ pkgdesc = Mattermost Desktop application for Linux
+ pkgver = 4.3.0
+ pkgrel = 1
url = https://github.com/mattermost/desktop
arch = i686
arch = x86_64
license = Apache
makedepends = npm
makedepends = git
- depends = electron4
- source = mattermost-desktop-4.2.3.tar.gz::https://github.com/mattermost/desktop/archive/v4.2.3.tar.gz
+ depends = electron
+ source = mattermost-desktop-4.3.0.tar.gz::https://github.com/mattermost/desktop/archive/v4.3.0.tar.gz
source = mattermost-desktop.sh
- source = mattermost-package-json.patch
- sha512sums = 478124a2cf9fff618035d408a73176fd68c21d16fdbecc307c621bf576d9bbdd2663a52a1dd4be6e3a0ea52029270d3f1d92c2180f0158b3c29d4116630c6f37
- sha512sums = ec10960a56593429996f153d0832345d1f9279aa386d5d09f078aed39a5e8e4c3d1900fc8ff608318c9c57a161c3850b2c7924d86af0ae41f76649c080fccc1f
- sha512sums = c5e6f14152eb325eab4cf43355f586a82975210a48599cb5b555eb56a4d25d3d66f669a95056baac43cb0372208ac954aa726d901411c9f16b8884c3a19777ed
+ source = mattermost.desktop
+ sha512sums = 2a5b1423fe0b1bcdcbd69bbb0591b682f049aa875d86b0a513746caea4c32198a624cd3c7707036c0969381e3c8821326ce218bc5ad2b67553423fa25f627fce
+ sha512sums = 7cce5fad5a923fbde106d0e67ce42d599a2d21358eca3c339d5c9e0a19a0ac057bbf2db23f5ee3628d625afcd4b128b9b9041ace4f1892a0e1d2bbd0a9c677b9
+ sha512sums = b8f24df883b71df4177155246fd5858ad785f75be4f7dfc674380674b48a45342b1f5ee217a20708f74ed8d2119d837bae4a3fd48d1b62d60d55644e36411266
pkgname = mattermost-desktop
diff --git a/PKGBUILD b/PKGBUILD
index 3ff8fe73946e..470ba84390ec 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,34 +1,31 @@
-# Maintainer: William Gathoye <william at gathoye dot be>
+# Maintainer: William Gathoye <william + aur at gathoye dot be>
# Maintainer: Aleksandar Trifunović <akstrfn at gmail dot com>
# Contributor: Jan Was <janek dot jan at gmail dot com>
# Contributor: Bruno Pagani <archange at archlinux dot org>
pkgname=mattermost-desktop
-pkgver=4.2.3
-pkgrel=2
-pkgdesc="Mattermost Desktop application for Linux (Beta)"
+pkgver=4.3.0
+pkgrel=1
+pkgdesc="Mattermost Desktop application for Linux"
arch=('i686' 'x86_64')
url="https://github.com/mattermost/desktop"
license=('Apache')
-depends=('electron4')
+depends=('electron')
makedepends=('npm' 'git')
source=(
"${pkgname}-${pkgver}.tar.gz"::"${url}/archive/v${pkgver}.tar.gz"
"${pkgname}.sh"
- "${pkgname%%-*}-package-json.patch"
+ "${pkgname/-/.}"
)
sha512sums=(
- '478124a2cf9fff618035d408a73176fd68c21d16fdbecc307c621bf576d9bbdd2663a52a1dd4be6e3a0ea52029270d3f1d92c2180f0158b3c29d4116630c6f37'
- 'ec10960a56593429996f153d0832345d1f9279aa386d5d09f078aed39a5e8e4c3d1900fc8ff608318c9c57a161c3850b2c7924d86af0ae41f76649c080fccc1f'
- 'c5e6f14152eb325eab4cf43355f586a82975210a48599cb5b555eb56a4d25d3d66f669a95056baac43cb0372208ac954aa726d901411c9f16b8884c3a19777ed'
+ '2a5b1423fe0b1bcdcbd69bbb0591b682f049aa875d86b0a513746caea4c32198a624cd3c7707036c0969381e3c8821326ce218bc5ad2b67553423fa25f627fce'
+ '7cce5fad5a923fbde106d0e67ce42d599a2d21358eca3c339d5c9e0a19a0ac057bbf2db23f5ee3628d625afcd4b128b9b9041ace4f1892a0e1d2bbd0a9c677b9'
+ 'b8f24df883b71df4177155246fd5858ad785f75be4f7dfc674380674b48a45342b1f5ee217a20708f74ed8d2119d837bae4a3fd48d1b62d60d55644e36411266'
)
prepare() {
cd "desktop-${pkgver}"
- # Bump dependencies. Temporary patch. Remove when 4.3 is out.
- patch < "${srcdir}"/mattermost-package-json.patch
-
# Depending on the architecture, in order to accelerate the build process,
# removes the compilation of ia32 or x64 build.
if [[ "$CARCH" == x86_64 ]];then
diff --git a/mattermost-desktop.sh b/mattermost-desktop.sh
index 3854870daf63..f96beceb8be0 100644
--- a/mattermost-desktop.sh
+++ b/mattermost-desktop.sh
@@ -1,2 +1,2 @@
#!/bin/bash
-exec electron4 /usr/lib/mattermost-desktop/app.asar --disable-dev-mode "$@"
+exec electron /usr/lib/mattermost-desktop/app.asar --disable-dev-mode "$@"
diff --git a/mattermost-package-json.patch b/mattermost-package-json.patch
deleted file mode 100644
index b581d195016a..000000000000
--- a/mattermost-package-json.patch
+++ /dev/null
@@ -1,49 +0,0 @@
---- package.json 2019-09-26 16:42:50.915815809 +0200
-+++ package.json 2019-09-26 16:52:44.822830028 +0200
-@@ -28,32 +28,31 @@
- "test": "npm-run-all test:* lint:*",
- "test:app": "cross-env NODE_ENV=production npm run build && mocha -r babel-register --reporter mocha-circleci-reporter --recursive test/specs",
- "package:all": "cross-env NODE_ENV=production npm-run-all check-build-config package:windows package:mac package:linux",
-- "package:windows": "cross-env NODE_ENV=production npm-run-all check-build-config build && build --win --x64 --ia32 --config.extraMetadata.name=mattermost --publish=never",
-+ "package:windows": "cross-env NODE_ENV=production npm-run-all check-build-config build && build --win --x64 --config.extraMetadata.name=mattermost --publish=never",
- "package:mac": "cross-env NODE_ENV=production npm-run-all check-build-config build && build --mac --publish=never",
-- "package:linux": "cross-env NODE_ENV=production npm-run-all check-build-config build && build --linux --x64 --ia32 --config.extraMetadata.name=mattermost-desktop --publish=never",
-+ "package:linux": "cross-env NODE_ENV=production npm-run-all check-build-config build && build --linux --x64 --config.extraMetadata.name=mattermost-desktop --publish=never",
- "manipulate-windows-zip": "node scripts/manipulate_windows_zip.js",
- "lint:js": "eslint --ignore-path .gitignore --ignore-pattern node_modules --ext .js --ext .jsx .",
- "fix:js": "eslint --ignore-path .gitignore --ignore-pattern node_modules --quiet --ext .js --ext .jsx . --fix",
- "check-build-config": "node -r babel-register scripts/check_build_config.js"
- },
- "devDependencies": {
-- "7zip-bin": "^4.0.2",
-+ "7zip-bin": "^4.1.0",
- "@storybook/react": "^3.4.6",
-- "babel-core": "^6.26.3",
-- "babel-eslint": "^8.2.3",
-- "babel-loader": "^7.1.4",
-+ "babel-core": "^6.0.0",
-+ "babel-eslint": "^10.0.0",
-+ "babel-loader": "^7.0.0",
- "babel-plugin-transform-object-rest-spread": "^6.26.0",
-- "babel-preset-env": "^1.7.0",
- "babel-preset-react": "^6.24.1",
-- "chai": "^4.1.2",
-- "cross-env": "^5.1.6",
-- "css-loader": "^0.28.11",
-+ "chai": "^4.2.0",
-+ "cross-env": "^5.2.0",
-+ "css-loader": "^1.0.1",
- "devtron": "^1.4.0",
-- "electron": "2.0.12",
-- "electron-builder": "20.14.7",
-- "electron-builder-squirrel-windows": "~20.14.0",
-- "electron-connect": "^0.6.3",
-- "eslint": "^4.19.1",
-+ "electron": "^2.0.0",
-+ "electron-builder": "^20.38.0",
-+ "electron-builder-squirrel-windows": "^20.14.0",
-+ "electron-connect": "^0.6.0",
-+ "eslint": "^5.9.0",
- "eslint-plugin-eslint-comments": "^3.1.2",
- "eslint-plugin-header": "^1.2.0",
- "eslint-plugin-import": "^2.12.0",
diff --git a/mattermost.desktop b/mattermost.desktop
new file mode 100644
index 000000000000..15a964c95885
--- /dev/null
+++ b/mattermost.desktop
@@ -0,0 +1,9 @@
+[Desktop Entry]
+Name=Mattermost
+Comment=Mattermost Desktop application for Linux
+Exec=/usr/bin/mattermost-desktop
+Terminal=false
+Type=Application
+Icon=mattermost-desktop
+Categories=Network;InstantMessaging;
+MimeType=x-scheme-handler/mattermost;