summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorxnicon2024-01-19 12:10:00 +0300
committerxnicon2024-01-19 12:10:00 +0300
commit3700fb4251ff50ae16e4e4f2ee6dc74b4655f56d (patch)
tree1f560c08d9bb241e172f7a8a7247a36a93aeb25e
downloadaur-mbw.tar.gz
v2.0
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD21
2 files changed, 36 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..11ab9b50c740
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = mbw
+ pkgdesc = MBW determines the copy memory bandwidth available to userspace programs. Its simplistic approach models that of real applications. It is not tuned to extremes and it is not aware of hardware architecture, just like your average software package.
+ pkgver = 2.0
+ pkgrel = 1
+ url = https://github.com/raas/mbw
+ arch = i686
+ arch = x86_64
+ arch = armv7h
+ arch = armv6h
+ license = GPLv3
+ makedepends = make
+ source = https://github.com/raas/mbw/archive/refs/tags/v2.0.tar.gz
+ md5sums = 46ca7401ae650734965e7a25453557d4
+
+pkgname = mbw
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..695e49567dda
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+pkgname=mbw
+pkgver=2.0
+pkgrel=1
+pkgdesc="MBW determines the "copy" memory bandwidth available to userspace programs. Its simplistic approach models that of real applications. It is not tuned to extremes and it is not aware of hardware architecture, just like your average software package."
+arch=('i686' 'x86_64' 'armv7h' 'armv6h')
+url="https://github.com/raas/mbw"
+makedepends=('make')
+license=('GPLv3')
+source=("https://github.com/raas/${pkgname}/archive/refs/tags/v${pkgver}.tar.gz")
+md5sums=('46ca7401ae650734965e7a25453557d4')
+
+build() {
+ cd "${pkgname}-${pkgver}"
+ make
+}
+
+package() {
+ cd "${pkgname}-${pkgver}"
+ install -d "${pkgdir}/usr/bin"
+ install -m755 "${pkgname}" "${pkgdir}/usr/bin/${pkgname}"
+}