summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authornic962016-06-20 14:13:25 +0000
committernic962016-06-20 14:13:25 +0000
commit1bae0fafb5ab41f221a6fae5e1a54b52549bdae2 (patch)
tree51d55ab103597c989841f1b92345f19c6980276e
parent18d79c054e368138087e33816ee7841d7c047a7f (diff)
downloadaur-1bae0fafb5ab41f221a6fae5e1a54b52549bdae2.tar.gz
updated to version 1.5.3.0
-rwxr-xr-x[-rw-r--r--].SRCINFO0
-rwxr-xr-x[-rw-r--r--]MCEdit0
-rwxr-xr-x[-rw-r--r--]PKGBUILD8
-rwxr-xr-x[-rw-r--r--]directories.patch39
4 files changed, 4 insertions, 43 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 40cd92a08068..40cd92a08068 100644..100755
--- a/.SRCINFO
+++ b/.SRCINFO
diff --git a/MCEdit b/MCEdit
index c471f6985305..c471f6985305 100644..100755
--- a/MCEdit
+++ b/MCEdit
diff --git a/PKGBUILD b/PKGBUILD
index 69893fe43609..4b7962b069e1 100644..100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname='mcedit'
reponame='MCEdit-Unified'
-pkgver='1.5.1.0'
+pkgver='1.5.3.0'
pkgrel=1
pkgdesc='Minecraft world editor'
arch=('any')
@@ -11,7 +11,7 @@ license=('BSD')
makedepends=('cython2')
depends=('python2' 'python2-opengl' 'python2-numpy' 'python2-pygame'
- 'python2-yaml' 'python2-pillow' 'python2-ftputil' 'xclip')
+ 'python2-yaml' 'python2-pillow' 'python2-ftputil' 'python2-xlib' 'xclip')
optdepends=('python2-leveldb_mcpe: for MCPE support')
conflicts=('mcedit-git' 'pymclevel-git')
@@ -70,5 +70,5 @@ package() {
md5sums=('b08f609c8923067b13a9bd462999a6f4'
'53fe3c41d58fd1f6429f90ba0b1831ac'
- '329f0dbdedd309e4dc121ad3d728e608'
- 'e3951e6905104351a53b0e45bc17aa00')
+ '34f209ecd6f0898f91fb5ddce02a0c4c'
+ '06055ce96c3091fd858eefde75228977')
diff --git a/directories.patch b/directories.patch
index 7a854af36a81..f0814b3c800e 100644..100755
--- a/directories.patch
+++ b/directories.patch
@@ -39,45 +39,6 @@
logfile = os.path.join(os.getcwdu(), logfile)
fh = logging.FileHandler(logfile, mode="w")
---- resource_packs.py.orig 2015-08-12 07:12:26.000000000 -0600
-+++ resource_packs.py 2015-12-24 21:13:54.257356703 -0700
-@@ -537,7 +537,7 @@
-
- def __init__(self):
- self.__stop = False
-- texture_path = os.path.join(directories.parentDir, "textures", self._pack_name)
-+ texture_path = os.path.join(directories.getDocumentsFolder(), "textures", self._pack_name)
- self.texture_path = texture_path
- self._isEmpty = False
- self._too_big = False
-@@ -727,7 +727,7 @@
- self._pack_name = self._folder.replace(" ", "_")
- IResourcePack.__init__(self)
- self._full_path = os.path.join(directories.getMinecraftProfileDirectory(directories.getSelectedProfile()), "resourcepacks", self._folder)
-- self.texture_path = os.path.join(directories.parentDir, "textures", self._pack_name)
-+ self.texture_path = os.path.join(directories.getDocumentsFolder(), "textures", self._pack_name)
- if not os.path.exists(self._terrain_path):
- self.add_textures()
-
-@@ -837,7 +837,7 @@
- if not os.path.exists(pack.terrain_path()):
- del terrains[tex]
- try:
-- shutil.rmtree(os.path.join(directories.parentDir, "textures"))
-+ shutil.rmtree(os.path.join(directories.getDocumentsFolder(), "textures"))
- except:
- print "Could not remove \"textures\" directory"
- pass
-@@ -851,7 +851,7 @@
-
- def __init__(self):
- try:
-- os.mkdir(os.path.join(directories.parentDir, "textures"))
-+ os.mkdir(os.path.join(directories.getDocumentsFolder(), "textures"))
- except OSError:
- pass
- self._resource_packs = setup_resource_packs()
-
--- splash.py.orig 2016-01-03 17:30:26.530655811 -0600
+++ splash.py 2016-01-03 17:32:52.887326839 -0600
@@ -26,7 +26,7 @@