summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristopher Arndt2024-04-04 01:57:06 +0200
committerChristopher Arndt2024-04-04 01:57:06 +0200
commitf72026ab2e058f29c672152abda39ba6483dcc29 (patch)
tree809173b2505768734ceee430accd3125a767b7eb
parent4ec25871d4877d1c715ffac793baa46b3c3bf1a7 (diff)
downloadaur-mda-lv2-git.tar.gz
Updates due to upstream changes
* Updated project URL. * Updated `license` field to use SPDX identifier. * Upstream added 0BSD and MIT license. * Install license files. * Added `check()` function with `lv2lint` checks. Signed-off-by: Christopher Arndt <chris@chrisarndt.de>
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD31
2 files changed, 28 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3f76c7dbff64..15f3d4c67b01 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,14 @@
pkgbase = mda-lv2-git
pkgdesc = A port of the MDA VST plugins to the LV2 format (git version)
- pkgver = 1.2.10.r244.da3df70
+ pkgver = 1.2.10.r262.5101d1a
pkgrel = 1
- url = https://drobilla.net/software/mda-lv2/
+ url = http://drobilla.net/software/mda-lv2.html
arch = x86_64
groups = lv2-plugins
groups = pro-audio
- license = GPL2
+ license = 0BSD
+ license = GPL-2.0-or-later
+ license = MIT
makedepends = git
makedepends = lv2
makedepends = meson
diff --git a/PKGBUILD b/PKGBUILD
index 810fa2f23c2b..91e61e14b5d3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,13 +1,13 @@
# Maintainer: Christopher Arndt <aur -at- chrisarndt -dot- de>
_pkgname=mda-lv2
-pkgname="$_pkgname-git"
-pkgver=1.2.10.r244.da3df70
+pkgname=$_pkgname-git
+pkgver=1.2.10.r262.5101d1a
pkgrel=1
pkgdesc='A port of the MDA VST plugins to the LV2 format (git version)'
arch=(x86_64)
-url='https://drobilla.net/software/mda-lv2/'
-license=(GPL2)
+url='http://drobilla.net/software/mda-lv2.html'
+license=(0BSD GPL-2.0-or-later MIT)
groups=(lv2-plugins pro-audio)
depends=(gcc-libs glibc)
makedepends=(git lv2 meson python)
@@ -27,14 +27,29 @@ build() {
meson compile -C $_pkgname-build
}
-# tests require 'autoship', which is not packaged nor vendored in the project
-#check() {
-# meson test -C $_pkgname-build
-#}
+check() {
+ local _plugins _plugin
+ _plugins=(Ambience Bandisto BeatBox Combo DX10 DeEss Degrade Delay Detune
+ Dither DubDelay Dynamics EPiano Image JX10 Leslie Limiter Loudness MultiBand
+ Overdrive Piano RePsycho RezFilter RingMod RoundPan Shepard Splitter Stereo
+ SubSynth TalkBox TestTone ThruZero Tracker Transient VocInput Vocoder)
+
+ for _plugin in "${_plugins[@]}"; do
+ # NOTE: whitelist globally visible library: https://gitlab.com/drobilla/mda-lv2/-/issues/2
+ lv2lint -Mpack -s lvz_new_audioeffectx -I "$_pkgname-build/mda.lv2" \
+ "http://drobilla.net/plugins/mda/$_plugin"
+ done
+
+ # upstream tests require 'autoship', which is not packaged nor vendored in the project
+ #meson test -C $_pkgname-build
+}
+
+
package() {
meson install -C $_pkgname-build --destdir "$pkgdir"
install -vDm 644 $_pkgname/{NEWS,README.md} -t "$pkgdir"/usr/share/doc/$pkgname
+ install -vDm 644 $_pkgname/LICENSES/* -t "$pkgdir"/usr/share/licenses/$pkgname
}
# vim:set ts=2 sw=2 et: