summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGavin Lloyd2018-01-08 11:34:45 -0800
committerGavin Lloyd2018-01-08 11:34:45 -0800
commitbf6df55898c1150ca0ead52bfb5d498296dd4b58 (patch)
treee74575afd2960d97e28aeb197a58089c075042d4
downloadaur-bf6df55898c1150ca0ead52bfb5d498296dd4b58.tar.gz
Init commit
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD32
-rw-r--r--db-location.patch5
3 files changed, 57 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..245c681eb787
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+# Generated by mksrcinfo v8
+# Mon Jan 8 19:34:24 UTC 2018
+pkgbase = meanalyzer-git
+ pkgdesc = Intel Management Engine firmware analysis tool
+ pkgver = 1.38.1.r109.r0.gf38d9da
+ pkgrel = 1
+ url = https://github.com/platomav/MEAnalyzer
+ arch = any
+ license = GPL3
+ makedepends = dos2unix
+ depends = python-colorama
+ depends = python-prettytable
+ depends = python-huffman11-git
+ source = meanalyzer-git::git+https://github.com/platomav/MEAnalyzer#branch=master
+ source = db-location.patch
+ sha256sums = SKIP
+ sha256sums = 0d2808b009cd890025a1c3a9e07ee396a06a65f74fa5699518d1a9d90b353abb
+
+pkgname = meanalyzer-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..620ff957e3d8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Gavin Lloyd <gavinhungry@gmail.com>
+
+pkgname=meanalyzer-git
+pkgver=1.38.1.r109.r0.gf38d9da
+pkgrel=1
+pkgdesc='Intel Management Engine firmware analysis tool'
+arch=('any')
+url='https://github.com/platomav/MEAnalyzer'
+license=('GPL3')
+depends=('python-colorama' 'python-prettytable' 'python-huffman11-git')
+makedepends=('dos2unix')
+source=("${pkgname}::git+${url}#branch=master"
+ 'db-location.patch')
+sha256sums=('SKIP'
+ '0d2808b009cd890025a1c3a9e07ee396a06a65f74fa5699518d1a9d90b353abb')
+
+pkgver() {
+ cd "${srcdir}/${pkgname}"
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+prepare() {
+ cd "${srcdir}/${pkgname}"
+ patch -p0 < ../db-location.patch
+ dos2unix MEA.py
+}
+
+package() {
+ cd "${srcdir}/${pkgname}"
+ install -Dm644 MEA.dat "${pkgdir}"/usr/lib/meanalyzer/MEA.dat
+ install -Dm755 MEA.py "${pkgdir}"/usr/bin/meanalyzer
+}
diff --git a/db-location.patch b/db-location.patch
new file mode 100644
index 000000000000..bd11f1d0e9b1
--- /dev/null
+++ b/db-location.patch
@@ -0,0 +1,5 @@
+--- MEA.py.ORIG 2018-01-08 11:31:40.365724999 -0800
++++ MEA.py 2018-01-08 11:31:56.418737327 -0800
+@@ -4071 +4071 @@
+-db_path = mea_dir + os_dir + 'MEA.dat'
++db_path = '/usr/lib/meanalyzer/MEA.dat'