summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBailey Fox2019-03-12 02:35:10 -0500
committerBailey Fox2019-03-12 02:35:10 -0500
commitc4a4b82eccd166fe4985c646201ed1979d3ff51d (patch)
treea3e62a80aa423b8be8f8dabfcd6a79686cd3077d
parentbf6df55898c1150ca0ead52bfb5d498296dd4b58 (diff)
downloadaur-c4a4b82eccd166fe4985c646201ed1979d3ff51d.tar.gz
Update to work with latest upstream as of 2019-03-12
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD16
-rw-r--r--db-location.patch16
3 files changed, 27 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 245c681eb787..3709c8c2e6bd 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,21 @@
-# Generated by mksrcinfo v8
-# Mon Jan 8 19:34:24 UTC 2018
pkgbase = meanalyzer-git
pkgdesc = Intel Management Engine firmware analysis tool
- pkgver = 1.38.1.r109.r0.gf38d9da
+ pkgver = 1.82.3.r154.r0.d8d9dfd
pkgrel = 1
url = https://github.com/platomav/MEAnalyzer
arch = any
license = GPL3
makedepends = dos2unix
+ makedepends = git
depends = python-colorama
depends = python-prettytable
depends = python-huffman11-git
source = meanalyzer-git::git+https://github.com/platomav/MEAnalyzer#branch=master
source = db-location.patch
+ source = https://github.com/platomav/PTable/archive/boxchar.zip
sha256sums = SKIP
- sha256sums = 0d2808b009cd890025a1c3a9e07ee396a06a65f74fa5699518d1a9d90b353abb
+ sha256sums = d6c820300071011041654d4d076c0a3594ca1443e7c93894ae512535a0f38de7
+ sha256sums = d8783384fa8e2d84bbd641cf01438f40b29fecf88d79340551789b435333e8b4
pkgname = meanalyzer-git
diff --git a/PKGBUILD b/PKGBUILD
index 620ff957e3d8..d0260d0e253e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,18 +1,21 @@
+# Maintainer: Bailey Fox <bfox200012@gmail.com>
# Maintainer: Gavin Lloyd <gavinhungry@gmail.com>
pkgname=meanalyzer-git
-pkgver=1.38.1.r109.r0.gf38d9da
+pkgver=1.82.3.r154.r0.d8d9dfd
pkgrel=1
pkgdesc='Intel Management Engine firmware analysis tool'
arch=('any')
url='https://github.com/platomav/MEAnalyzer'
license=('GPL3')
depends=('python-colorama' 'python-prettytable' 'python-huffman11-git')
-makedepends=('dos2unix')
+makedepends=('dos2unix' 'git')
source=("${pkgname}::git+${url}#branch=master"
- 'db-location.patch')
+ 'db-location.patch'
+ 'https://github.com/platomav/PTable/archive/boxchar.zip')
sha256sums=('SKIP'
- '0d2808b009cd890025a1c3a9e07ee396a06a65f74fa5699518d1a9d90b353abb')
+ 'd6c820300071011041654d4d076c0a3594ca1443e7c93894ae512535a0f38de7'
+ 'd8783384fa8e2d84bbd641cf01438f40b29fecf88d79340551789b435333e8b4')
pkgver() {
cd "${srcdir}/${pkgname}"
@@ -21,11 +24,14 @@ pkgver() {
prepare() {
cd "${srcdir}/${pkgname}"
- patch -p0 < ../db-location.patch
+ patch -p0 --binary < ../db-location.patch
dos2unix MEA.py
}
package() {
+ cd "${srcdir}/PTable-boxchar"
+ python setup.py install --root="$pkgdir/" --optimize=1
+
cd "${srcdir}/${pkgname}"
install -Dm644 MEA.dat "${pkgdir}"/usr/lib/meanalyzer/MEA.dat
install -Dm755 MEA.py "${pkgdir}"/usr/bin/meanalyzer
diff --git a/db-location.patch b/db-location.patch
index bd11f1d0e9b1..c0bd40a40999 100644
--- a/db-location.patch
+++ b/db-location.patch
@@ -1,5 +1,11 @@
---- MEA.py.ORIG 2018-01-08 11:31:40.365724999 -0800
-+++ MEA.py 2018-01-08 11:31:56.418737327 -0800
-@@ -4071 +4071 @@
--db_path = mea_dir + os_dir + 'MEA.dat'
-+db_path = '/usr/lib/meanalyzer/MEA.dat'
+--- MEA.py
++++ MEA.py
+@@ -7110,7 +7110,7 @@
+ arg_num = len(sys.argv)
+
+ # Set dependencies paths
+-db_path = os.path.join(mea_dir, 'MEA.dat')
++db_path = '/usr/lib/meanalyzer/MEA.dat'
+
+ # Check if dependencies exist
+ depend_db = os.path.isfile(db_path)