summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorViktor Drobot2022-01-20 21:07:53 +0300
committerViktor Drobot2022-01-20 21:07:53 +0300
commit30ce10d817e0bb372312d07e7e170109ed17b045 (patch)
tree1eb49d9d97e59c31ccf2c42ede1e48f5d082be9a
parent18c929afefdb3488cb7802a8c6c4691cf1fc5510 (diff)
downloadaur-medet-git.tar.gz
Update pkgbuild
-rw-r--r--.SRCINFO1
-rw-r--r--PKGBUILD8
2 files changed, 4 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index dcb662b60c3c..3bddd87007ce 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -14,4 +14,3 @@ pkgbase = medet-git
sha256sums = SKIP
pkgname = medet-git
-
diff --git a/PKGBUILD b/PKGBUILD
index ad6fa450135a..38769453ab8d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,23 +5,23 @@ pkgver=r18.8021339
pkgrel=1
pkgdesc="A portable decoder for METEOR M weather satellite LRPT signal"
arch=(i686 x86_64)
-license=('GPL3')
+license=(GPL3)
url="https://github.com/artlav/meteor_decoder"
makedepends=(git fpc)
provides=(medet)
conflicts=(medet)
-source=("$pkgname::git+https://github.com/artlav/meteor_decoder.git")
+source=("${pkgname}::git+https://github.com/artlav/meteor_decoder.git")
sha256sums=('SKIP')
pkgver() {
cd "${pkgname}"
-
+
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
build() {
cd "${pkgname}"
-
+
mkdir units
fpc -CX -XX -O3 -Mdelphi -FUunits -Fualib medet.dpr
}