summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorOle Ernst2015-10-28 17:11:40 +0100
committerOle Ernst2015-10-28 17:11:40 +0100
commit7d24f3fafffc0f404f55268454a198bf096690d3 (patch)
tree5b69400d8d33143a2c9e6a19dcf3a9f159efd31e
parent16626ee7a1f3e77089357a6731febb42c2e055f1 (diff)
downloadaur-7d24f3fafffc0f404f55268454a198bf096690d3.tar.gz
upgpkg: 20151028-1
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD19
-rw-r--r--dma_buf_export.patch116
3 files changed, 10 insertions, 135 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7199f93e1aa7..e860410f8fd5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = media-build-dvbsky
pkgdesc = Driver for DVBSky cards/boxes
- pkgver = 20150322
- pkgrel = 5
+ pkgver = 20151028
+ pkgrel = 1
url = http://www.dvbsky.net/Support_linux.html
install = media-build-dvbsky.install
arch = i686
@@ -12,12 +12,10 @@ pkgbase = media-build-dvbsky
depends = dvbsky-firmware
conflicts = dvbsky-dvb-drivers
replaces = dvbsky-dvb-drivers
- source = http://dvbsky.net/download/linux/media_build-bst-150322.tar.gz
+ source = http://www.dvbsky.net/download/linux/media_build-bst-151028.tar.gz
source = add_c2800e.patch
- source = dma_buf_export.patch
- sha256sums = fd4acd06d2a4a5d5987393d68979aaf8832f5b21ae828ea6a50baca998cd89c7
+ sha256sums = 48a8726c6799025be06bc5b8bafa8449ca02abf8fe578e805f91707a5edf1e52
sha256sums = bdb4cb06418cb2e36eb3219b4d4be329d5297db1704e6e3ef0c73dd6bb9721f1
- sha256sums = da27997a54a1dd805c7177ccc930a86ae7d3042a46926f89109d2c692995329a
pkgname = media-build-dvbsky
diff --git a/PKGBUILD b/PKGBUILD
index 53ec39e2962f..217f82496b92 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Ole Ernst <olebowle[at]gmx[dot]com>
pkgname=media-build-dvbsky
-pkgver=20150322
-pkgrel=5
+pkgver=20151028
+pkgrel=1
pkgdesc="Driver for DVBSky cards/boxes"
arch=('i686' 'x86_64')
url="http://www.dvbsky.net/Support_linux.html"
@@ -11,24 +11,17 @@ makedepends=('linux-headers' 'perl-proc-processtable')
conflicts=('dvbsky-dvb-drivers')
replaces=('dvbsky-dvb-drivers')
install="$pkgname.install"
-source=("http://dvbsky.net/download/linux/media_build-bst-150322.tar.gz"
- 'add_c2800e.patch'
- 'dma_buf_export.patch')
-sha256sums=('fd4acd06d2a4a5d5987393d68979aaf8832f5b21ae828ea6a50baca998cd89c7'
- 'bdb4cb06418cb2e36eb3219b4d4be329d5297db1704e6e3ef0c73dd6bb9721f1'
- 'da27997a54a1dd805c7177ccc930a86ae7d3042a46926f89109d2c692995329a')
-
-#server doesn't like curl user agent
-DLAGENTS="$( IFS=$'\n'; echo "${DLAGENTS[*]}" | grep '^http::' ) --user-agent 'Mozilla/4.0'"
+source=("http://www.dvbsky.net/download/linux/media_build-bst-151028.tar.gz"
+ 'add_c2800e.patch')
+sha256sums=('48a8726c6799025be06bc5b8bafa8449ca02abf8fe578e805f91707a5edf1e52'
+ 'bdb4cb06418cb2e36eb3219b4d4be329d5297db1704e6e3ef0c73dd6bb9721f1')
prepare() {
cd "$srcdir/media_build-bst"
ln -sr v4l/sit2_op.o.x${CARCH: -2} v4l/sit2_op.o
cp v4l/sit2_mod.dvb linux/drivers/media/dvb-frontends/sit2_mod.c
- sed -i '/eth_rebuild_header/d' linux/drivers/media/dvb-core/dvb_net.c
sed -i '/depmod/d' v4l/Makefile v4l/scripts/make_makefile.pl
patch -p1 -i ../add_c2800e.patch
- patch -p1 -i ../dma_buf_export.patch
export _kernver=$(</usr/lib/modules/extramodules-[0-9]\.+([0-9])-ARCH/version)
sed -i "s/KERNEL_VERSION=.*/KERNEL_VERSION=$_kernver/" "$startdir/$install"
diff --git a/dma_buf_export.patch b/dma_buf_export.patch
deleted file mode 100644
index 5fb4f5490af7..000000000000
--- a/dma_buf_export.patch
+++ /dev/null
@@ -1,116 +0,0 @@
---- a/linux/include/linux/dma-buf.h
-+++ b/linux/include/linux/dma-buf.h
-@@ -163,6 +163,33 @@ struct dma_buf_attachment {
- };
-
- /**
-+ * struct dma_buf_export_info - holds information needed to export a dma_buf
-+ * @exp_name: name of the exporting module - useful for debugging.
-+ * @ops: Attach allocator-defined dma buf ops to the new buffer
-+ * @size: Size of the buffer
-+ * @flags: mode flags for the file
-+ * @resv: reservation-object, NULL to allocate default one
-+ * @priv: Attach private data of allocator to this buffer
-+ *
-+ * This structure holds the information required to export the buffer. Used
-+ * with dma_buf_export() only.
-+ */
-+struct dma_buf_export_info {
-+ const char *exp_name;
-+ const struct dma_buf_ops *ops;
-+ size_t size;
-+ int flags;
-+ struct reservation_object *resv;
-+ void *priv;
-+};
-+
-+/**
-+ * helper macro for exporters; zeros and fills in most common values
-+ */
-+#define DEFINE_DMA_BUF_EXPORT_INFO(a) \
-+ struct dma_buf_export_info a = { .exp_name = KBUILD_MODNAME }
-+
-+/**
- * get_dma_buf - convenience wrapper for get_file.
- * @dmabuf: [in] pointer to dma_buf
- *
-@@ -181,12 +208,7 @@ struct dma_buf_attachment *dma_buf_attac
- void dma_buf_detach(struct dma_buf *dmabuf,
- struct dma_buf_attachment *dmabuf_attach);
-
--struct dma_buf *dma_buf_export_named(void *priv, const struct dma_buf_ops *ops,
-- size_t size, int flags, const char *,
-- struct reservation_object *);
--
--#define dma_buf_export(priv, ops, size, flags, resv) \
-- dma_buf_export_named(priv, ops, size, flags, KBUILD_MODNAME, resv)
-+struct dma_buf *dma_buf_export(const struct dma_buf_export_info *exp_info);
-
- int dma_buf_fd(struct dma_buf *dmabuf, int flags);
- struct dma_buf *dma_buf_get(int fd);
---- a/linux/drivers/media/v4l2-core/videobuf2-dma-contig.c
-+++ b/linux/drivers/media/v4l2-core/videobuf2-dma-contig.c
-@@ -402,6 +402,12 @@ static struct dma_buf *vb2_dc_get_dmabuf
- {
- struct vb2_dc_buf *buf = buf_priv;
- struct dma_buf *dbuf;
-+ DEFINE_DMA_BUF_EXPORT_INFO(exp_info);
-+
-+ exp_info.ops = &vb2_dc_dmabuf_ops;
-+ exp_info.size = buf->size;
-+ exp_info.flags = flags;
-+ exp_info.priv = buf;
-
- if (!buf->sgt_base)
- buf->sgt_base = vb2_dc_get_base_sgt(buf);
-@@ -409,7 +415,7 @@ static struct dma_buf *vb2_dc_get_dmabuf
- if (WARN_ON(!buf->sgt_base))
- return NULL;
-
-- dbuf = dma_buf_export(buf, &vb2_dc_dmabuf_ops, buf->size, flags, NULL);
-+ dbuf = dma_buf_export(&exp_info);
- if (IS_ERR(dbuf))
- return NULL;
-
---- a/linux/drivers/media/v4l2-core/videobuf2-dma-sg.c
-+++ b/linux/drivers/media/v4l2-core/videobuf2-dma-sg.c
-@@ -583,11 +583,17 @@ static struct dma_buf *vb2_dma_sg_get_dm
- {
- struct vb2_dma_sg_buf *buf = buf_priv;
- struct dma_buf *dbuf;
-+ DEFINE_DMA_BUF_EXPORT_INFO(exp_info);
-+
-+ exp_info.ops = &vb2_dma_sg_dmabuf_ops;
-+ exp_info.size = buf->size;
-+ exp_info.flags = flags;
-+ exp_info.priv = buf;
-
- if (WARN_ON(!buf->dma_sgt))
- return NULL;
-
-- dbuf = dma_buf_export(buf, &vb2_dma_sg_dmabuf_ops, buf->size, flags, NULL);
-+ dbuf = dma_buf_export(&exp_info);
- if (IS_ERR(dbuf))
- return NULL;
-
---- a/linux/drivers/media/v4l2-core/videobuf2-vmalloc.c
-+++ b/linux/drivers/media/v4l2-core/videobuf2-vmalloc.c
-@@ -367,11 +367,17 @@ static struct dma_buf *vb2_vmalloc_get_d
- {
- struct vb2_vmalloc_buf *buf = buf_priv;
- struct dma_buf *dbuf;
-+ DEFINE_DMA_BUF_EXPORT_INFO(exp_info);
-+
-+ exp_info.ops = &vb2_vmalloc_dmabuf_ops;
-+ exp_info.size = buf->size;
-+ exp_info.flags = flags;
-+ exp_info.priv = buf;
-
- if (WARN_ON(!buf->vaddr))
- return NULL;
-
-- dbuf = dma_buf_export(buf, &vb2_vmalloc_dmabuf_ops, buf->size, flags, NULL);
-+ dbuf = dma_buf_export(&exp_info);
- if (IS_ERR(dbuf))
- return NULL;
-