summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorwillemw122024-03-03 20:24:26 +0100
committerwillemw122024-03-03 20:24:26 +0100
commite31c3b303d509af97531bd243b09531f87571997 (patch)
tree4396467392a5250fec0dfcd6809bc13ad980d857
parent462a62003af19339e4182a43caa3ce2a908b8ab5 (diff)
downloadaur-media-downloader-git.tar.gz
Switch to Qt 6
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD15
2 files changed, 9 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2ca72bfcc402..7af9adc71d61 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,13 @@
pkgbase = media-downloader-git
pkgdesc = GUI front-end for downloading media files (yt-dlp, youtube-dl, ...)
- pkgver = 2.5.0.r3.gb32364b
+ pkgver = 4.4.0.r0.gcef0edc
pkgrel = 1
url = https://github.com/mhogomchungu/media-downloader
arch = x86_64
license = GPL
makedepends = cmake
makedepends = git
- depends = qt5-base
+ depends = qt6-base
optdepends = aria2: download files
optdepends = wget: download files
optdepends = youtube-dl: download files
diff --git a/PKGBUILD b/PKGBUILD
index 5ff3d6b2a3d2..52d42e9680d1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,13 +1,13 @@
# Maintainer: willemw <willemw12@gmail.com>
pkgname=media-downloader-git
-pkgver=2.5.0.r3.gb32364b
+pkgver=4.4.0.r0.gcef0edc
pkgrel=1
-pkgdesc="GUI front-end for downloading media files (yt-dlp, youtube-dl, ...)"
-arch=('x86_64')
-url="https://github.com/mhogomchungu/media-downloader"
-license=('GPL')
-depends=('qt5-base')
+pkgdesc='GUI front-end for downloading media files (yt-dlp, youtube-dl, ...)'
+arch=(x86_64)
+url=https://github.com/mhogomchungu/media-downloader
+license=(GPL)
+depends=(qt6-base)
makedepends=('cmake' 'git')
optdepends=('aria2: download files'
'wget: download files'
@@ -23,11 +23,10 @@ pkgver() {
}
build() {
- cmake -B build -S $pkgname -DCMAKE_BUILD_TYPE=None -DCMAKE_INSTALL_PREFIX=/usr -Wno-dev
+ cmake -B build -S $pkgname -DBUILD_WITH_QT6=1 -DCMAKE_BUILD_TYPE=None -DCMAKE_INSTALL_PREFIX=/usr -Wno-dev
make -C build
}
package() {
make -C build DESTDIR="$pkgdir/" install
}
-