aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorarchimede2018-02-11 15:24:38 +0800
committerarchimede2018-02-11 15:24:38 +0800
commitdeadbb4046064d335d8894798849b5c5aa33a616 (patch)
treed4dc75bbce36b149466de686c3cb87cb0c92f83a
parent8aeb3ea776c398b9658577daae4136fa397dc68a (diff)
downloadaur-deadbb4046064d335d8894798849b5c5aa33a616.tar.gz
make install in /lib and /bin, but pacman does not like that, as they are symlink. hence move them to /usr/lib and /usr/bin
-rw-r--r--PKGBUILD6
1 files changed, 5 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index acd76e91bd61..043ef1c95345 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Archimede Pitagorico <archimede.pitagorico@mail.com>
pkgname=megasync-headless
-pkgver=v3.3.1.1.gbcfd5fd9
+pkgver=v3.3.1.1.gf4ba4aec
pkgrel=1
pkgdesc="Sync with MEGA. Daemon, fuse and cli client. Original sdk (git)."
arch=('x86_64')
@@ -68,4 +68,8 @@ package() {
mkdir -p "${pkgdir}/srv/mega"
mkdir -p "${pkgdir}/var/mega"
chmod 0700 "${pkgdir}/var/mega"
+ # pacman does not like /lib and /bin, because they are symlink, so move them to /usr/lib and /usr/bin
+ cp -R ${pkgdir}/lib/* ${pkgdir}/usr/lib
+ rm -rf ${pkgdir}/lib
+ mv ${pkgdir}/bin ${pkgdir}/usr
}