summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEivind Eide2020-01-09 04:39:42 +0100
committerEivind Eide2020-01-09 04:39:42 +0100
commit82a4c04f129804be321d1df44307063844ce4aad (patch)
tree085cc24fcccc090d8b5c248cfd5e68344be48f4d
downloadaur-members.tar.gz
'members is the complement of groups', old program from Debian.
-rw-r--r--.SRCINFO15
-rw-r--r--LICENSE21
-rw-r--r--PKGBUILD31
3 files changed, 67 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2a8671e22835
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = members
+ pkgdesc = Shows the members of a group; by default, all members
+ pkgver = 20080128
+ pkgrel = 1
+ url = https://packages.qa.debian.org/m/members.html
+ arch = x86_64
+ license = GPL
+ depends = gcc-libs
+ source = http://ftp.de.debian.org/debian/pool/main/m/members/members_20080128.1+nmu1.tar.xz
+ source = LICENSE
+ sha256sums = 334fed53fd3698f6fb644188550e0ff91769c63606bc189dd7a4380a3e6f8160
+ sha256sums = c4855f8626ae06af0301e2d373832d0c27b8aa8db34457c3a3a7d334927e2fc0
+
+pkgname = members
+
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..c97bf5b4939b
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,21 @@
+ Copyright (c) 1997 by Jim Lynch.
+ This software comes with NO WARRANTY WHATSOEVER.
+
+ This program is free software; you can redistribute it and/or modify
+ it under the terms of the GNU General Public License as published by
+ the Free Software Foundation; version 2 dated June, 1991, or, at your
+ option, any LATER version.
+
+ This program is distributed in the hope that it will be useful,
+ but WITHOUT ANY WARRANTY; without even the implied warranty of
+ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+ GNU General Public License for more details.
+
+ You should have received a copy of the GNU General Public License
+ along with this program; if not, write to the Free Software
+ Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
+
+ On Debian Linux systems, the complete text of the GNU General
+ Public License can be found in `/usr/doc/copyright/GPL' (on some
+ installations) or /usr/share/common-licenses/GPL (on newer
+ ones).
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6a21754430d0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Eivind Eide <xenofil AT gmail DOT com>
+# Contributor: Jim Pryor <jim AT jimpryor DOT net>
+
+pkgname=members
+pkgver=20080128
+pkgrel=1
+pkgdesc="Shows the members of a group; by default, all members"
+arch=('x86_64')
+depends=('gcc-libs')
+url='https://packages.qa.debian.org/m/members.html'
+license=('GPL')
+
+source=("http://ftp.de.debian.org/debian/pool/main/m/members/${pkgname}_${pkgver}.1+nmu1.tar.xz"
+ 'LICENSE')
+sha256sums=('334fed53fd3698f6fb644188550e0ff91769c63606bc189dd7a4380a3e6f8160'
+ 'c4855f8626ae06af0301e2d373832d0c27b8aa8db34457c3a3a7d334927e2fc0')
+
+build() {
+ cd "${pkgname}-${pkgver}.1+nmu1"
+
+ make
+}
+
+package() {
+ cd "${pkgname}-${pkgver}.1+nmu1"
+
+ install -D -m 755 members -t "${pkgdir}/usr/bin"
+ install -D -m 644 members.1 -t "${pkgdir}/usr/share/man/man1"
+ install -D -m 644 "${srcdir}/LICENSE" -t "${pkgdir}/usr/share/licenses/${pkgname}"
+}
+