summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorxiota2024-04-19 07:10:34 +0000
committerxiota2024-04-19 07:10:34 +0000
commit7fcaf1361f2f64a9018f6fd32fd26862fcb523d4 (patch)
tree09d0311e874d4636398f471b785cffadcfa93bd7
parent4b289205bce39411037160db1ad1e02fde24ce69 (diff)
downloadaur-mercury-browser-bin.tar.gz
remove optdeps
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD27
-rw-r--r--PKGBUILD.avx27
-rw-r--r--PKGBUILD.avx227
-rw-r--r--PKGBUILD.sse327
-rw-r--r--PKGBUILD.sse427
6 files changed, 50 insertions, 89 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1380bbd8d43c..871901b37dd8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -6,10 +6,6 @@ pkgbase = mercury-browser-bin
install = mercury-browser.install
arch = x86_64
license = MPL-2.0
- optdepends = ffmpeg: H264/AAC/MP3 decoding
- optdepends = hunspell: Spell checking
- optdepends = hyphen: Hyphenation
- optdepends = networkmanager: Location detection via available WiFi networks
noextract = mercury-browser_123.0.1_SSE3.deb
options = !emptydirs
options = !strip
diff --git a/PKGBUILD b/PKGBUILD
index 16bb72140814..d9c2bf5c4a4a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: Alexey Peschany <archlinux at sandboiii dot xyz>
# options
-if [ -n "$_srcinfo" ] || [ -n "$_pkgver" ] ; then
+if [ -n "$_srcinfo" ] || [ -n "$_pkgver" ]; then
: ${_autoupdate:=false}
else
: ${_autoupdate:=true}
@@ -24,13 +24,6 @@ arch=('x86_64')
_main_package() {
_update_version
- optdepends=(
- 'ffmpeg: H264/AAC/MP3 decoding'
- 'hunspell: Spell checking'
- 'hyphen: Hyphenation'
- 'networkmanager: Location detection via available WiFi networks'
- )
-
options=('!emptydirs' '!strip')
install="$_pkgname.install"
@@ -49,7 +42,7 @@ pkgver() {
prepare() {
# desktop
- install -Dvm644 /dev/stdin "$_pkgname.desktop" <<END
+ install -Dvm644 /dev/stdin "$_pkgname.desktop" << END
[Desktop Entry]
Version=1.0
Name=Mercury
@@ -80,7 +73,7 @@ Name=Open With Temporary User Profile
Exec=$_pkgname --temp-profile
END
- install -Dvm644 /dev/stdin "$_pkgname.sh" <<END
+ install -Dvm644 /dev/stdin "$_pkgname.sh" << END
#!/usr/bin/env bash
# check microprocessor architecture level
@@ -146,11 +139,11 @@ package() {
)
local _filetype="zip"
- if bsdtar -xf "$_dl_filename" -- data.tar.* &> /dev/null ; then
+ if bsdtar -xf "$_dl_filename" -- data.tar.* &> /dev/null; then
_filetype="deb"
fi
- if [[ "${_filetype::1}" == 'z' ]] ; then
+ if [[ "${_filetype::1}" == 'z' ]]; then
_package_zip
else
_package_deb
@@ -161,7 +154,7 @@ package() {
install -Dm755 "$_pkgname.sh" "$pkgdir/usr/bin/$_pkgname"
# icon
- install -Dm644 "$pkgdir/opt/$_pkgname/browser/chrome/icons/default/default128.png" "$pkgdir/usr/share/pixmaps/$_pkgname.png"
+ install -Dm644 "$pkgdir/opt/$_pkgname/browser/chrome/icons/default/default128.png" "$pkgdir/usr/share/pixmaps/$_pkgname.png"
# .desktop
\rm -rf "$pkgdir/usr/share/applications/mercury-browser.desktop"
@@ -207,7 +200,7 @@ _package_zip() {
_update_version() {
: ${_pkgver:=${pkgver%%.r*}}
- if [[ "${_autoupdate::1}" != "t" ]] ; then
+ if [[ "${_autoupdate::1}" != "t" ]]; then
return
fi
@@ -223,14 +216,14 @@ _update_version() {
| sed -E 's@^.*/releases/tag/(.*)".*$@\1@' \
| grep -Ev '[a-z]{2}'
)
- for i in "${_blacklist[@]}" ; do
- _tags=${_tags/$i}
+ for i in "${_blacklist[@]}"; do
+ _tags=${_tags/$i/}
done
_tag=$(printf '%s' "$_tags" | sort -rV | head -1)
_pkgver_new="${_tag#v.}"
# update _pkgver
- if [ "$_pkgver" != "${_pkgver_new:?}" ] ; then
+ if [ "$_pkgver" != "${_pkgver_new:?}" ]; then
_pkgver="${_pkgver_new:?}"
fi
}
diff --git a/PKGBUILD.avx b/PKGBUILD.avx
index 66aa6865e024..25ecd357c8b2 100644
--- a/PKGBUILD.avx
+++ b/PKGBUILD.avx
@@ -1,7 +1,7 @@
# Maintainer:
# options
-if [ -n "$_srcinfo" ] || [ -n "$_pkgver" ] ; then
+if [ -n "$_srcinfo" ] || [ -n "$_pkgver" ]; then
: ${_autoupdate:=false}
else
: ${_autoupdate:=true}
@@ -23,13 +23,6 @@ arch=('x86_64')
_main_package() {
_update_version
- optdepends=(
- 'ffmpeg: H264/AAC/MP3 decoding'
- 'hunspell: Spell checking'
- 'hyphen: Hyphenation'
- 'networkmanager: Location detection via available WiFi networks'
- )
-
options=('!emptydirs' '!strip')
: ${_dl_filename:=${_pkgname%-avx}_${_pkgver:?}_AVX.deb}
@@ -47,7 +40,7 @@ pkgver() {
prepare() {
# desktop
- install -Dvm644 /dev/stdin "$_pkgname.desktop" <<END
+ install -Dvm644 /dev/stdin "$_pkgname.desktop" << END
[Desktop Entry]
Version=1.0
Name=Mercury
@@ -78,7 +71,7 @@ Name=Open With Temporary User Profile
Exec=$_pkgname --temp-profile
END
- install -Dvm644 /dev/stdin "$_pkgname.sh" <<END
+ install -Dvm644 /dev/stdin "$_pkgname.sh" << END
#!/usr/bin/env bash
# check microprocessor architecture level
@@ -144,11 +137,11 @@ package() {
)
local _filetype="zip"
- if bsdtar -xf "$_dl_filename" -- data.tar.* &> /dev/null ; then
+ if bsdtar -xf "$_dl_filename" -- data.tar.* &> /dev/null; then
_filetype="deb"
fi
- if [[ "${_filetype::1}" == 'z' ]] ; then
+ if [[ "${_filetype::1}" == 'z' ]]; then
_package_zip
else
_package_deb
@@ -159,7 +152,7 @@ package() {
install -Dm755 "$_pkgname.sh" "$pkgdir/usr/bin/$_pkgname"
# icon
- install -Dm644 "$pkgdir/opt/$_pkgname/browser/chrome/icons/default/default128.png" "$pkgdir/usr/share/pixmaps/$_pkgname.png"
+ install -Dm644 "$pkgdir/opt/$_pkgname/browser/chrome/icons/default/default128.png" "$pkgdir/usr/share/pixmaps/$_pkgname.png"
# .desktop
\rm -rf "$pkgdir/usr/share/applications/mercury-browser.desktop"
@@ -205,7 +198,7 @@ _package_zip() {
_update_version() {
: ${_pkgver:=${pkgver%%.r*}}
- if [[ "${_autoupdate::1}" != "t" ]] ; then
+ if [[ "${_autoupdate::1}" != "t" ]]; then
return
fi
@@ -221,14 +214,14 @@ _update_version() {
| sed -E 's@^.*/releases/tag/(.*)".*$@\1@' \
| grep -Ev '[a-z]{2}'
)
- for i in "${_blacklist[@]}" ; do
- _tags=${_tags/$i}
+ for i in "${_blacklist[@]}"; do
+ _tags=${_tags/$i/}
done
_tag=$(printf '%s' "$_tags" | sort -rV | head -1)
_pkgver_new="${_tag#v.}"
# update _pkgver
- if [ "$_pkgver" != "${_pkgver_new:?}" ] ; then
+ if [ "$_pkgver" != "${_pkgver_new:?}" ]; then
_pkgver="${_pkgver_new:?}"
fi
}
diff --git a/PKGBUILD.avx2 b/PKGBUILD.avx2
index 40b23b426e41..ac32b9bfa8fa 100644
--- a/PKGBUILD.avx2
+++ b/PKGBUILD.avx2
@@ -1,7 +1,7 @@
# Maintainer:
# options
-if [ -n "$_srcinfo" ] || [ -n "$_pkgver" ] ; then
+if [ -n "$_srcinfo" ] || [ -n "$_pkgver" ]; then
: ${_autoupdate:=false}
else
: ${_autoupdate:=true}
@@ -23,13 +23,6 @@ arch=('x86_64')
_main_package() {
_update_version
- optdepends=(
- 'ffmpeg: H264/AAC/MP3 decoding'
- 'hunspell: Spell checking'
- 'hyphen: Hyphenation'
- 'networkmanager: Location detection via available WiFi networks'
- )
-
options=('!emptydirs' '!strip')
: ${_dl_filename:=${_pkgname%-avx2}_${_pkgver:?}_AVX2.deb}
@@ -47,7 +40,7 @@ pkgver() {
prepare() {
# desktop
- install -Dvm644 /dev/stdin "$_pkgname.desktop" <<END
+ install -Dvm644 /dev/stdin "$_pkgname.desktop" << END
[Desktop Entry]
Version=1.0
Name=Mercury
@@ -78,7 +71,7 @@ Name=Open With Temporary User Profile
Exec=$_pkgname --temp-profile
END
- install -Dvm644 /dev/stdin "$_pkgname.sh" <<END
+ install -Dvm644 /dev/stdin "$_pkgname.sh" << END
#!/usr/bin/env bash
# check microprocessor architecture level
@@ -144,11 +137,11 @@ package() {
)
local _filetype="zip"
- if bsdtar -xf "$_dl_filename" -- data.tar.* &> /dev/null ; then
+ if bsdtar -xf "$_dl_filename" -- data.tar.* &> /dev/null; then
_filetype="deb"
fi
- if [[ "${_filetype::1}" == 'z' ]] ; then
+ if [[ "${_filetype::1}" == 'z' ]]; then
_package_zip
else
_package_deb
@@ -159,7 +152,7 @@ package() {
install -Dm755 "$_pkgname.sh" "$pkgdir/usr/bin/$_pkgname"
# icon
- install -Dm644 "$pkgdir/opt/$_pkgname/browser/chrome/icons/default/default128.png" "$pkgdir/usr/share/pixmaps/$_pkgname.png"
+ install -Dm644 "$pkgdir/opt/$_pkgname/browser/chrome/icons/default/default128.png" "$pkgdir/usr/share/pixmaps/$_pkgname.png"
# .desktop
\rm -rf "$pkgdir/usr/share/applications/mercury-browser.desktop"
@@ -205,7 +198,7 @@ _package_zip() {
_update_version() {
: ${_pkgver:=${pkgver%%.r*}}
- if [[ "${_autoupdate::1}" != "t" ]] ; then
+ if [[ "${_autoupdate::1}" != "t" ]]; then
return
fi
@@ -221,14 +214,14 @@ _update_version() {
| sed -E 's@^.*/releases/tag/(.*)".*$@\1@' \
| grep -Ev '[a-z]{2}'
)
- for i in "${_blacklist[@]}" ; do
- _tags=${_tags/$i}
+ for i in "${_blacklist[@]}"; do
+ _tags=${_tags/$i/}
done
_tag=$(printf '%s' "$_tags" | sort -rV | head -1)
_pkgver_new="${_tag#v.}"
# update _pkgver
- if [ "$_pkgver" != "${_pkgver_new:?}" ] ; then
+ if [ "$_pkgver" != "${_pkgver_new:?}" ]; then
_pkgver="${_pkgver_new:?}"
fi
}
diff --git a/PKGBUILD.sse3 b/PKGBUILD.sse3
index 63fddc9f738c..f661210ac407 100644
--- a/PKGBUILD.sse3
+++ b/PKGBUILD.sse3
@@ -1,7 +1,7 @@
# Maintainer:
# options
-if [ -n "$_srcinfo" ] || [ -n "$_pkgver" ] ; then
+if [ -n "$_srcinfo" ] || [ -n "$_pkgver" ]; then
: ${_autoupdate:=false}
else
: ${_autoupdate:=true}
@@ -23,13 +23,6 @@ arch=('x86_64')
_main_package() {
_update_version
- optdepends=(
- 'ffmpeg: H264/AAC/MP3 decoding'
- 'hunspell: Spell checking'
- 'hyphen: Hyphenation'
- 'networkmanager: Location detection via available WiFi networks'
- )
-
options=('!emptydirs' '!strip')
: ${_dl_filename:=${_pkgname%-sse3}_${_pkgver:?}_SSE3.deb}
@@ -47,7 +40,7 @@ pkgver() {
prepare() {
# desktop
- install -Dvm644 /dev/stdin "$_pkgname.desktop" <<END
+ install -Dvm644 /dev/stdin "$_pkgname.desktop" << END
[Desktop Entry]
Version=1.0
Name=Mercury
@@ -78,7 +71,7 @@ Name=Open With Temporary User Profile
Exec=$_pkgname --temp-profile
END
- install -Dvm644 /dev/stdin "$_pkgname.sh" <<END
+ install -Dvm644 /dev/stdin "$_pkgname.sh" << END
#!/usr/bin/env bash
# check microprocessor architecture level
@@ -144,11 +137,11 @@ package() {
)
local _filetype="zip"
- if bsdtar -xf "$_dl_filename" -- data.tar.* &> /dev/null ; then
+ if bsdtar -xf "$_dl_filename" -- data.tar.* &> /dev/null; then
_filetype="deb"
fi
- if [[ "${_filetype::1}" == 'z' ]] ; then
+ if [[ "${_filetype::1}" == 'z' ]]; then
_package_zip
else
_package_deb
@@ -159,7 +152,7 @@ package() {
install -Dm755 "$_pkgname.sh" "$pkgdir/usr/bin/$_pkgname"
# icon
- install -Dm644 "$pkgdir/opt/$_pkgname/browser/chrome/icons/default/default128.png" "$pkgdir/usr/share/pixmaps/$_pkgname.png"
+ install -Dm644 "$pkgdir/opt/$_pkgname/browser/chrome/icons/default/default128.png" "$pkgdir/usr/share/pixmaps/$_pkgname.png"
# .desktop
\rm -rf "$pkgdir/usr/share/applications/mercury-browser.desktop"
@@ -205,7 +198,7 @@ _package_zip() {
_update_version() {
: ${_pkgver:=${pkgver%%.r*}}
- if [[ "${_autoupdate::1}" != "t" ]] ; then
+ if [[ "${_autoupdate::1}" != "t" ]]; then
return
fi
@@ -221,14 +214,14 @@ _update_version() {
| sed -E 's@^.*/releases/tag/(.*)".*$@\1@' \
| grep -Ev '[a-z]{2}'
)
- for i in "${_blacklist[@]}" ; do
- _tags=${_tags/$i}
+ for i in "${_blacklist[@]}"; do
+ _tags=${_tags/$i/}
done
_tag=$(printf '%s' "$_tags" | sort -rV | head -1)
_pkgver_new="${_tag#v.}"
# update _pkgver
- if [ "$_pkgver" != "${_pkgver_new:?}" ] ; then
+ if [ "$_pkgver" != "${_pkgver_new:?}" ]; then
_pkgver="${_pkgver_new:?}"
fi
}
diff --git a/PKGBUILD.sse4 b/PKGBUILD.sse4
index 62157c895fce..f5dbcb590b8a 100644
--- a/PKGBUILD.sse4
+++ b/PKGBUILD.sse4
@@ -1,7 +1,7 @@
# Maintainer:
# options
-if [ -n "$_srcinfo" ] || [ -n "$_pkgver" ] ; then
+if [ -n "$_srcinfo" ] || [ -n "$_pkgver" ]; then
: ${_autoupdate:=false}
else
: ${_autoupdate:=true}
@@ -23,13 +23,6 @@ arch=('x86_64')
_main_package() {
_update_version
- optdepends=(
- 'ffmpeg: H264/AAC/MP3 decoding'
- 'hunspell: Spell checking'
- 'hyphen: Hyphenation'
- 'networkmanager: Location detection via available WiFi networks'
- )
-
options=('!emptydirs' '!strip')
: ${_dl_filename:=${_pkgname%-sse4}_${_pkgver:?}_SSE4.deb}
@@ -47,7 +40,7 @@ pkgver() {
prepare() {
# desktop
- install -Dvm644 /dev/stdin "$_pkgname.desktop" <<END
+ install -Dvm644 /dev/stdin "$_pkgname.desktop" << END
[Desktop Entry]
Version=1.0
Name=Mercury
@@ -78,7 +71,7 @@ Name=Open With Temporary User Profile
Exec=$_pkgname --temp-profile
END
- install -Dvm644 /dev/stdin "$_pkgname.sh" <<END
+ install -Dvm644 /dev/stdin "$_pkgname.sh" << END
#!/usr/bin/env bash
# check microprocessor architecture level
@@ -144,11 +137,11 @@ package() {
)
local _filetype="zip"
- if bsdtar -xf "$_dl_filename" -- data.tar.* &> /dev/null ; then
+ if bsdtar -xf "$_dl_filename" -- data.tar.* &> /dev/null; then
_filetype="deb"
fi
- if [[ "${_filetype::1}" == 'z' ]] ; then
+ if [[ "${_filetype::1}" == 'z' ]]; then
_package_zip
else
_package_deb
@@ -159,7 +152,7 @@ package() {
install -Dm755 "$_pkgname.sh" "$pkgdir/usr/bin/$_pkgname"
# icon
- install -Dm644 "$pkgdir/opt/$_pkgname/browser/chrome/icons/default/default128.png" "$pkgdir/usr/share/pixmaps/$_pkgname.png"
+ install -Dm644 "$pkgdir/opt/$_pkgname/browser/chrome/icons/default/default128.png" "$pkgdir/usr/share/pixmaps/$_pkgname.png"
# .desktop
\rm -rf "$pkgdir/usr/share/applications/mercury-browser.desktop"
@@ -205,7 +198,7 @@ _package_zip() {
_update_version() {
: ${_pkgver:=${pkgver%%.r*}}
- if [[ "${_autoupdate::1}" != "t" ]] ; then
+ if [[ "${_autoupdate::1}" != "t" ]]; then
return
fi
@@ -221,14 +214,14 @@ _update_version() {
| sed -E 's@^.*/releases/tag/(.*)".*$@\1@' \
| grep -Ev '[a-z]{2}'
)
- for i in "${_blacklist[@]}" ; do
- _tags=${_tags/$i}
+ for i in "${_blacklist[@]}"; do
+ _tags=${_tags/$i/}
done
_tag=$(printf '%s' "$_tags" | sort -rV | head -1)
_pkgver_new="${_tag#v.}"
# update _pkgver
- if [ "$_pkgver" != "${_pkgver_new:?}" ] ; then
+ if [ "$_pkgver" != "${_pkgver_new:?}" ]; then
_pkgver="${_pkgver_new:?}"
fi
}