summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLone_Wolf2022-04-30 18:22:34 +0200
committerLone_Wolf2022-04-30 18:22:34 +0200
commit6e37c263e61e864be414b4e06cbd4e4bd4e65ded (patch)
tree7c22f030abc52494bf1ff730d30171f114a4d5f3
parent35280519f61576cb8dc24faf785ff6d1691e2ca0 (diff)
downloadaur-6e37c263e61e864be414b4e06cbd4e4bd4e65ded.tar.gz
added patches for 2 build failures, re-enabled clover.
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD30
-rw-r--r--gallium-clover: LLVM setLangDefaults moved from clangFrontend to clangBasic.patch29
-rw-r--r--workaround--LLVM15-FTBFS-no-more-Coroutines.h.patch15
4 files changed, 76 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4acb25589d73..9d8c33c56c0c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = mesa-minimal-git
pkgdesc = an open-source implementation of the OpenGL specification, stripped down git version
- pkgver = 22.1.0_devel.150239.bc638025964
- pkgrel = 1
+ pkgver = 22.2.0_devel.153077.2f8123abab7
+ pkgrel = 2
url = https://www.mesa3d.org
arch = x86_64
license = custom
@@ -14,13 +14,13 @@ pkgbase = mesa-minimal-git
makedepends = libva
makedepends = elfutils
makedepends = libxrandr
- makedepends = ocl-icd
makedepends = wayland-protocols
makedepends = meson
makedepends = ninja
makedepends = glslang
makedepends = llvm-minimal-git
makedepends = libdrm
+ makedepends = libclc
optdepends = opengl-man-pages: for the OpenGL API man pages
provides = mesa
provides = vulkan-intel
@@ -30,6 +30,8 @@ pkgbase = mesa-minimal-git
provides = vulkan-swrast
provides = vulkan-driver
provides = opengl-driver
+ provides = opencl-mesa
+ provides = opencl-driver
conflicts = mesa
conflicts = opencl-mesa
conflicts = vulkan-intel
@@ -40,10 +42,16 @@ pkgbase = mesa-minimal-git
conflicts = mesa-vdpau
source = mesa::git+https://gitlab.freedesktop.org/mesa/mesa.git
source = LICENSE
+ source = workaround--LLVM15-FTBFS-no-more-Coroutines.h.patch
+ source = gallium-clover: LLVM setLangDefaults moved from clangFrontend to clangBasic.patch
md5sums = SKIP
md5sums = 5c65a0fe315dd347e09b1f2826a1df5a
+ md5sums = a4e1e8a8a90b6434b80d8ec859747e0c
+ md5sums = c89665c4dd4e98ab9447cb3df371ef1c
sha512sums = SKIP
sha512sums = 25da77914dded10c1f432ebcbf29941124138824ceecaf1367b3deedafaecabc082d463abcfa3d15abff59f177491472b505bcb5ba0c4a51bb6b93b4721a23c2
+ sha512sums = ee96c9c3c29cfd7bffc1ee72fecf6bdd9a4ac7245afa11e7b28432e8695fc9d16d241cb8330029e5460cc54898258b87bc73d99fc1bf9743ce9bb718a85f5806
+ sha512sums = 40af0496e6829ecf820104e5f241dfe06cd62479dceb591668e325c6a2fb9fd95b5c60971038de40ebd84d864988e1ae44fa1b743fbecb73d60479d1541937b4
pkgname = mesa-minimal-git
depends = libdrm
@@ -58,3 +66,4 @@ pkgname = mesa-minimal-git
depends = vulkan-icd-loader
depends = zstd
depends = llvm-libs-minimal-git
+ depends = libclc
diff --git a/PKGBUILD b/PKGBUILD
index 32e6397cc4eb..a1b0881ef6a9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -12,27 +12,31 @@
pkgname=mesa-minimal-git
pkgdesc="an open-source implementation of the OpenGL specification, stripped down git version"
-pkgver=22.1.0_devel.150239.bc638025964
-pkgrel=1
+pkgver=22.2.0_devel.153077.2f8123abab7
+pkgrel=2
arch=('x86_64')
makedepends=('git' 'python-mako' 'xorgproto' 'libxml2' 'libx11' 'libvdpau' 'libva' 'elfutils' 'libxrandr'
- 'ocl-icd' 'wayland-protocols' 'meson' 'ninja' 'glslang' 'llvm-minimal-git' 'libdrm')
+ 'wayland-protocols' 'meson' 'ninja' 'glslang' 'llvm-minimal-git' 'libdrm' 'libclc')
# In order to keep the package simple and ease troubleshooting only use one llvm implementation
optdepends=('opengl-man-pages: for the OpenGL API man pages')
-provides=('mesa' 'vulkan-intel' 'vulkan-radeon' 'vulkan-mesa-layer' 'libva-mesa-driver' 'vulkan-swrast' 'vulkan-driver' 'opengl-driver')
+provides=('mesa' 'vulkan-intel' 'vulkan-radeon' 'vulkan-mesa-layer' 'libva-mesa-driver' 'vulkan-swrast' 'vulkan-driver' 'opengl-driver' 'opencl-mesa' 'opencl-driver')
conflicts=('mesa' 'opencl-mesa' 'vulkan-intel' 'vulkan-radeon' 'vulkan-mesa-layer' 'libva-mesa-driver' 'vulkan-swrast' 'mesa-vdpau')
# mixing components from different mesa versions is a bad idea, conflict with everything unique provided by extra/mesa
url="https://www.mesa3d.org"
license=('custom')
source=('mesa::git+https://gitlab.freedesktop.org/mesa/mesa.git'
'LICENSE'
+ 'workaround--LLVM15-FTBFS-no-more-Coroutines.h.patch'
+ 'gallium-clover: LLVM setLangDefaults moved from clangFrontend to clangBasic.patch'
)
md5sums=('SKIP'
'5c65a0fe315dd347e09b1f2826a1df5a'
-)
+ 'a4e1e8a8a90b6434b80d8ec859747e0c'
+ 'c89665c4dd4e98ab9447cb3df371ef1c')
sha512sums=('SKIP'
'25da77914dded10c1f432ebcbf29941124138824ceecaf1367b3deedafaecabc082d463abcfa3d15abff59f177491472b505bcb5ba0c4a51bb6b93b4721a23c2'
-)
+ 'ee96c9c3c29cfd7bffc1ee72fecf6bdd9a4ac7245afa11e7b28432e8695fc9d16d241cb8330029e5460cc54898258b87bc73d99fc1bf9743ce9bb718a85f5806'
+ '40af0496e6829ecf820104e5f241dfe06cd62479dceb591668e325c6a2fb9fd95b5c60971038de40ebd84d864988e1ae44fa1b743fbecb73d60479d1541937b4')
# ninja grabs all available cores and leaves almost nothing for other processes.
# this package uses the environment variable NINJAFLAGS to allow the user to change this behaviour
@@ -51,6 +55,12 @@ prepare() {
if [ -d _build ]; then
rm -rf _build
fi
+
+ # see https://gitlab.freedesktop.org/mesa/mesa/-/issues/6359
+ patch --directory="mesa" --forward --strip=1 --input="${srcdir}/workaround--LLVM15-FTBFS-no-more-Coroutines.h.patch"
+
+ # see https://gitlab.freedesktop.org/mesa/mesa/-/issues/6333
+ patch --directory="mesa" --forward --strip=1 --input="${srcdir}/gallium-clover: LLVM setLangDefaults moved from clangFrontend to clangBasic.patch"
}
build () {
@@ -84,21 +94,21 @@ build () {
-D lmsensors=enabled \
-D osmesa=false \
-D shared-glapi=enabled \
- -D gallium-opencl=disabled \
+ -D gallium-opencl=icd \
-D valgrind=disabled \
-D vulkan-layers=device-select,overlay \
-D tools=[] \
-D zstd=enabled \
- -D microsoft-clc=disabled
+ -D microsoft-clc=disabled \
meson configure _build
-
+# ninja -j1 -C _build
ninja $NINJAFLAGS -C _build
}
package() {
depends=('libdrm' 'libxxf86vm' 'libxdamage' 'libxshmfence' 'libelf'
- 'libunwind' 'libglvnd' 'wayland' 'lm_sensors' 'vulkan-icd-loader' 'zstd' 'llvm-libs-minimal-git')
+ 'libunwind' 'libglvnd' 'wayland' 'lm_sensors' 'vulkan-icd-loader' 'zstd' 'llvm-libs-minimal-git' 'libclc')
DESTDIR="${pkgdir}" ninja $NINJAFLAGS -C _build install
diff --git a/gallium-clover: LLVM setLangDefaults moved from clangFrontend to clangBasic.patch b/gallium-clover: LLVM setLangDefaults moved from clangFrontend to clangBasic.patch
new file mode 100644
index 000000000000..a0ca845ac434
--- /dev/null
+++ b/gallium-clover: LLVM setLangDefaults moved from clangFrontend to clangBasic.patch
@@ -0,0 +1,29 @@
+From 48185c3b8244d730a4de7c628e715cea71313870 Mon Sep 17 00:00:00 2001
+From: Thomas Debesse <dev@illwieckz.net>
+Date: Mon, 18 Apr 2022 04:21:02 +0200
+Subject: [PATCH] gallium/clover: LLVM setLangDefaults moved from clangFrontend
+ to clangBasic
+
+---
+ src/gallium/frontends/clover/llvm/compat.hpp | 4 ++++
+ 1 file changed, 4 insertions(+)
+
+diff --git a/src/gallium/frontends/clover/llvm/compat.hpp b/src/gallium/frontends/clover/llvm/compat.hpp
+index 8c369b2cac90..1127a397fde1 100644
+--- a/src/gallium/frontends/clover/llvm/compat.hpp
++++ b/src/gallium/frontends/clover/llvm/compat.hpp
+@@ -102,7 +102,11 @@ namespace clover {
+ clang::InputKind ik, const ::llvm::Triple& triple,
+ clang::LangStandard::Kind d)
+ {
++#if LLVM_VERSION_MAJOR >= 15
++ c->getLangOpts().setLangDefaults(c->getLangOpts(), ik.getLanguage(), triple,
++#else
+ c->getInvocation().setLangDefaults(c->getLangOpts(), ik, triple,
++#endif
+ #if LLVM_VERSION_MAJOR >= 12
+ c->getPreprocessorOpts().Includes,
+ #else
+--
+GitLab
+
diff --git a/workaround--LLVM15-FTBFS-no-more-Coroutines.h.patch b/workaround--LLVM15-FTBFS-no-more-Coroutines.h.patch
new file mode 100644
index 000000000000..597eff7bc707
--- /dev/null
+++ b/workaround--LLVM15-FTBFS-no-more-Coroutines.h.patch
@@ -0,0 +1,15 @@
+---
+ src/gallium/auxiliary/gallivm/lp_bld.h | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+--- a/src/gallium/auxiliary/gallivm/lp_bld.h
++++ b/src/gallium/auxiliary/gallivm/lp_bld.h
+@@ -81,7 +81,7 @@
+ #define LLVMInsertBasicBlock ILLEGAL_LLVM_FUNCTION
+ #define LLVMCreateBuilder ILLEGAL_LLVM_FUNCTION
+
+-#if LLVM_VERSION_MAJOR >= 8
++#if LLVM_VERSION_MAJOR >= 8 && LLVM_VERSION_MAJOR < 15
+ #define GALLIVM_HAVE_CORO 1
+ #else
+ #define GALLIVM_HAVE_CORO 0