summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLone_Wolf2023-09-26 23:09:36 +0200
committerLone_Wolf2023-09-26 23:09:36 +0200
commit747272b9ba925efd5d37222a28b39cd3b26591a7 (patch)
tree40d5d7c13cb153b59cbf7a4e5a3c57d0156f81bd
parentbeb2c7c447957e8e1c78c42ae290379f115f9067 (diff)
downloadaur-747272b9ba925efd5d37222a28b39cd3b26591a7.tar.gz
removed no longer needed patches
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD10
-rw-r--r--llvm18-change-in-CodeGenOpt-structure.patch21
-rw-r--r--llvm18-replace-CGFT-with-CodeGenFileType-where-needed.patch40
4 files changed, 3 insertions, 74 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 872eeae86759..a03d4b011702 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = mesa-minimal-git
pkgdesc = an open-source implementation of the OpenGL specification, stripped down git version
- pkgver = 23.3.0_devel.177988.4c877ebfe50
+ pkgver = 23.3.0_devel.178244.b1e851d66c3
pkgrel = 1
url = https://www.mesa3d.org
arch = x86_64
@@ -48,8 +48,6 @@ pkgbase = mesa-minimal-git
options = !emptydirs
source = mesa::git+https://gitlab.freedesktop.org/mesa/mesa.git
source = LICENSE
- source = llvm18-replace-CGFT-with-CodeGenFileType-where-needed.patch
- source = llvm18-change-in-CodeGenOpt-structure.patch
md5sums = SKIP
md5sums = 5c65a0fe315dd347e09b1f2826a1df5a
md5sums = e9dbaa32b8624c90cd3729e4cb1c5b20
@@ -89,7 +87,7 @@ pkgname = opencl-rusticl-mesa-minimal-git
depends = spirv-llvm-translator-minimal-git
depends = libclc-minimal-git
depends = spirv-tools-git
- depends = mesa-minimal-git=23.3.0_devel.177988.4c877ebfe50-1
+ depends = mesa-minimal-git=23.3.0_devel.178244.b1e851d66c3-1
depends = llvm-libs-minimal-git
depends = clang-libs-minimal-git
depends = clang-minimal-git
diff --git a/PKGBUILD b/PKGBUILD
index b500745eb6f6..281ece4c025f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -13,7 +13,7 @@
pkgbase=mesa-minimal-git
pkgname=(mesa-minimal-git opencl-rusticl-mesa-minimal-git)
pkgdesc="an open-source implementation of the OpenGL specification, stripped down git version"
-pkgver=23.3.0_devel.177988.4c877ebfe50
+pkgver=23.3.0_devel.178244.b1e851d66c3
pkgrel=1
arch=('x86_64')
makedepends=(git meson ninja libglvnd python-mako xorgproto libxml2 libx11 libva elfutils libxrandr
@@ -27,8 +27,6 @@ url="https://www.mesa3d.org"
license=('custom')
source=("mesa::git+https://gitlab.freedesktop.org/mesa/mesa.git"
'LICENSE'
- 'llvm18-replace-CGFT-with-CodeGenFileType-where-needed.patch'
- 'llvm18-change-in-CodeGenOpt-structure.patch'
)
md5sums=('SKIP'
'5c65a0fe315dd347e09b1f2826a1df5a'
@@ -45,12 +43,6 @@ options=(!emptydirs)
# The responsibility to validate the value of NINJAFLAGS lies with the user.
# If unsure, use NINJAFLAGS=""
-prepare() {
- cd mesa
- patch --forward --strip=1 --input="${srcdir}"/llvm18-replace-CGFT-with-CodeGenFileType-where-needed.patch
- patch --forward --strip=1 --input="${srcdir}"/llvm18-change-in-CodeGenOpt-structure.patch
-}
-
pkgver() {
cd mesa
local _ver
diff --git a/llvm18-change-in-CodeGenOpt-structure.patch b/llvm18-change-in-CodeGenOpt-structure.patch
deleted file mode 100644
index 4573fee3a97c..000000000000
--- a/llvm18-change-in-CodeGenOpt-structure.patch
+++ /dev/null
@@ -1,21 +0,0 @@
-diff --unified --recursive --text mesa/src/gallium/auxiliary/gallivm/lp_bld_misc.cpp mesa.new1/src/gallium/auxiliary/gallivm/lp_bld_misc.cpp
---- mesa/src/gallium/auxiliary/gallivm/lp_bld_misc.cpp 2023-09-19 14:11:23.739532226 +0200
-+++ mesa.new1/src/gallium/auxiliary/gallivm/lp_bld_misc.cpp 2023-09-19 15:17:40.952081411 +0200
-@@ -363,10 +363,17 @@
- options.StackAlignmentOverride = 4;
- #endif
-
-+#if LLVM_VERSION_MAJOR >= 18
-+ builder.setEngineKind(EngineKind::JIT)
-+ .setErrorStr(&Error)
-+ .setTargetOptions(options)
-+ .setOptLevel((CodeGenOptLevel)OptLevel);
-+#else
- builder.setEngineKind(EngineKind::JIT)
- .setErrorStr(&Error)
- .setTargetOptions(options)
- .setOptLevel((CodeGenOpt::Level)OptLevel);
-+#endif
-
- #if DETECT_OS_WINDOWS
- /*
diff --git a/llvm18-replace-CGFT-with-CodeGenFileType-where-needed.patch b/llvm18-replace-CGFT-with-CodeGenFileType-where-needed.patch
deleted file mode 100644
index a27adb6a8beb..000000000000
--- a/llvm18-replace-CGFT-with-CodeGenFileType-where-needed.patch
+++ /dev/null
@@ -1,40 +0,0 @@
-diff --unified --recursive --text mesa/src/amd/llvm/ac_llvm_helper.cpp mesa.new/src/amd/llvm/ac_llvm_helper.cpp
---- mesa/src/amd/llvm/ac_llvm_helper.cpp 2023-09-19 14:11:23.482860135 +0200
-+++ mesa.new/src/amd/llvm/ac_llvm_helper.cpp 2023-09-19 14:59:04.514748140 +0200
-@@ -249,8 +249,11 @@
-
- TargetMachine *TM = reinterpret_cast<TargetMachine *>(tm);
-
-+/* The change from CGFT_ObjectFile to CodeGenFileType::ObjectFile breaks build on llvm pre-18
-+ * unfortunately my coding skills are not good enough to do this in a clean way
-+ */
- if (TM->addPassesToEmitFile(p->passmgr, p->ostream, nullptr,
-- CGFT_ObjectFile)) {
-+ CodeGenFileType::ObjectFile)) {
- fprintf(stderr, "amd: TargetMachine can't emit a file of this type!\n");
- delete p;
- return NULL;
-diff --unified --recursive --text mesa/src/gallium/frontends/clover/llvm/compat.hpp mesa.new/src/gallium/frontends/clover/llvm/compat.hpp
---- mesa/src/gallium/frontends/clover/llvm/compat.hpp 2023-09-19 14:11:23.989537509 +0200
-+++ mesa.new/src/gallium/frontends/clover/llvm/compat.hpp 2023-09-19 14:25:35.699455684 +0200
-@@ -68,7 +68,6 @@
- namespace llvm {
- namespace compat {
-
-- const auto CGFT_ObjectFile = ::llvm::CGFT_ObjectFile;
- const auto CGFT_AssemblyFile = ::llvm::CGFT_AssemblyFile;
- typedef ::llvm::CodeGenFileType CodeGenFileType;
-
-@@ -109,6 +108,12 @@
- #else
- return dl.getABITypeAlignment(type);
- #endif
-+#if LLVM_VERSION_MAJOR >= 18
-+ const auto CGFT_ObjectFile = ::llvm::CodeGenFileType::ObjectFile;
-+#else
-+ const auto CGFT_ObjectFile = ::llvm::CGFT_ObjectFile;
-+#endif
-+
- }
-
- static inline bool