summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLone_Wolf2021-09-08 13:57:53 +0200
committerLone_Wolf2021-09-08 13:57:53 +0200
commit81d3597ebe33a05aa381008496e472881e88c4c7 (patch)
tree3764eeeb048d3a0ed5250c28f98a3d941637cdf7
parent74ad4a4fb63346bf58bf82e9b066eac000be3ea9 (diff)
downloadaur-81d3597ebe33a05aa381008496e472881e88c4c7.tar.gz
patch added to solve build failure, see https://gitlab.freedesktop.org/mesa/mesa/-/issues/5320
-rw-r--r--.SRCINFO6
-rw-r--r--12715 - use hasParamAttr instead of hasAttribute.patch24
-rw-r--r--PKGBUILD8
3 files changed, 33 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cbadf0c624de..8ae8b61c399d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = mesa-minimal-git
pkgdesc = an open-source implementation of the OpenGL specification, stripped down git version
- pkgver = 21.2.0_devel.138224.f601fd635bb
+ pkgver = 21.3.0_devel.144574.20ec247cb8e
pkgrel = 1
url = https://www.mesa3d.org
arch = x86_64
@@ -55,10 +55,12 @@ pkgbase = mesa-minimal-git
conflicts = mesa-vdpau
source = mesa::git+https://gitlab.freedesktop.org/mesa/mesa.git
source = LICENSE
+ source = 12715 - use hasParamAttr instead of hasAttribute.patch
md5sums = SKIP
md5sums = 5c65a0fe315dd347e09b1f2826a1df5a
+ md5sums = 87cc71137f5fa8b686ff4f562dbf65d5
sha512sums = SKIP
sha512sums = 25da77914dded10c1f432ebcbf29941124138824ceecaf1367b3deedafaecabc082d463abcfa3d15abff59f177491472b505bcb5ba0c4a51bb6b93b4721a23c2
+ sha512sums = 47886f0916dbf68b5cad7cd6aacfc61955d1352bff9431b0958aa17b0280e18d03b3690be872f10156a1d206560b11cf8835446df82f118ffa138acd551e47b8
pkgname = mesa-minimal-git
-
diff --git a/12715 - use hasParamAttr instead of hasAttribute.patch b/12715 - use hasParamAttr instead of hasAttribute.patch
new file mode 100644
index 000000000000..067141ff4d42
--- /dev/null
+++ b/12715 - use hasParamAttr instead of hasAttribute.patch
@@ -0,0 +1,24 @@
+--- a/src/amd/llvm/ac_llvm_helper.cpp
++++ b/src/amd/llvm/ac_llvm_helper.cpp
+@@ -60,7 +60,7 @@
+ llvm::Argument *A = llvm::unwrap<llvm::Argument>(arg);
+ llvm::AttributeList AS = A->getParent()->getAttributes();
+ unsigned ArgNo = A->getArgNo();
+- return AS.hasAttribute(ArgNo + 1, llvm::Attribute::InReg);
++ return AS.hasParamAttr(ArgNo, llvm::Attribute::InReg);
+ }
+
+
+--- a/src/gallium/frontends/clover/llvm/codegen/common.cpp
++++ b/src/gallium/frontends/clover/llvm/codegen/common.cpp
+@@ -233,8 +233,8 @@ namespace {
+ }
+
+ } else {
+- const bool needs_sign_ext = f.getAttributes().hasAttribute(
+- arg.getArgNo() + 1, ::llvm::Attribute::SExt);
++ const bool needs_sign_ext = f.getAttributes().hasParamAttr(
++ arg.getArgNo(), ::llvm::Attribute::SExt);
+
+ args.emplace_back(module::argument::scalar, arg_api_size,
+ target_size, target_align,
diff --git a/PKGBUILD b/PKGBUILD
index c30a7fbffe3a..b3df01310c57 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -12,7 +12,7 @@
pkgname=mesa-minimal-git
pkgdesc="an open-source implementation of the OpenGL specification, stripped down git version"
-pkgver=21.2.0_devel.138224.f601fd635bb
+pkgver=21.3.0_devel.144574.20ec247cb8e
pkgrel=1
arch=('x86_64')
makedepends=('git' 'python-mako' 'xorgproto'
@@ -30,13 +30,14 @@ url="https://www.mesa3d.org"
license=('custom')
source=('mesa::git+https://gitlab.freedesktop.org/mesa/mesa.git'
'LICENSE'
+ "12715 - use hasParamAttr instead of hasAttribute.patch"
)
md5sums=('SKIP'
'5c65a0fe315dd347e09b1f2826a1df5a'
-)
+ '87cc71137f5fa8b686ff4f562dbf65d5')
sha512sums=('SKIP'
'25da77914dded10c1f432ebcbf29941124138824ceecaf1367b3deedafaecabc082d463abcfa3d15abff59f177491472b505bcb5ba0c4a51bb6b93b4721a23c2'
-)
+ '47886f0916dbf68b5cad7cd6aacfc61955d1352bff9431b0958aa17b0280e18d03b3690be872f10156a1d206560b11cf8835446df82f118ffa138acd551e47b8')
# ninja grabs all available cores and leaves almost nothing for other processes.
# this package uses the environment variable NINJAFLAGS to allow the user to change this behaviour
@@ -55,6 +56,7 @@ prepare() {
if [ -d _build ]; then
rm -rf _build
fi
+ patch --directory=mesa --forward --strip=1 --input="${srcdir}/12715 - use hasParamAttr instead of hasAttribute.patch"
}
build () {