summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLone_Wolf2021-03-03 00:55:00 +0100
committerLone_Wolf2021-03-03 00:55:00 +0100
commitbfb098aa1da8eac43e85031f439d26926319d23f (patch)
tree3b6319452d0cfd83d083ebc12ea980fdf4ae1104
parente0e6f283b1f788eaaa6eccbe45d20af98390024c (diff)
downloadaur-bfb098aa1da8eac43e85031f439d26926319d23f.tar.gz
updated patches
-rw-r--r--.SRCINFO12
-rw-r--r--0001-clover-llvm13-use-FixedVectorType.patch2
-rw-r--r--0002-fix-ac_build_atomic_rmw-with-LLVM-13.patch36
-rw-r--r--8543 clover: Fix build with llvm-12.patch42
-rw-r--r--PKGBUILD17
5 files changed, 52 insertions, 57 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 87134b01fcc2..cc2ab1cc641d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = mesa-minimal-git
pkgdesc = an open-source implementation of the OpenGL specification, stripped down git version
- pkgver = 21.1.0_devel.135493.2b10bff7b3d
+ pkgver = 21.1.0_devel.135956.c77df59c9e6
pkgrel = 1
url = https://www.mesa3d.org
arch = x86_64
@@ -55,16 +55,16 @@ pkgbase = mesa-minimal-git
conflicts = mesa-vdpau
source = mesa::git+https://gitlab.freedesktop.org/mesa/mesa.git
source = LICENSE
- source = 8543 clover: Fix build with llvm-12.patch
source = 0001-clover-llvm13-use-FixedVectorType.patch
+ source = 0002-fix-ac_build_atomic_rmw-with-LLVM-13.patch
md5sums = SKIP
md5sums = 5c65a0fe315dd347e09b1f2826a1df5a
- md5sums = febd615545826793ff84a016e59b516c
- md5sums = eabf32299ab9fc89e2eddd6ac5a95ebc
+ md5sums = 5f0620ce35da2d1f80dc1b3c03eafc32
+ md5sums = 02e6ec0777fd25a51f6e15ba3bdbfff2
sha512sums = SKIP
sha512sums = 25da77914dded10c1f432ebcbf29941124138824ceecaf1367b3deedafaecabc082d463abcfa3d15abff59f177491472b505bcb5ba0c4a51bb6b93b4721a23c2
- sha512sums = 2e1b0773cee0511c5ca87a163fef5ce46e78d5a8ba99fa88eda73f5757ee00b103a072614c266fedd515d55bb5cb03c3f3b45f75869c6f0bde33c1f7f767984b
- sha512sums = 2f16e3098a8b8a3083b158b0b6fe54cf4b216c99beb21d5e6774db2e18b829067e80f862468506687beddb562e568dfcac6deb60bb133e470601eee579920e7c
+ sha512sums = c3a567df69a263c6b87d9c7887464ed03b5a0bf008caf180c45cf50dca3f4710e0eda3e453a7a69b89720e333c33b9aa7da1b7f9c79d72bb76d847b567558d19
+ sha512sums = 694793099b05351bbcc83751499487b627c4daa13b5bdb93bf3f391372286ef8fb599d3e2a660452400ba56bb130454f067987a3d59214022055963e45f85779
pkgname = mesa-minimal-git
diff --git a/0001-clover-llvm13-use-FixedVectorType.patch b/0001-clover-llvm13-use-FixedVectorType.patch
index 78c4dda78a81..d3eade097f6a 100644
--- a/0001-clover-llvm13-use-FixedVectorType.patch
+++ b/0001-clover-llvm13-use-FixedVectorType.patch
@@ -9,7 +9,7 @@ diff --unified --recursive --text mesa.orig/src/gallium/frontends/clover/llvm/me
+#if LLVM_VERSION_MAJOR >= 13
+ data += std::to_string(((::llvm::FixedVectorType*)type)->getNumElements());
+#else
-+ data += std::to_string(((::llvm::VectorType*)type)->getNumElements())
++ data += std::to_string(((::llvm::VectorType*)type)->getNumElements());
+#endif
} else {
diff --git a/0002-fix-ac_build_atomic_rmw-with-LLVM-13.patch b/0002-fix-ac_build_atomic_rmw-with-LLVM-13.patch
new file mode 100644
index 000000000000..2bebd52e8721
--- /dev/null
+++ b/0002-fix-ac_build_atomic_rmw-with-LLVM-13.patch
@@ -0,0 +1,36 @@
+From 5903405880c81dfffa9391d3df7e133da3160934 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Marek=20Ol=C5=A1=C3=A1k?= <marek.olsak@amd.com>
+Date: Tue, 2 Mar 2021 02:59:23 -0500
+Subject: [PATCH] ac/llvm: fix ac_build_atomic_rmw with LLVM 13
+
+---
+ src/amd/llvm/ac_llvm_helper.cpp | 6 ++++++
+ 1 file changed, 6 insertions(+)
+
+diff --git a/src/amd/llvm/ac_llvm_helper.cpp b/src/amd/llvm/ac_llvm_helper.cpp
+index ebeafaea553..0ab9517f431 100644
+--- a/src/amd/llvm/ac_llvm_helper.cpp
++++ b/src/amd/llvm/ac_llvm_helper.cpp
+@@ -321,6 +321,9 @@ LLVMValueRef ac_build_atomic_rmw(struct ac_llvm_context *ctx, LLVMAtomicRMWBinOp
+ unsigned SSID = llvm::unwrap(ctx->context)->getOrInsertSyncScopeID(sync_scope);
+ return llvm::wrap(llvm::unwrap(ctx->builder)
+ ->CreateAtomicRMW(binop, llvm::unwrap(ptr), llvm::unwrap(val),
++#if LLVM_VERSION_MAJOR >= 13
++ llvm::MaybeAlign(0),
++#endif
+ llvm::AtomicOrdering::SequentiallyConsistent, SSID));
+ }
+
+@@ -331,6 +334,9 @@ LLVMValueRef ac_build_atomic_cmp_xchg(struct ac_llvm_context *ctx, LLVMValueRef
+ return llvm::wrap(llvm::unwrap(ctx->builder)
+ ->CreateAtomicCmpXchg(llvm::unwrap(ptr), llvm::unwrap(cmp),
+ llvm::unwrap(val),
++#if LLVM_VERSION_MAJOR >= 13
++ llvm::MaybeAlign(0),
++#endif
+ llvm::AtomicOrdering::SequentiallyConsistent,
+ llvm::AtomicOrdering::SequentiallyConsistent, SSID));
+ }
+--
+GitLab
+
diff --git a/8543 clover: Fix build with llvm-12.patch b/8543 clover: Fix build with llvm-12.patch
deleted file mode 100644
index 4c221d544461..000000000000
--- a/8543 clover: Fix build with llvm-12.patch
+++ /dev/null
@@ -1,42 +0,0 @@
-From 67b36d1e81dcdce97daa6eab4a6a7e60c6d3949a Mon Sep 17 00:00:00 2001
-From: Vinson Lee <vlee@freedesktop.org>
-Date: Sat, 16 Jan 2021 22:55:41 -0800
-Subject: [PATCH] clover: Fix build with llvm-12.
-MIME-Version: 1.0
-Content-Type: text/plain; charset=UTF-8
-Content-Transfer-Encoding: 8bit
-
-Fix build error after LLVM commit c495dfe0268b ("[clang][cli] NFC:
-Decrease the scope of ParseLangArgs parameters").
-
-../src/gallium/frontends/clover/llvm/invocation.cpp: In function ‘std::unique_ptr<clang::CompilerInstance> {anonymous}::create_compiler_instance(const clover::device&, const string&, const std::vector<std::__cxx11::basic_string<char> >&, std::string&)’:
-../src/gallium/frontends/clover/llvm/invocation.cpp:252:55: error: cannot convert ‘clang::PreprocessorOptions’ to ‘std::vector<std::__cxx11::basic_string<char> >&’
- 252 | c->getPreprocessorOpts(),
- | ~~~~~~~~~~~~~~~~~~~~~~^~
- | |
- | clang::PreprocessorOptions
-
-Signed-off-by: Vinson Lee <vlee@freedesktop.org>
----
- src/gallium/frontends/clover/llvm/invocation.cpp | 4 ++++
- 1 file changed, 4 insertions(+)
-
-diff --git a/src/gallium/frontends/clover/llvm/invocation.cpp b/src/gallium/frontends/clover/llvm/invocation.cpp
-index be0f3976b92..bcbec21cd1c 100644
---- a/src/gallium/frontends/clover/llvm/invocation.cpp
-+++ b/src/gallium/frontends/clover/llvm/invocation.cpp
-@@ -249,7 +249,11 @@ namespace {
-
- c->getInvocation().setLangDefaults(c->getLangOpts(),
- compat::ik_opencl, ::llvm::Triple(target.triple),
-+#if LLVM_VERSION_MAJOR >= 12
-+ c->getPreprocessorOpts().Includes,
-+#else
- c->getPreprocessorOpts(),
-+#endif
- get_language_version(opts, device_clc_version));
-
- c->createDiagnostics(new clang::TextDiagnosticPrinter(
---
-GitLab
-
diff --git a/PKGBUILD b/PKGBUILD
index 319c5277da62..a2c3a933013d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -12,7 +12,7 @@
pkgname=mesa-minimal-git
pkgdesc="an open-source implementation of the OpenGL specification, stripped down git version"
-pkgver=21.1.0_devel.135493.2b10bff7b3d
+pkgver=21.1.0_devel.135956.c77df59c9e6
pkgrel=1
arch=('x86_64')
makedepends=('git' 'python-mako' 'xorgproto'
@@ -30,16 +30,16 @@ url="https://www.mesa3d.org"
license=('custom')
source=('mesa::git+https://gitlab.freedesktop.org/mesa/mesa.git'
'LICENSE'
- '8543 clover: Fix build with llvm-12.patch'
- '0001-clover-llvm13-use-FixedVectorType.patch')
+ '0001-clover-llvm13-use-FixedVectorType.patch'
+ '0002-fix-ac_build_atomic_rmw-with-LLVM-13.patch')
md5sums=('SKIP'
'5c65a0fe315dd347e09b1f2826a1df5a'
- 'febd615545826793ff84a016e59b516c'
- 'eabf32299ab9fc89e2eddd6ac5a95ebc')
+ '5f0620ce35da2d1f80dc1b3c03eafc32'
+ '02e6ec0777fd25a51f6e15ba3bdbfff2')
sha512sums=('SKIP'
'25da77914dded10c1f432ebcbf29941124138824ceecaf1367b3deedafaecabc082d463abcfa3d15abff59f177491472b505bcb5ba0c4a51bb6b93b4721a23c2'
- '2e1b0773cee0511c5ca87a163fef5ce46e78d5a8ba99fa88eda73f5757ee00b103a072614c266fedd515d55bb5cb03c3f3b45f75869c6f0bde33c1f7f767984b'
- '2f16e3098a8b8a3083b158b0b6fe54cf4b216c99beb21d5e6774db2e18b829067e80f862468506687beddb562e568dfcac6deb60bb133e470601eee579920e7c')
+ 'c3a567df69a263c6b87d9c7887464ed03b5a0bf008caf180c45cf50dca3f4710e0eda3e453a7a69b89720e333c33b9aa7da1b7f9c79d72bb76d847b567558d19'
+ '694793099b05351bbcc83751499487b627c4daa13b5bdb93bf3f391372286ef8fb599d3e2a660452400ba56bb130454f067987a3d59214022055963e45f85779')
# ninja grabs all available cores and leaves almost nothing for other processes.
# this package uses the environment variable NINJAFLAGS to allow the user to change this behaviour
@@ -59,8 +59,9 @@ prepare() {
rm -rf _build
fi
cd mesa
- patch --forward --strip=1 --input="${srcdir}/8543 clover: Fix build with llvm-12.patch"
+# patch --forward --strip=1 --input="${srcdir}/0002-clover-additonal-include-for-mr8543-llvm12.patch"
patch --forward --strip=1 --input="${srcdir}/0001-clover-llvm13-use-FixedVectorType.patch"
+ patch --forward --strip=1 --input="${srcdir}/0002-fix-ac_build_atomic_rmw-with-LLVM-13.patch"
}
build () {