summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbartus2017-01-09 19:04:04 +0100
committerbartus2017-01-09 19:04:04 +0100
commit63f7b512e8e57f574dc8b198091753ca72d28885 (patch)
treea37475b38740c2a48304a0ddc62471bbcfe76a47
parent4e2eb210361f099e92f233ad6276535f87465795 (diff)
downloadaur-63f7b512e8e57f574dc8b198091753ca72d28885.tar.gz
drop marged patches
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD8
-rw-r--r--cpp11_abs.patch11
-rw-r--r--fix_locale.patch19
4 files changed, 5 insertions, 39 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4e3a3fe475eb..21239736e605 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = meshlab-git
pkgdesc = System for processing and editing of unstructured 3D models arising in 3D scanning (qt5 version)
- pkgver = 2016.12.r6.gf29d0ba1
+ pkgver = 2016.12.r10.g781a39a5
pkgrel = 1
url = http://www.meshlab.net
install = meshlab-git.install
@@ -30,7 +30,6 @@ pkgbase = meshlab-git
source = bzip2.patch
source = meshlabserver_GLU.patch
source = cpp11_abs.patch
- source = fix_locale.patch
source = mpir.patch
source = rpath.patch
source = meshlab.desktop
@@ -42,8 +41,7 @@ pkgbase = meshlab-git
md5sums = 64caafa96bef4208d641e889099eba26
md5sums = 616b0dcf018f46a490867028d6ddc533
md5sums = 5d87f00356539f84f37f873f304eb11e
- md5sums = c1cfb910d20db49ec195d9918036e3c3
- md5sums = 5b59b23cf66e42f8b3d3eabe466b3eaa
+ md5sums = 3f49b66001a0e4d31f43c1429d73d7b6
md5sums = 5df295c21de5bac8d6073528823d975a
md5sums = 2cc1246fc1b01029ae762c82a7dbf364
md5sums = 18aed0a21276a22325bf8c32166fb110
diff --git a/PKGBUILD b/PKGBUILD
index a2be78708d89..98aafcfb9459 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: bartus <aur@bartus.33mail.com>
pkgname=meshlab-git
-pkgver=2016.12.r6.gf29d0ba1
+pkgver=2016.12.r10.g781a39a5
pkgrel=1
pkgdesc="System for processing and editing of unstructured 3D models arising in 3D scanning (qt5 version)"
arch=('i686' 'x86_64')
@@ -21,7 +21,6 @@ source=("git+https://github.com/cnr-isti-vclab/meshlab.git"
"bzip2.patch"
"meshlabserver_GLU.patch"
"cpp11_abs.patch"
- "fix_locale.patch"
"mpir.patch"
"rpath.patch"
"meshlab.desktop")
@@ -33,8 +32,7 @@ md5sums=('SKIP'
'64caafa96bef4208d641e889099eba26'
'616b0dcf018f46a490867028d6ddc533'
'5d87f00356539f84f37f873f304eb11e'
- 'c1cfb910d20db49ec195d9918036e3c3'
- '5b59b23cf66e42f8b3d3eabe466b3eaa'
+ '3f49b66001a0e4d31f43c1429d73d7b6'
'5df295c21de5bac8d6073528823d975a'
'2cc1246fc1b01029ae762c82a7dbf364'
'18aed0a21276a22325bf8c32166fb110')
@@ -58,8 +56,6 @@ prepare() {
patch -Np0 -i meshlabserver_GLU.patch
msg "fix cpp11 abs()"
patch -Np0 -i cpp11_abs.patch
- msg "fix decimal separator problem"
- patch -Np0 -i fix_locale.patch
msg "using system mpir lib"
patch -Np0 -i mpir.patch
msg "using system bzip2 lib"
diff --git a/cpp11_abs.patch b/cpp11_abs.patch
index 6078b92c4c9c..15b1af5f8a07 100644
--- a/cpp11_abs.patch
+++ b/cpp11_abs.patch
@@ -6,16 +6,7 @@ diff -Naur meshlab.orig/src/meshlabplugins/edit_quality/eqhandle.cpp meshlab/src
#include "eqhandle.h"
#include <QMouseEvent>
#include <QGraphicsSceneMouseEvent>
-+#include "math.h" /* fabs() */
++#include <cmath.h>
EqHandle::EqHandle(CHART_INFO *environment_info, QColor color, QPointF position,
EQUALIZER_HANDLE_TYPE type, EqHandle** handles, qreal* midHandlePercentilePosition, QDoubleSpinBox* spinbox,
-@@ -83,7 +83,7 @@
- setCursor(Qt::OpenHandCursor);
-
- QPointF newPos = event->scenePos();
-- qreal handleOffset = abs(newPos.x()-pos().x());
-+ qreal handleOffset = fabs(newPos.x()-pos().x());
-
- if (handleOffset >= std::numeric_limits<float>::epsilon())
- {
diff --git a/fix_locale.patch b/fix_locale.patch
deleted file mode 100644
index 343507d497b8..000000000000
--- a/fix_locale.patch
+++ /dev/null
@@ -1,19 +0,0 @@
-diff -Naur meshlab.orig/src/meshlab/main.cpp meshlab/src/meshlab/main.cpp
---- meshlab.orig/src/meshlab/main.cpp 2016-10-30 19:47:18.130692500 +0100
-+++ meshlab/src/meshlab/main.cpp 2016-10-30 19:49:14.529497595 +0100
-@@ -20,6 +20,7 @@
- * for more details. *
- * *
- ****************************************************************************/
-+#include <locale.h>
- #include <common/mlapplication.h>
- #include <QMessageBox>
- #include "mainwindow.h"
-@@ -29,6 +30,7 @@
- {
-
- MeshLabApplication app(argc, argv);
-+ setlocale(LC_ALL, "C");
- QLocale::setDefault(QLocale::C);
- QCoreApplication::setOrganizationName(MeshLabApplication::organization());
- #if QT_VERSION >= 0x050100