summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbartus2017-07-31 11:18:04 +0200
committerbartus2017-07-31 11:18:04 +0200
commitc5d2f923d811637b760ddc9687b0e65a24131065 (patch)
treec28b1f0290f64bf99e416de4ed61211d98f66a77
parent9f9ff0e12cf1e7abb27ec5459f0d4f1567fa20a5 (diff)
downloadaur-c5d2f923d811637b760ddc9687b0e65a24131065.tar.gz
fix plugin align for latest vcglib
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD6
-rw-r--r--meshlabplugins.align.patch31
3 files changed, 39 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 89411b76dc1c..d7dd10d40626 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = meshlab-git
pkgdesc = System for processing and editing of unstructured 3D models arising in 3D scanning (qt5 version)
pkgver = 2016.12.r177.g70b9dd7f
- pkgrel = 1
+ pkgrel = 2
url = http://www.meshlab.net
install = meshlab-git.install
arch = i686
@@ -33,6 +33,7 @@ pkgbase = meshlab-git
source = mpir.patch
source = rpath.patch
source = import_bundle_out.patch
+ source = meshlabplugins.align.patch
source = meshlab.desktop
md5sums = SKIP
md5sums = SKIP
@@ -46,6 +47,7 @@ pkgbase = meshlab-git
md5sums = cb5a75c2f2cdf154ad61f753439f226f
md5sums = 07da2fc11c1667e6c6a07f0042a2757d
md5sums = 765a59b64dd05b74f6a4bdf3962a1d93
+ md5sums = 664dd92112695930b2564c08b04b57c5
md5sums = 18aed0a21276a22325bf8c32166fb110
pkgname = meshlab-git
diff --git a/PKGBUILD b/PKGBUILD
index ea56700978b1..680abe5a2de8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: bartus <aur@bartus.33mail.com>
pkgname=meshlab-git
pkgver=2016.12.r177.g70b9dd7f
-pkgrel=1
+pkgrel=2
pkgdesc="System for processing and editing of unstructured 3D models arising in 3D scanning (qt5 version)"
arch=('i686' 'x86_64')
url="http://www.meshlab.net"
@@ -23,6 +23,7 @@ source=("git+https://github.com/cnr-isti-vclab/meshlab.git"
"mpir.patch"
"rpath.patch"
"import_bundle_out.patch"
+ "meshlabplugins.align.patch"
"meshlab.desktop")
md5sums=('SKIP'
'SKIP'
@@ -36,6 +37,7 @@ md5sums=('SKIP'
'cb5a75c2f2cdf154ad61f753439f226f'
'07da2fc11c1667e6c6a07f0042a2757d'
'765a59b64dd05b74f6a4bdf3962a1d93'
+ '664dd92112695930b2564c08b04b57c5'
'18aed0a21276a22325bf8c32166fb110')
pkgver() {
@@ -69,6 +71,8 @@ prepare() {
patch -Np0 -i shaders_dir.patch
msg "fix import bundler/nvm"
patch -Np0 -i import_bundle_out.patch
+ msg "fix align plugin incompatible with latest vcglib"
+ patch -Np0 -i meshlabplugins.align.patch
}
build() {
diff --git a/meshlabplugins.align.patch b/meshlabplugins.align.patch
new file mode 100644
index 000000000000..08da9ff312f0
--- /dev/null
+++ b/meshlabplugins.align.patch
@@ -0,0 +1,31 @@
+diff --git a/src/meshlabplugins/edit_align/align/AlignGlobal.cpp b/src/meshlabplugins/edit_align/align/AlignGlobal.cpp
+index 509c940f..7203fb51 100644
+--- meshlab/src/meshlabplugins/edit_align/align/AlignGlobal.cpp
++++ b/src/meshlabplugins/edit_align/align/AlignGlobal.cpp
+@@ -429,11 +429,11 @@ Per ogni componente connessa,
+
+ ******************************/
+
+-bool AlignGlobal::GlobalAlign(const std::map<int,string> &Names, const double epsilon, int maxiter, bool Rigid, FILE *elfp, CallBack* cb )
++bool AlignGlobal::GlobalAlign(const std::map<int,string> &Names, const double epsilon, int maxiter, bool Rigid, FILE *elfp, CallBackPos* cb )
+ {
+ double change;
+ int step, localmaxiter;
+- cb("Global Alignment...");
++ cb(1,"Global Alignment...");
+ LOG(elfp,"----------------\n----------------\nGlobalAlignment (target eps %7.3f)\n",epsilon);
+
+ queue<AlignGlobal::Node *> Q;
+diff --git a/src/meshlabplugins/edit_align/align/AlignGlobal.h b/src/meshlabplugins/edit_align/align/AlignGlobal.h
+index c306f53d..42c5614f 100644
+--- meshlab/src/meshlabplugins/edit_align/align/AlignGlobal.h
++++ b/src/meshlabplugins/edit_align/align/AlignGlobal.h
+@@ -115,7 +115,7 @@ public:
+ Node *ChooseDormantWithMostActiveLink ();
+ void MakeAllDormant();
+ void Clear();
+- bool GlobalAlign(const std::map<int,std::string> &Names, const double epsilon, int maxiter, bool Rigid, FILE *elfp=0, CallBack * cb=DummyCallBack );
++ bool GlobalAlign(const std::map<int,std::string> &Names, const double epsilon, int maxiter, bool Rigid, FILE *elfp=0, CallBackPos *cb=DummyCallBackPos);
+
+ bool CheckGraph();
+