summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbartus2017-06-28 02:27:55 +0200
committerbartus2017-06-28 02:27:55 +0200
commitf50aa42b61a4deb2e0f20d8e8e7cc3a276a0fe50 (patch)
tree542338d092e5f0a164febbdbc789f70d895f3aa1
parent2440356a2a90289c5eaeed56145706a88cb41f37 (diff)
downloadaur-f50aa42b61a4deb2e0f20d8e8e7cc3a276a0fe50.tar.gz
fix gcc7, patch vcglib
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD9
-rw-r--r--import_bundle_out.patch38
-rw-r--r--patch.patch13
4 files changed, 64 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ccf3da60f55f..f4eab81d51eb 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = meshlab-git
pkgdesc = System for processing and editing of unstructured 3D models arising in 3D scanning (qt5 version)
- pkgver = 2016.12.r145.gd26b0446
+ pkgver = 2016.12.r170.gb4103dc0
pkgrel = 1
url = http://www.meshlab.net
install = meshlab-git.install
@@ -32,6 +32,8 @@ pkgbase = meshlab-git
source = meshlabserver_GLU.patch
source = mpir.patch
source = rpath.patch
+ source = import_bundle_out.patch
+ source = patch.patch
source = meshlab.desktop
md5sums = SKIP
md5sums = SKIP
@@ -44,6 +46,8 @@ pkgbase = meshlab-git
md5sums = ca962601b06fac1fb2b6bf0b408777ad
md5sums = cb5a75c2f2cdf154ad61f753439f226f
md5sums = 07da2fc11c1667e6c6a07f0042a2757d
+ md5sums = 765a59b64dd05b74f6a4bdf3962a1d93
+ md5sums = 7cb2aa39c2b4a6e7abbec40201df9c7e
md5sums = 18aed0a21276a22325bf8c32166fb110
pkgname = meshlab-git
diff --git a/PKGBUILD b/PKGBUILD
index 11c9bca7d6a5..7a58ddc1dce9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: bartus <aur@bartus.33mail.com>
pkgname=meshlab-git
-pkgver=2016.12.r145.gd26b0446
+pkgver=2016.12.r170.gb4103dc0
pkgrel=1
pkgdesc="System for processing and editing of unstructured 3D models arising in 3D scanning (qt5 version)"
arch=('i686' 'x86_64')
@@ -22,6 +22,8 @@ source=("git+https://github.com/cnr-isti-vclab/meshlab.git"
"meshlabserver_GLU.patch"
"mpir.patch"
"rpath.patch"
+ "import_bundle_out.patch"
+ "patch.patch"
"meshlab.desktop")
md5sums=('SKIP'
'SKIP'
@@ -34,6 +36,8 @@ md5sums=('SKIP'
'ca962601b06fac1fb2b6bf0b408777ad'
'cb5a75c2f2cdf154ad61f753439f226f'
'07da2fc11c1667e6c6a07f0042a2757d'
+ '765a59b64dd05b74f6a4bdf3962a1d93'
+ '7cb2aa39c2b4a6e7abbec40201df9c7e'
'18aed0a21276a22325bf8c32166fb110')
pkgver() {
@@ -65,6 +69,9 @@ prepare() {
patch -Np0 -i plugin_dir.patch
msg "put shaders in /usr/shade/meshlab"
patch -Np0 -i shaders_dir.patch
+ msg "fix import bundler/nvm"
+ patch -Np0 -i import_bundle_out.patch
+ patch -Np0 -i patch.patch
}
build() {
diff --git a/import_bundle_out.patch b/import_bundle_out.patch
new file mode 100644
index 000000000000..f3afd9a6e36a
--- /dev/null
+++ b/import_bundle_out.patch
@@ -0,0 +1,38 @@
+diff --git a/wrap/io_trimesh/import_nvm.h b/wrap/io_trimesh/import_nvm.h
+index bebe7c36..f797da9d 100644
+--- vcglib/wrap/io_trimesh/import_nvm.h
++++ b/wrap/io_trimesh/import_nvm.h
+@@ -85,14 +85,6 @@ static bool ReadHeader(FILE *fp,unsigned int &num_cams){
+ return true;
+ }
+
+-static bool ReadHeader(const char * filename,unsigned int &/*num_cams*/, unsigned int &/*num_points*/){
+- FILE *fp = fopen(filename, "r");
+- if(!fp) return false;
+- ReadHeader(fp);
+- fclose(fp);
+- return true;
+-}
+-
+
+ static int Open( OpenMeshType &m, std::vector<Shot<ScalarType> > & shots,
+ std::vector<std::string > & image_filenames,
+diff --git a/wrap/io_trimesh/import_out.h b/wrap/io_trimesh/import_out.h
+index 01331bc5..c2cd86fe 100644
+--- vcglib/wrap/io_trimesh/import_out.h
++++ b/wrap/io_trimesh/import_out.h
+@@ -85,14 +85,6 @@ static bool ReadHeader(FILE *fp,unsigned int &num_cams, unsigned int &num_points
+ return true;
+ }
+
+-static bool ReadHeader(const char * filename,unsigned int &/*num_cams*/, unsigned int &/*num_points*/){
+- FILE *fp = fopen(filename, "r");
+- if(!fp) return false;
+- ReadHeader(fp);
+- fclose(fp);
+- return true;
+-}
+-
+
+ static int Open( OpenMeshType &m, std::vector<Shot<ScalarType> > & shots,
+ std::vector<std::string > & image_filenames,
diff --git a/patch.patch b/patch.patch
new file mode 100644
index 000000000000..274d70ec4c77
--- /dev/null
+++ b/patch.patch
@@ -0,0 +1,13 @@
+diff --git a/wrap/io_trimesh/export_3ds.h b/wrap/io_trimesh/export_3ds.h
+index 387222f5..9a473b75 100644
+--- vcglib/wrap/io_trimesh/export_3ds.h
++++ b/wrap/io_trimesh/export_3ds.h
+@@ -362,7 +362,7 @@ namespace io {
+
+ if((mask & vcg::tri::io::Mask::IOM_FACECOLOR) | (mask & vcg::tri::io::Mask::IOM_WEDGTEXCOORD))
+ {
+- int material_index = vcg::tri::io::Materials<SaveMeshType>::CreateNewMaterial(m, materials, 0, fi);
++ int material_index = vcg::tri::io::Materials<SaveMeshType>::CreateNewMaterial(m, materials, fi);
+ if(material_index == (int)materials.size())
+ {
+ Lib3dsMaterial *material = lib3ds_material_new();//creates a new material