summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVladimír Vondruš2022-09-17 13:07:28 +0200
committerVladimír Vondruš2022-09-17 13:10:19 +0200
commitbf49fd5c3c92db5f56443e876bd5d4776116785c (patch)
treedffd400a988b499d5526f2ea5b9b34bd50df7c70
parent91470290a52ca3cbf8faaa2cdbc4a96f6e2d5cb8 (diff)
downloadaur-bf49fd5c3c92db5f56443e876bd5d4776116785c.tar.gz
Drop -Werror, causes compilation to break with -march=native and AVX512.
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD13
-rw-r--r--no-error.patch13
3 files changed, 26 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a77823ed2607..a9f3fd541f2c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,15 @@
pkgbase = meshoptimizer
pkgdesc = Mesh optimization library that makes meshes smaller and faster to render
pkgver = 0.18
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/zeux/meshoptimizer
arch = x86_64
license = MIT
makedepends = cmake
makedepends = ninja
source = https://github.com/zeux/meshoptimizer/archive/v0.18.tar.gz
+ source = no-error.patch
sha256sums = f5bc07d7322e6292fe0afce03462b5c394d111386236f926fdc44d2aff3b854b
+ sha256sums = 2ab7614fed032a45ad3b9038b736bb7617c8c564d943b39f3b4c5fa26a4e4db1
pkgname = meshoptimizer
diff --git a/PKGBUILD b/PKGBUILD
index 329c80031105..4d5e208e32fe 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,21 @@
# Author: mosra <mosra@centrum.cz>
pkgname=meshoptimizer
pkgver=0.18
-pkgrel=1
+pkgrel=2
pkgdesc='Mesh optimization library that makes meshes smaller and faster to render'
arch=(x86_64)
url='https://github.com/zeux/meshoptimizer'
license=(MIT)
makedepends=(cmake ninja)
-source=("https://github.com/zeux/meshoptimizer/archive/v$pkgver.tar.gz")
-sha256sums=('f5bc07d7322e6292fe0afce03462b5c394d111386236f926fdc44d2aff3b854b')
+source=("https://github.com/zeux/meshoptimizer/archive/v$pkgver.tar.gz"
+ "no-error.patch")
+sha256sums=('f5bc07d7322e6292fe0afce03462b5c394d111386236f926fdc44d2aff3b854b'
+ '2ab7614fed032a45ad3b9038b736bb7617c8c564d943b39f3b4c5fa26a4e4db1')
+
+prepare() {
+ cd "$srcdir/meshoptimizer-$pkgver"
+ patch -p1 < $srcdir/no-error.patch
+}
build() {
mkdir -p build && cd build
diff --git a/no-error.patch b/no-error.patch
new file mode 100644
index 000000000000..157dcced15ff
--- /dev/null
+++ b/no-error.patch
@@ -0,0 +1,13 @@
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index b13d946..dc20be0 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -57,7 +57,7 @@ set(GLTF_SOURCES
+ if(MSVC)
+ add_compile_options(/W4 /WX)
+ else()
+- add_compile_options(-Wall -Wextra -Wshadow -Wno-missing-field-initializers -Werror)
++ add_compile_options(-Wall -Wextra -Wshadow -Wno-missing-field-initializers)
+ endif()
+
+ if(MESHOPT_BUILD_SHARED_LIBS)