summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTheowhy2019-01-01 23:03:04 +0100
committerTheowhy2019-01-01 23:03:04 +0100
commit2801a7ef6b69d3f2492724dc5b0d1f0c32c913a4 (patch)
tree61548fc853c4bb95322c62524440b14549a44f7f
downloadaur-2801a7ef6b69d3f2492724dc5b0d1f0c32c913a4.tar.gz
Initial package release. Version 1.2.39
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD38
2 files changed, 53 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..184d9db0323b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = mfgtools
+ pkgdesc = Freescale/NXP I.MX Chip image deploy tools
+ pkgver = 1.2.39
+ pkgrel = 1
+ url = https://github.com/NXPmicro/mfgtools
+ arch = x86_64
+ license = BSD
+ depends = bzip2
+ depends = zlib
+ depends = libusb
+ source = https://github.com/NXPmicro/mfgtools/archive/uuu_1.2.39.tar.gz
+ sha256sums = 3bcc473536cb883656172c6c07357477752b3cef816de4295434338ce10699ac
+
+pkgname = mfgtools
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ae8504bd1913
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: Theowhy <aur.theowhy@shizoku.fr>
+pkgname=mfgtools
+pkgver=1.2.39
+pkgrel=1
+pkgdesc="Freescale/NXP I.MX Chip image deploy tools"
+arch=(x86_64)
+url="https://github.com/NXPmicro/mfgtools"
+license=('BSD')
+groups=()
+depends=('bzip2' 'zlib' 'libusb')
+makedepends=()
+optdepends=()
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=
+changelog=
+source=(https://github.com/NXPmicro/mfgtools/archive/uuu_$pkgver.tar.gz)
+noextract=()
+sha256sums=('3bcc473536cb883656172c6c07357477752b3cef816de4295434338ce10699ac')
+
+build() {
+ cd "$pkgname-uuu_$pkgver"
+ echo "#define GIT_VERSION \"uuu_$pkgver\"" > libuuu/gitversion.h
+ mkdir -p build
+ cd build
+
+ cmake -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_BUILD_TYPE=Release ..
+ make
+}
+
+package() {
+ cd "$pkgname-uuu_$pkgver/build"
+
+ make DESTDIR="$pkgdir/" install
+}