summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTheowhy2022-04-04 22:33:05 +0200
committerTheowhy2022-04-04 22:38:26 +0200
commit2c168d45f91e94be36a3c894c382025e829cfa73 (patch)
treee4fb98c0ed046ecad872eaf1b4e060230c80fe02
parent3fea5df0cb7417171f3613c00e83eff218471fbb (diff)
downloadaur-2c168d45f91e94be36a3c894c382025e829cfa73.tar.gz
Update package to 1.4.193 and add changes from jjguti
-rw-r--r--.SRCINFO9
-rw-r--r--History.md36
-rw-r--r--PKGBUILD28
3 files changed, 49 insertions, 24 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 78ac4bc7329c..4712bce1a09c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,21 +1,20 @@
pkgbase = mfgtools
pkgdesc = Freescale/NXP I.MX Chip image deploy tools
- pkgver = 1.4.165
+ pkgver = 1.4.193
pkgrel = 1
url = https://github.com/NXPmicro/mfgtools
changelog = History.md
arch = x86_64
license = BSD
makedepends = cmake
- makedepends = git
depends = bzip2
depends = zlib
depends = libusb
depends = libzip
depends = openssl
- source = git+https://github.com/NXPmicro/mfgtools#tag=uuu_1.4.165
+ source = https://github.com/NXPmicro/mfgtools/releases/download/uuu_1.4.193/uuu_source-1.4.193.tar.gz
source = uuu-complete.bash
- sha256sums = SKIP
- sha256sums = SKIP
+ sha256sums = a9b8b74e32e6718d591c66951b8b52276df7862db80ee943e046947f7313e57f
+ sha256sums = ffc8e32655ce574a4719c85c5c9a3530a5ec619e933fc801a291df8ec506a442
pkgname = mfgtools
diff --git a/History.md b/History.md
index 33b8850bc88d..7cec9ec55ce9 100644
--- a/History.md
+++ b/History.md
@@ -1,4 +1,40 @@
+uuu_1.4.193 / 2022-01-18
+========================
+
+ * consolidated libusb_init and libusb_deinit into CAutoDeInit
+
+uuu_1.4.191 / 2022-01-04
+========================
+
+ * Fixed 314 Corrupt image with larger transfer sizes at sdp(s)
+ * fixed missed true at else branch at built-in script
+ * Added CAutoDeInit to call libusb_exit() automatically
+ * Replaced all libusb_get_device_list calls with CAutoList objects
+ * can't call libusb_exit at uuu_for_each_devices
+ * fixed missed call libusb_free_device_list at look_for_match_device
+ * Fixed invalid progress percentage in verbose mode
+
+uuu_1.4.182 / 2021-12-13
+========================
+
+ * Add NXP FB/FBK/SDPV device PID
+ * Fixed QSPI flashing script
+ * Fix cmake warning related to uuu tool
+ * Add zlib1g-dev to fix snap build failure
+
+uuu_1.4.174 / 2021-11-04
+========================
+
+ * Fix invalid test on fastboot_bytes on lst script
+ * ubuntu 16 still use old libusb version
+ * Fix depracated method TLSv1_2_client_method
+ * Remove depracated function libusb_set_debug
+ * Remove dependences from fastboot_bytes that is specific to freescale uboot
+ * fix #297 print error when run quit cmd in shell mode
+ * remove unnecessary libzip dependency
+ * Fix #180 support check getval return value
+
uuu_1.4.165 / 2021-09-28
========================
diff --git a/PKGBUILD b/PKGBUILD
index 6daf7b467b60..bfb55d814194 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,34 +1,24 @@
# Maintainer: Theowhy <aur.theowhy@shizoku.fr>
# Contributor: jpkotta
pkgname=mfgtools
-pkgver=1.4.165
+pkgver=1.4.193
pkgrel=1
pkgdesc="Freescale/NXP I.MX Chip image deploy tools"
arch=(x86_64)
url="https://github.com/NXPmicro/mfgtools"
license=('BSD')
-groups=()
depends=('bzip2' 'zlib' 'libusb' 'libzip' 'openssl')
-makedepends=('cmake' 'git')
-optdepends=()
-provides=()
-conflicts=()
-replaces=()
-backup=()
-options=()
-install=
+makedepends=('cmake')
changelog=History.md
-source=(git+https://github.com/NXPmicro/mfgtools#tag=uuu_$pkgver uuu-complete.bash)
-noextract=()
-sha256sums=(SKIP SKIP)
+source=(https://github.com/NXPmicro/mfgtools/releases/download/uuu_$pkgver/uuu_source-$pkgver.tar.gz uuu-complete.bash)
+sha256sums=('a9b8b74e32e6718d591c66951b8b52276df7862db80ee943e046947f7313e57f'
+ 'ffc8e32655ce574a4719c85c5c9a3530a5ec619e933fc801a291df8ec506a442')
-pkgver() {
- cd "$pkgname"
- git describe --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g;s/uuu_//g'
-}
build() {
- cd "$pkgname"
+ cd "uuu-$pkgver"
+ # Remove useless folders to make
+ rm -Rf -- bzip2 libusb msvc zlib
mkdir -p build
cd build
@@ -37,7 +27,7 @@ build() {
}
package() {
- cd "$pkgname/build"
+ cd "uuu-$pkgver/build"
make DESTDIR="$pkgdir/" install