summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTheowhy2019-07-04 23:57:55 +0200
committerTheowhy2019-07-04 23:57:55 +0200
commit403a79c9e47a75cbc3ba0e4f1370c4e28f8d6f34 (patch)
tree607e2d5a2418283f338acbcae62f801526e11ddb
parent4d86dc21ca1f9525826420ad003c99b3d5104c99 (diff)
downloadaur-403a79c9e47a75cbc3ba0e4f1370c4e28f8d6f34.tar.gz
Now use git source directly and bump version to 1.2.135
Replace use of source tarball in favor of git+https source. This allows to remove the manual generation of gitversion.h file from PKGBUILD
-rw-r--r--.SRCINFO6
-rw-r--r--History.md26
-rw-r--r--PKGBUILD16
3 files changed, 39 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8925dfa28114..b58fbcdbf7d8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = mfgtools
pkgdesc = Freescale/NXP I.MX Chip image deploy tools
- pkgver = 1.2.91
+ pkgver = 1.2.135
pkgrel = 1
url = https://github.com/NXPmicro/mfgtools
changelog = History.md
@@ -9,8 +9,8 @@ pkgbase = mfgtools
depends = bzip2
depends = zlib
depends = libusb
- source = https://github.com/NXPmicro/mfgtools/archive/uuu_1.2.91.tar.gz
- sha256sums = 378caa930fdc1b06d49abf26811827f12103d995438b91302a7c6e34368419f9
+ source = git+https://github.com/NXPmicro/mfgtools#tag=uuu_1.2.135
+ sha256sums = SKIP
pkgname = mfgtools
diff --git a/History.md b/History.md
index 7f342a3b8d42..7489ad0b819e 100644
--- a/History.md
+++ b/History.md
@@ -1,4 +1,30 @@
+uuu_1.2.135 / 2019-05-28
+========================
+
+ * Fix decompress data missed bug when use sdcard.bz2/* if enable -O2
+
+uuu_1.2.130 / 2018-07-20
+========================
+
+ * Support i.MX 815 chip
+ * add license shield io
+ * fix crash when console 47 < width < 54
+ * Increase string size for device numeration
+ * Fixed Typo
+ * Typo in Debian/Ubuntu dependencies
+ * Remove xcode8 build
+ * build: Only create gitversion.h on success
+ * gen_ver.sh: Don't ignore errors
+ * version: Drop GIT_VERSION define
+ * enable -O2 for build option
+ * Add imx28 support
+ * libuuu: add commands for reading and writting a memory address for iMX6/iMX7
+ * uuu: resize status bar for longer error messages
+ * libuuu: remove redefinitions of ROM_WRITE_ACK, ROM_STATUS_ACK and ROM_OK_ACK
+ * Only run sdps log read when write success.
+ * improve build-in list to burn different files
+
uuu_1.2.91 / 2019-02-25
=======================
diff --git a/PKGBUILD b/PKGBUILD
index a5d2c23a3c48..dbbf9e2d0270 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Theowhy <aur.theowhy@shizoku.fr>
# Contributor:
pkgname=mfgtools
-pkgver=1.2.91
+pkgver=1.2.135
pkgrel=1
pkgdesc="Freescale/NXP I.MX Chip image deploy tools"
arch=(x86_64)
@@ -18,13 +18,17 @@ backup=()
options=()
install=
changelog=History.md
-source=(https://github.com/NXPmicro/mfgtools/archive/uuu_$pkgver.tar.gz)
+source=(git+https://github.com/NXPmicro/mfgtools#tag=uuu_1.2.135)
noextract=()
-sha256sums=('378caa930fdc1b06d49abf26811827f12103d995438b91302a7c6e34368419f9')
+sha256sums=(SKIP)
+
+pkgver() {
+ cd "$pkgname"
+ git describe --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g;s/uuu_//g'
+}
build() {
- cd "$pkgname-uuu_$pkgver"
- echo "#define GIT_VERSION \"uuu_$pkgver\"" > libuuu/gitversion.h
+ cd "$pkgname"
mkdir -p build
cd build
@@ -33,7 +37,7 @@ build() {
}
package() {
- cd "$pkgname-uuu_$pkgver/build"
+ cd "$pkgname/build"
make DESTDIR="$pkgdir/" install
}