summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGiacoLenzo21092021-02-25 22:15:46 +0100
committerGiacoLenzo21092021-02-25 22:15:46 +0100
commitb8040c07abb401290e9466a9aeaf5f4b8f1d1481 (patch)
tree336dd3b255fc33c117e2cd8f9d0e1ab8549f6f5f
downloadaur-mhwd-croco-git.tar.gz
Upload
-rw-r--r--.SRCINFO33
-rw-r--r--PKGBUILD51
-rw-r--r--mhwd.install28
3 files changed, 112 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..814f824fb9a3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,33 @@
+pkgbase = mhwd-croco-git
+ pkgdesc = mhwd-croco(manjaro's mhwd backported to archlinux with additional features and limited to only dkms drivers)
+ pkgver = r11.b17a3eb
+ pkgrel = 1
+ url = https://gitlab.com/croco-linux/applications/mhwd-croco
+ arch = any
+ license = GPL
+ makedepends = git
+ makedepends = cmake
+ depends = gcc-libs
+ depends = hwinfo
+ source = git+https://gitlab.com/croco-linux/applications/mhwd-croco.git#branch=master
+ sha256sums = SKIP
+
+pkgname = mhwd-croco-git
+ pkgdesc = mhwd-croco(manjaro's mhwd backported to archlinux with additional features and limited to only dkms drivers)
+ install = mhwd.install
+ depends = hwinfo
+ depends = mesa
+ depends = mhwd-db-croco-git
+ depends = pacman
+ depends = mesa-demos
+ depends = vulkan-tools
+ depends = libva-utils
+ depends = vdpauinfo
+ depends = vulkan-icd-loader
+ depends = opencl-icd-loader
+ provides = mhwd
+ provides = mhwd-croco
+ conflicts = mhwd
+ conflicts = mhwd-croco
+ replaces = mhwd-croco
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5c68f607817b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,51 @@
+# Maintainer: Librewish <librewish@gmail.com>
+# Contributer : Philip Müller <philm[at]manjaro[dog]org>
+# Contributer : Roland Singer <roland[at]manjaro[dog]org>
+
+pkgbase=mhwd-croco-git
+pkgname=('mhwd-croco-git')
+pkgver=r11.b17a3eb
+pkgrel=1
+pkgdesc="mhwd-croco(manjaro's mhwd backported to archlinux with additional features and limited to only dkms drivers)"
+arch=('any')
+_branch='master'
+url="https://gitlab.com/croco-linux/applications/mhwd-croco"
+license=('GPL')
+depends=('gcc-libs' 'hwinfo')
+makedepends=('git' 'cmake')
+_git=yes
+source=("git+$url.git#branch=${_branch}")
+sha256sums=('SKIP')
+pkgver() {
+ cd "$srcdir/mhwd-croco"
+
+# Git, no tags available
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+
+}
+
+build() {
+ cd ${srcdir}/mhwd-croco
+
+ if [ -e ${srcdir}/../mhwd-${pkgver}-${pkgrel}.patch ]; then
+ patch -Np1 -i ${srcdir}/../mhwd-${pkgver}-${pkgrel}.patch
+ fi
+
+ cmake ./
+ make all
+}
+
+package_mhwd-croco-git() {
+ pkgdesc="mhwd-croco(manjaro's mhwd backported to archlinux with additional features and limited to only dkms drivers)"
+ depends=('hwinfo' 'mesa' 'mhwd-db-croco-git' 'pacman' 'mesa-demos' 'vulkan-tools' 'libva-utils' 'vdpauinfo' 'vulkan-icd-loader' 'opencl-icd-loader')
+ depends_x86_64=("lib32-mesa" "lib32-mesa-demos" "lib32-vulkan-icd-loader" "lib32-opencl-icd-loader")
+ provides=("mhwd" "mhwd-croco")
+ conflicts=("mhwd" "mhwd-croco")
+ replaces=("mhwd-croco")
+ install=mhwd.install
+
+ cd ${srcdir}/mhwd-croco
+
+ make DESTDIR="${pkgdir}" install
+ install -d -m755 ${pkgdir}/var/lib/mhwd/{db,local}/{pci,usb}
+}
diff --git a/mhwd.install b/mhwd.install
new file mode 100644
index 000000000000..4a3131b9fb5c
--- /dev/null
+++ b/mhwd.install
@@ -0,0 +1,28 @@
+err() {
+ ALL_OFF="\e[1;0m"
+ BOLD="\e[1;1m"
+ RED="${BOLD}\e[1;31m"
+ local mesg=$1; shift
+ printf "${RED}==>${ALL_OFF}${BOLD} ${mesg}${ALL_OFF}\n" "$@" >&2
+}
+
+msg() {
+ ALL_OFF="\e[1;0m"
+ BOLD="\e[1;1m"
+ GREEN="${BOLD}\e[1;32m"
+ local mesg=$1; shift
+ printf "${GREEN}==>${ALL_OFF}${BOLD} ${mesg}${ALL_OFF}\n" "$@" >&2
+}
+
+post_install() {
+ mhwd-gpu --check
+}
+
+post_upgrade() {
+ mhwd-gpu --check
+}
+
+
+post_remove() {
+ mhwd-gpu --check
+}