summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristophe-Marie Duquesne2015-06-14 18:14:54 +0200
committerChristophe-Marie Duquesne2015-06-14 18:14:54 +0200
commite7b30e4d22051fcca22bdb5481585130c52131d4 (patch)
tree95fdc1bf952032486d0441dbebcc39735715cf49
downloadaur-michel-git.tar.gz
initial commit
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD30
2 files changed, 50 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..05383adc558c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = michel-git
+ pkgdesc = push/pull flat text files to gtasks
+ pkgver = 0.r25.d789243
+ pkgrel = 1
+ url = http://github.com/chmduquesne/michel
+ arch = any
+ license = Public Domain
+ makedepends = python2-distribute
+ makedepends = git
+ depends = python2-google-api-python-client
+ depends = python2-gflags
+ depends = python2-httplib2
+ depends = pyxdg
+ depends = python2-oauth2
+ provides = michel
+ source = michel-git::git+http://github.com/chmduquesne/michel.git
+ md5sums = SKIP
+
+pkgname = michel-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..73edad4e7c60
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Christophe-Marie Duquesne <chmd@chmd.fr>
+
+pkgname=michel-git
+pkgdesc="push/pull flat text files to gtasks"
+url="http://github.com/chmduquesne/michel"
+depends=(
+ 'python2-google-api-python-client'
+ 'python2-gflags'
+ 'python2-httplib2'
+ 'pyxdg'
+ 'python2-oauth2')
+makedepends=('python2-distribute' 'git')
+provides=('michel')
+license=('Public Domain')
+arch=('any')
+pkgver=0.r25.d789243
+pkgrel=1
+source=("$pkgname"::'git+http://github.com/chmduquesne/michel.git')
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/$pkgname"
+ printf "0.r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "$srcdir/$pkgname"
+ python2 setup.py install --root="$pkgdir" --optimize=1
+ chmod +r ${pkgdir}/* -R
+}