summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGeorge Rawlinson2023-05-22 20:13:19 +1200
committerGeorge Rawlinson2023-05-22 20:13:19 +1200
commita43c2d84e9d922c250ea7502f08d9598ffe4d894 (patch)
treea905ea61c03a80db5740cbd090fa03895c6eae3d
parentdd4c73a7c7fc4d4acd57d61289b3169acc8eb5d6 (diff)
downloadaur-mightymike.tar.gz
fix: gcc 13 ftbfs
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD13
2 files changed, 10 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 496b4acb79ac..6a38455a023c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = mightymike
pkgdesc = High Powered Action Rescue in a Toy Store Gone Mad
pkgver = 3.0.2
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/jorio/mightymike
arch = x86_64
license = custom:CC-BY-NC-SA-4.0
diff --git a/PKGBUILD b/PKGBUILD
index 3b0e2e7ad804..09e1d6beaee5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=mightymike
pkgver=3.0.2
-pkgrel=1
+pkgrel=2
pkgdesc='High Powered Action Rescue in a Toy Store Gone Mad'
arch=('x86_64')
url='https://github.com/jorio/mightymike'
@@ -30,9 +30,14 @@ pkgver() {
prepare() {
cd "$pkgname"
+ # setup git submodules
git submodule init
git config submodule.extern/Pomme.url "$srcdir/github.com-jorio-Pomme"
git -c protocol.file.allow=always submodule update
+
+ # ftbfs: gcc 13 & cstdint headers
+ cd extern/Pomme
+ git cherry-pick --no-commit d57c28e205462e51063e787f9ebddaadff592f1e
}
build() {
@@ -41,9 +46,9 @@ build() {
cmake \
-S . \
-B build \
- -DCMAKE_BUILD_TYPE=None \
- -DCMAKE_INSTALL_PREFIX=/usr \
- -Wno-dev
+ -D CMAKE_BUILD_TYPE=None \
+ -D CMAKE_INSTALL_PREFIX=/usr \
+ -W no-dev
cmake --build build
}