summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorShadowKyogre2016-08-15 10:47:09 -0700
committerShadowKyogre2016-08-15 11:01:19 -0700
commit49daddbbbb742b7cf85e614e047d1f7f9b62fd4b (patch)
tree55b37fd365b291792b9004c5df14dca242e39d67
parent085035ba5c6208189f61a888d4ced24890863be9 (diff)
downloadaur-mikidown.tar.gz
Bump to 0.3.11
-rw-r--r--.SRCINFO10
-rw-r--r--.gitignore3
-rw-r--r--PKGBUILD33
3 files changed, 28 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b2954ff4cbb1..86291b4ce3fb 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,14 @@
+# Generated by mksrcinfo v8
+# Mon Aug 15 17:46:21 UTC 2016
pkgbase = mikidown
pkgdesc = A note taking application featuring markdown syntax
- pkgver = 0.3.10
+ pkgver = 0.3.11
pkgrel = 1
url = http://shadowkyogre.github.io/mikidown/
arch = any
license = MIT
depends = python
- depends = pyqt
+ depends = python-pyqt5
depends = python-markdown
depends = python-whoosh
optdepends = python-pygments: for code block syntax highlighting
@@ -15,8 +17,8 @@ pkgbase = mikidown
optdepends = python-asciimathml: for asciimath support
optdepends = python-html2text: for converting to markdown (instead of HTML pasting)
optdepends = slickpicker: for better color picking in mikidown for the highlighting color scheme
- source = https://pypi.python.org/packages/source/m/mikidown/mikidown-0.3.10.tar.gz
- md5sums = 3bced7091442d681ba7d681c606a8fd2
+ source = https://pypi.python.org/packages/20/a0/94eab1cf9468b5772eb6b9cca843f8a3fda5ead5f7326ec2ea40f5499ee6/mikidown-0.3.11.tar.gz
+ md5sums = 5f54f665d526f95f93171143d1ab5fb2
pkgname = mikidown
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..a5401c5d685d
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,3 @@
+pkg/
+src/
+*.pkg.tar.xz
diff --git a/PKGBUILD b/PKGBUILD
index 27d0ffcb31c9..042ad635d239 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,28 +1,33 @@
# Maintainer: rnons <remotenonsense at gmail dot com>
# Maintainer: ShadowKyogre <shadowkyogre dot public at gmail dot com>
+_url_hashid="20/a0/94eab1cf9468b5772eb6b9cca843f8a3fda5ead5f7326ec2ea40f5499ee6"
pkgname=mikidown
-pkgver=0.3.10
+pkgver=0.3.11
pkgrel=1
pkgdesc="A note taking application featuring markdown syntax"
arch=('any')
url="http://shadowkyogre.github.io/mikidown/"
license=('MIT')
-depends=('python'
- 'pyqt'
- 'python-markdown'
- 'python-whoosh')
-optdepends=('python-pygments: for code block syntax highlighting'
- 'python-pyenchant: for spellchecking'
- 'aspell-en: pyenchant need backend support from aspell'
- 'python-asciimathml: for asciimath support'
- 'python-html2text: for converting to markdown (instead of HTML pasting)'
- 'slickpicker: for better color picking in mikidown for the highlighting color scheme')
-source=("https://pypi.python.org/packages/source/m/mikidown/mikidown-$pkgver.tar.gz")
+depends=(
+ 'python'
+ 'python-pyqt5'
+ 'python-markdown'
+ 'python-whoosh'
+)
+optdepends=(
+ 'python-pygments: for code block syntax highlighting'
+ 'python-pyenchant: for spellchecking'
+ 'aspell-en: pyenchant need backend support from aspell'
+ 'python-asciimathml: for asciimath support'
+ 'python-html2text: for converting to markdown (instead of HTML pasting)'
+ 'slickpicker: for better color picking in mikidown for the highlighting color scheme'
+)
+source=("https://pypi.python.org/packages/${_url_hashid}/mikidown-0.3.11.tar.gz")
package() {
cd "$srcdir/mikidown-$pkgver"
- lrelease-qt4 mikidown.pro
+ lrelease-qt5 mikidown.pro
python setup.py install --root="$pkgdir"
}
-md5sums=('3bced7091442d681ba7d681c606a8fd2')
+md5sums=('5f54f665d526f95f93171143d1ab5fb2')