summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFabioLolix2024-04-01 14:12:20 +0200
committerFabioLolix2024-04-01 14:12:20 +0200
commite5a6610c9b9069c45025709da7082e4567d12b5e (patch)
treead295bd6edca9e7551274aabc5a0f6cdd4e8a321
parent85a3d5e7a846c9257c39b2037110fa76b3c46096 (diff)
downloadaur-mindforger.tar.gz
v2.0.0
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD9
2 files changed, 5 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0c0bd6481e28..023c3c42112a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = mindforger
pkgdesc = Thinking notebook and Markdown IDE. Search, browse, view and edit your Markdown files. Get as much as possible from knowledge in your remarks
- pkgver = 1.54.0
+ pkgver = 2.0.0
pkgrel = 1
url = https://www.mindforger.com/
arch = x86_64
@@ -16,13 +16,11 @@ pkgbase = mindforger
depends = qt5-webkit
depends = zlib
depends = hunspell
- source = git+https://github.com/dvorka/mindforger.git#tag=1.54.0
+ source = git+https://github.com/dvorka/mindforger.git#tag=2.0.0
source = git+https://github.com/dvorka/mindforger-repository.git
- source = mindforger-MITIE::git+https://github.com/dvorka/MITIE.git
source = mindforger-cmark::git+https://github.com/dvorka/cmark.git
sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
- sha256sums = SKIP
pkgname = mindforger
diff --git a/PKGBUILD b/PKGBUILD
index 2082b4313750..cbe77fa5ac60 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Maintainer: Maxim Mikityanskiy <maxtram95@gmail.com>
pkgname=mindforger
-pkgver=1.54.0
+pkgver=2.0.0
pkgrel=1
pkgdesc="Thinking notebook and Markdown IDE. Search, browse, view and edit your Markdown files. Get as much as possible from knowledge in your remarks"
arch=(x86_64 i686 arm armv6h armv7h aarch64)
@@ -10,20 +10,17 @@ url="https://www.mindforger.com/"
license=(GPL2)
depends=(qt5-base qt5-webkit zlib hunspell)
makedepends=(git cmake)
-source=("git+https://github.com/dvorka/mindforger.git#tag=$pkgver"
+source=("git+https://github.com/dvorka/mindforger.git#tag=${pkgver}"
"git+https://github.com/dvorka/mindforger-repository.git"
- "mindforger-MITIE::git+https://github.com/dvorka/MITIE.git"
"mindforger-cmark::git+https://github.com/dvorka/cmark.git")
sha256sums=('SKIP'
'SKIP'
- 'SKIP'
'SKIP')
prepare() {
cd "$pkgname"
git submodule init
git config 'submodule.doc.url' "${srcdir}/mindforger-repository"
- git config 'submodule.deps/mitie.url' "${srcdir}/mindforger-MITIE"
git config 'submodule.deps/cmark-gfm.url' "${srcdir}/mindforger-cmark"
git -c protocol.file.allow=always submodule update
}
@@ -31,7 +28,7 @@ prepare() {
build() {
mkdir -p "$srcdir/$pkgname"/deps/cmark-gfm/build
cd "$srcdir/$pkgname"/deps/cmark-gfm/build
- cmake -DCMARK_TESTS=OFF -DCMARK_SHARED=OFF ..
+ cmake -DCMARK_TESTS=OFF -DCMARK_SHARED=OFF -Wno-dev ..
cmake --build .
cd "$srcdir/$pkgname"