summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorYurii Kolesnykov2020-04-04 19:51:38 +0300
committerYurii Kolesnykov2020-04-04 19:51:38 +0300
commit7bbccb49872dead44dc5922422d70d00d21561e7 (patch)
treead00718c2edeedd04e5c11e639fd47082c1043b8
parentfec04d46964382965f73cd5578ed8ab1a5e24333 (diff)
downloadaur-7bbccb49872dead44dc5922422d70d00d21561e7.tar.gz
2.1.13509
Signed-off-by: Yurii Kolesnykov <root@yurikoles.com>
-rw-r--r--.SRCINFO26
-rw-r--r--PKGBUILD34
-rwxr-xr-xminecraft29
-rw-r--r--minecraft.desktop9
-rw-r--r--minecraft.install21
5 files changed, 34 insertions, 85 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2b64138b735d..9377a3e8d468 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,28 @@
pkgbase = minecraft
- pkgdesc = An open-world game whose gameplay revolves around breaking and placing blocks
- pkgver = latest
- pkgrel = 30
+ pkgdesc = Minecraft Launcher
+ pkgver = 2.1.13509
+ pkgrel = 1
url = https://www.minecraft.net/
- install = minecraft.install
arch = any
license = custom
- depends = java-runtime>=8
+ depends = java-runtime
depends = xorg-xrandr
- depends = ttf-font
+ depends = libxss
+ depends = libx11
+ depends = libxcb
+ depends = alsa-lib
+ depends = gtk2
+ depends = gtk3
+ depends = gconf
depends = libxtst
- noextract = minecraft.jar
+ depends = nss
+ optdepends = flite: narrator support
+ provides = minecraft-launcher
+ provides = minecraft-launcher-beta
+ conflicts = minecraft-launcher
+ conflicts = minecraft-launcher-beta
source = https://launcher.mojang.com/download/Minecraft.deb
- source = minecraft.install
sha256sums = cd0ae1dc28f029e6bf2c61cb4a36bb244d4129519917d7a17a7f4c8ad98adb37
- sha256sums = 5174152203f11821b88993c77e30f2a56bbfe655f7514114a0f1d0f1a40b0d10
pkgname = minecraft
diff --git a/PKGBUILD b/PKGBUILD
index 9537d06e73ca..6d0457d77e70 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,34 +2,34 @@
# Previous maintainer: Christophe Robin <crobin@nekoo.com>
pkgname=minecraft
-pkgver=latest
-pkgrel=30
-pkgdesc="An open-world game whose gameplay revolves around breaking and placing blocks"
+_pkgname=minecraft-launcher
+pkgver=2.1.13509
+pkgrel=1
+pkgdesc="Minecraft Launcher"
arch=(any)
license=('custom')
url="https://www.minecraft.net/"
-depends=('java-runtime>=8' 'xorg-xrandr' 'ttf-font' 'libxtst')
-noextract=('minecraft.jar')
-source=(https://launcher.mojang.com/download/Minecraft.deb
- minecraft.install)
-sha256sums=('cd0ae1dc28f029e6bf2c61cb4a36bb244d4129519917d7a17a7f4c8ad98adb37'
- '5174152203f11821b88993c77e30f2a56bbfe655f7514114a0f1d0f1a40b0d10')
-install='minecraft.install'
+depends=('java-runtime' 'xorg-xrandr' 'libxss' 'libx11' 'libxcb' 'alsa-lib' 'gtk2' 'gtk3' 'gconf' 'libxtst' 'nss')
+optdepends=('flite: narrator support')
+conflicts=("$_pkgname" "$_pkgname-beta")
+provides=("$_pkgname" "$_pkgname-beta")
+source=(https://launcher.mojang.com/download/Minecraft.deb)
+sha256sums=('cd0ae1dc28f029e6bf2c61cb4a36bb244d4129519917d7a17a7f4c8ad98adb37')
prepare() {
tar xpf data.tar.xz
}
package() {
- install -d "${pkgdir}"/opt/minecraft-launcher
- cp -a "${srcdir}/opt/minecraft-launcher/"* "${pkgdir}/opt/minecraft-launcher/"
+ install -d "${pkgdir}/opt/$_pkgname"
+ cp -a "${srcdir}/opt/${_pkgname}/"* "${pkgdir}/opt/${_pkgname}/"
- install -Dm644 "${srcdir}/usr/share/applications/minecraft-launcher.desktop" \
- "${pkgdir}/usr/share/applications/minecraft-launcher.desktop"
+ install -Dm644 "${srcdir}/usr/share/applications/${_pkgname}.desktop" \
+ "${pkgdir}/usr/share/applications/${_pkgname}.desktop"
- install -Dm644 "${srcdir}/usr/share/icons/hicolor/symbolic/apps/minecraft-launcher.svg" \
- "${pkgdir}/usr/share/icons/hicolor/symbolic/apps/minecraft-launcher.svg"
+ install -Dm644 "${srcdir}/usr/share/icons/hicolor/symbolic/apps/${_pkgname}.svg" \
+ "${pkgdir}/usr/share/icons/hicolor/symbolic/apps/${_pkgname}.svg"
install -d "${pkgdir}/usr/bin"
- ln -s /opt/minecraft-launcher/minecraft-launcher "${pkgdir}/usr/bin/"
+ ln -s "/opt/${_pkgname}/${_pkgname}" "${pkgdir}/usr/bin/"
}
diff --git a/minecraft b/minecraft
deleted file mode 100755
index b10c5f9b3277..000000000000
--- a/minecraft
+++ /dev/null
@@ -1,29 +0,0 @@
-#!/bin/sh
-
-# We need to force Java 8 here since both Java 7 and 9 currently causes the game to crash
-export PATH=/usr/lib/jvm/java-8-openjdk/jre/bin/:/usr/lib/jvm/java-8-jre/jre/bin/:$PATH
-
-# Since launching the minecraft launch from the home directory bypass the update mechanism, I'm adding this
-# small piece of code that will do a checksum of the versions.json file provided by mojang, if a new version
-# of the game is out, I force a download of the launcher just to keep everyone up to date
-
-# those 2 can be overrided if you want
-MC_VERSION_URL=${MC_VERSION_URL:-"https://launchermeta.mojang.com/mc/game/version_manifest.json"}
-MC_SUM_FILE=${MC_SUM_FILE:-"${HOME}/.minecraft/versions.sum"}
-
-# compute sums
-MC_VERSION_SUM=$( curl -s "${MC_VERSION_URL}" | sha256sum | cut -f 1 -d " " )
-MC_CURRENT_SUM=$( cat "$MC_SUM_FILE" 2>/dev/null )
-
-if [ "$MC_VERSION_SUM" != "$MC_CURRENT_SUM" ]; then
- export MC_FORCE_UPDATE=1
- echo "$MC_VERSION_SUM" > "$MC_SUM_FILE"
-fi
-
-if [ -e "${HOME}/.minecraft/launcher.jar" ] && [ -z "$MC_FORCE_UPDATE" ]; then
- exec java -jar "${HOME}/.minecraft/launcher.jar" $@
-else
- exec java -jar /usr/share/minecraft/Minecraft.jar $@
-fi
-
-unset MC_FORCE_UPDATE
diff --git a/minecraft.desktop b/minecraft.desktop
deleted file mode 100644
index f10584ee3178..000000000000
--- a/minecraft.desktop
+++ /dev/null
@@ -1,9 +0,0 @@
-[Desktop Entry]
-Name=Minecraft
-GenericName=Minecraft
-Comment=A game about placing blocks while running from skeletons.
-Exec=minecraft
-Icon=minecraft
-Terminal=false
-Type=Application
-Categories=Game;
diff --git a/minecraft.install b/minecraft.install
deleted file mode 100644
index 8322f294baf5..000000000000
--- a/minecraft.install
+++ /dev/null
@@ -1,21 +0,0 @@
-# This is a default template for a post-install scriptlet.
-# Uncomment only required functions and remove any functions
-# you don't need (and this header).
-
-## arg 1: the new package version
-post_install() {
- echo "PACKAGES NOTES"
- echo "--------------"
- echo ""
- echo "This is the full version of the game, you need a valid account to play it."
- echo "To create an account, connect to http://www.minecraft.net/ and buy the full"
- echo "game from the store. You should then be able to log in and play."
- echo ""
- echo "The game will auto update and store the updated binary and game configuration"
- echo "in ~/.minecraft"
- echo ""
- echo "For Java 9 users, please check the following link: http://bit.ly/2BAzKUP for"
- echo "details about how to run the game properly."
-}
-
-# vim:set ts=2 sw=2 et: