summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartchus2016-03-13 19:05:35 +0100
committerMartchus2016-03-13 19:05:35 +0100
commitaa9460ab70365588239909970c3c2471230e91ce (patch)
treed555bacd4fa0f5d21bca6cca39821c8a5fe06ab0
parentd59b96ccbd56ed23b415f9bb5ab29a12064d8d70 (diff)
downloadaur-aa9460ab70365588239909970c3c2471230e91ce.tar.gz
fixed static libs
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD12
2 files changed, 11 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index db6a7c0b9177..2ee14bf1a48e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Sat Mar 12 15:41:37 UTC 2016
+# Sun Mar 13 18:04:31 UTC 2016
pkgbase = mingw-w64-angleproject
pkgdesc = ANGLE project (mingw-w64)
pkgver = 2.1.r5637.0e49e6b
- pkgrel = 1
+ pkgrel = 2
url = https://chromium.googlesource.com/angle/angle/+/master/README.md
arch = any
license = BSD
diff --git a/PKGBUILD b/PKGBUILD
index f9086b04b37b..9639a44d5185 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@
pkgname=mingw-w64-angleproject
pkgver=2.1.r5637.0e49e6b
-pkgrel=1
+pkgrel=2
pkgdesc='ANGLE project (mingw-w64)'
arch=('any')
url='https://chromium.googlesource.com/angle/angle/+/master/README.md'
@@ -93,6 +93,13 @@ build() {
gyp -D OS=win -D TARGET=$target --format make -D MSVS_VERSION="" --depth . -I ../build/common.gypi ../src/angle.gyp -D angle_gl_library_type=static_library
make -j1 V=1
+ # the static libs produced by the build script are just thin archives so they don't contain any objects themselves
+ # -> repackage them to actually contain the object files
+ for lib in out/Debug/src/lib*.a; do
+ ${_arch}-ar -t $lib | xargs ${_arch}-ar rvs $lib.new && mv $lib.new $lib;
+ ${_arch}-ranlib $lib
+ done
+
popd
done
}
@@ -107,7 +114,6 @@ package() {
cp -Rv ../include/* "${pkgdir}/usr/${_arch}/include/"
${_arch}-strip --strip-unneeded "${pkgdir}/usr/${_arch}/bin/"*.dll
- ${_arch}-strip -g "${pkgdir}/usr/${_arch}/lib/"*.dll.a
- # static libs seem to be thin archives which mustn't be stripped
+ ${_arch}-strip -g "${pkgdir}/usr/${_arch}/lib/"*.a
done
}