summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMladen Milinkovic2019-07-09 01:14:23 +0200
committerMladen Milinkovic2019-07-09 01:14:23 +0200
commit1f0cc97374fe663a47391bf31ca5776e7266ae30 (patch)
tree4c43f14fea599696a562dd8437af46d28b453b16
downloadaur-mingw-w64-crossc.tar.gz
Version 1.6.0
-rw-r--r--.SRCINFO16
-rw-r--r--.gitignore6
-rw-r--r--PKGBUILD56
3 files changed, 78 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3fdf94b35e11
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = mingw-w64-crossc
+ pkgdesc = Portable C wrapper for SPIRV-Cross (mingw-w64)
+ pkgver = 1.6.0
+ pkgrel = 1
+ url = https://github.com/rossy/crossc/
+ arch = any
+ license = APACHE
+ makedepends = git
+ depends = gcc-libs
+ source = git+https://github.com/rossy/crossc.git#tag=v1.6.0
+ source = git+https://github.com/KhronosGroup/SPIRV-Cross.git
+ sha256sums = SKIP
+ sha256sums = SKIP
+
+pkgname = mingw-w64-crossc
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..c98cdbbd9a8b
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,6 @@
+pkg/
+src/
+*.log
+*.sig
+*.tar
+*.xz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f8e0f2021303
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,56 @@
+# Maintainer: Daniel Bermond < gmail-com: danielbermond >
+
+_pkgname=crossc
+pkgname="mingw-w64-${_pkgname}"
+pkgver=1.6.0
+pkgrel=1
+pkgdesc='Portable C wrapper for SPIRV-Cross (mingw-w64)'
+arch=('any')
+url='https://github.com/rossy/crossc/'
+license=('APACHE')
+depends=('gcc-libs')
+makedepends=('git')
+source=("git+https://github.com/rossy/crossc.git#tag=v${pkgver}"
+ 'git+https://github.com/KhronosGroup/SPIRV-Cross.git')
+sha256sums=('SKIP'
+ 'SKIP')
+
+_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
+
+prepare() {
+ for _arch in ${_architectures}; do
+ cp -rf crossc "build-${_arch}"
+ cp -rf SPIRV-Cross "SPIRV-Cross-${_arch}"
+ pushd "build-${_arch}"
+ git submodule init
+ git config --local 'submodule.SPIRV-Cross.url' "${srcdir}/SPIRV-Cross-${_arch}"
+ git submodule update
+ popd
+ done
+ rm -rf crossc SPIRV-Cross
+}
+
+build() {
+ for _arch in ${_architectures}; do
+ pushd "build-${_arch}"
+ unset LDFLAGS
+
+ CXX=/usr/bin/${_arch}-g++ \
+ AR=/usr/bin/${_arch}-ar \
+ make
+ popd
+ done
+}
+
+package() {
+ for _arch in ${_architectures}; do
+ pushd "build-${_arch}"
+ CXX=/usr/bin/${_arch}-g++ \
+ AR=/usr/bin/${_arch}-ar \
+ make DESTDIR="$pkgdir" prefix="/usr/${_arch}" install
+ find "$pkgdir/usr/${_arch}" -name '*.exe' -exec ${_arch}-strip {} \;
+ find "$pkgdir/usr/${_arch}" -name '*.dll' -exec ${_arch}-strip --strip-unneeded {} \;
+ find "$pkgdir/usr/${_arch}" -name '*.a' -o -name '*.dll' | xargs ${_arch}-strip -g
+ popd
+ done
+}