summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorxantares2015-06-08 22:46:52 +0200
committerxantares2015-06-08 22:46:52 +0200
commit2f6807918bd2d98b95e53ce6d45fdf4852147c74 (patch)
treeeeed713dfe1c87d73541dc74927e14419fea8896
downloadaur-2f6807918bd2d98b95e53ce6d45fdf4852147c74.tar.gz
Initial import
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD40
2 files changed, 60 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2f7cf80b4c0f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = mingw-w64-flac
+ pkgdesc = Free Lossless Audio Codec (mingw-w64)
+ pkgver = 1.3.1
+ pkgrel = 5
+ url = http://flac.sourceforge.net/
+ arch = any
+ license = BSD
+ license = GPL
+ makedepends = nasm
+ makedepends = mingw-w64-configure
+ depends = mingw-w64-libogg
+ depends = mingw-w64-crt
+ options = !strip
+ options = !buildflags
+ options = staticlibs
+ source = http://downloads.xiph.org/releases/flac/flac-1.3.1.tar.xz
+ md5sums = b9922c9a0378c88d3e901b234f852698
+
+pkgname = mingw-w64-flac
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..93b4a910665e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# Contributor: naelstrof <naelstrof@gmail.com>
+
+pkgname=mingw-w64-flac
+pkgver=1.3.1
+pkgrel=5
+pkgdesc="Free Lossless Audio Codec (mingw-w64)"
+arch=('any')
+url="http://flac.sourceforge.net/"
+license=('BSD' 'GPL')
+depends=('mingw-w64-libogg' 'mingw-w64-crt')
+makedepends=('nasm' 'mingw-w64-configure')
+options=(!strip !buildflags staticlibs)
+source=("http://downloads.xiph.org/releases/flac/flac-${pkgver}.tar.xz")
+md5sums=('b9922c9a0378c88d3e901b234f852698')
+
+_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
+_pkgname="flac"
+
+build() {
+ cd "$srcdir/${_pkgname}-${pkgver}"
+ for _arch in ${_architectures}; do
+ mkdir -p build-${_arch} && pushd build-${_arch}
+ touch config.rpath
+ ${_arch}-configure --disable-xmms-plugin --disable-sse --disable-asm-optimizations --with-pic
+ make
+ popd
+ done
+}
+
+package() {
+ for _arch in ${_architectures}; do
+ cd ${srcdir}/$_pkgname-$pkgver/build-${_arch}
+ make DESTDIR="$pkgdir/" install
+ rm "$pkgdir"/usr/${_arch}/bin/*.exe
+ rm -r $pkgdir/usr/${_arch}/share/doc/
+ rm -r $pkgdir/usr/${_arch}/share/man/
+ ${_arch}-strip --strip-unneeded "$pkgdir"/usr/${_arch}/bin/*.dll
+ ${_arch}-strip -g "$pkgdir"/usr/${_arch}/lib/*.a
+ done
+}