summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichel Zou2021-03-14 20:05:31 +0100
committerMichel Zou2021-03-14 20:05:31 +0100
commit8c7b97298dc65fc294fcab29d82e773de4e119d4 (patch)
tree16b0614357fcdf5f1bd8ddce4bf73002ea50b81d
downloadaur-mingw-w64-grvk.tar.gz
0.3
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD32
2 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d65913605eb3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = mingw-w64-grvk
+ pkgdesc = Mantle to Vulkan translation layer (mingw-w64)
+ pkgver = 0.3.0
+ pkgrel = 1
+ url = https://github.com/libcg/grvk
+ arch = any
+ license = zlib
+ makedepends = mingw-w64-meson
+ depends = mingw-w64-vulkan-icd-loader
+ options = staticlibs
+ options = !strip
+ options = !buildflags
+ source = https://github.com/libcg/grvk/archive/0.3.0.tar.gz
+ sha256sums = 05072fdd49beed46a099c831d98f20f9d5f86416b288d5ee348b4004c5f020ae
+
+pkgname = mingw-w64-grvk
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9ca66ced11e2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+pkgname=mingw-w64-grvk
+pkgver=0.3.0
+pkgrel=1
+pkgdesc="Mantle to Vulkan translation layer (mingw-w64)"
+arch=('any')
+url="https://github.com/libcg/grvk"
+license=("zlib")
+makedepends=('mingw-w64-meson')
+depends=('mingw-w64-vulkan-icd-loader')
+options=('staticlibs' '!strip' '!buildflags')
+source=("https://github.com/libcg/grvk/archive/${pkgver}.tar.gz")
+sha256sums=('05072fdd49beed46a099c831d98f20f9d5f86416b288d5ee348b4004c5f020ae')
+
+_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
+
+build() {
+ cd "${srcdir}"/grvk-${pkgver}
+ for _arch in ${_architectures}; do
+ ${_arch}-meson build-${_arch}
+ ninja -C build-${_arch} ${MAKEFLAGS}
+ done
+}
+
+package() {
+ cd "${srcdir}"/grvk-${pkgver}
+ for _arch in ${_architectures}; do
+ DESTDIR="$pkgdir" ninja -C build-${_arch} install
+ install -d "$pkgdir"/usr/${_arch}/include/mantle
+ install include/mantle/*.h "$pkgdir"/usr/${_arch}/include/mantle
+ ${_arch}-strip --strip-unneeded "$pkgdir"/usr/${_arch}/bin/*.dll
+ done
+}