summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichel Zou2018-01-12 11:08:49 +0100
committerMichel Zou2018-01-12 11:08:49 +0100
commit35d5bee7c72d41cfb2f317274b029eeee8310108 (patch)
tree5c7fb8ce7c298d0d40dba04de9e6dacddccc9fe8
parentf317f8c6b7c8e7913cc8ced787f7ce69595d20c2 (diff)
downloadaur-mingw-w64-iistaskpanel.tar.gz
fix dl location
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD12
2 files changed, 10 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9bf657fa69fe..38e7cd7344b5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,10 @@
# Generated by mksrcinfo v8
-# Sat Jan 6 20:57:11 UTC 2018
+# Fri Jan 12 10:08:49 UTC 2018
pkgbase = mingw-w64-iistaskpanel
pkgdesc = Qt widget like to Windows XP panel for common tasks of a folder (mingw-w64)
pkgver = 0.2.2
pkgrel = 1
- url = http://qt-apps.org/content/show.php?content=79286
+ url = https://www.linux-apps.com/content/show.php?content=79286
arch = any
license = LGPL
makedepends = mingw-w64-gcc
@@ -13,8 +13,8 @@ pkgbase = mingw-w64-iistaskpanel
options = !buildflags
options = !strip
options = staticlibs
- source = https://dl.opendesktop.org/api/files/downloadfile/id/1466644899/s/97b93167ecee54b359b5644ccb1b177a/t/1515275776/79286-iistaskpanel-0.2.2-src.zip
- sha256sums = daaea72d5e06c5c694f0b657af49287ad611b4bfd96a7db7f7c6b2f888e8c353
+ source = iistaskpanel-0.2.2.tar.gz::https://github.com/xantares/iistaskpanel/archive/v0.2.2.tar.gz
+ sha256sums = 047238dc70633c5b3ea732adaf52fdb4c886262b1571ea492e62e876492ebf55
pkgname = mingw-w64-iistaskpanel
diff --git a/PKGBUILD b/PKGBUILD
index cefad0d0471b..f42540f6fcf2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,17 +4,17 @@ pkgrel=1
pkgdesc="Qt widget like to Windows XP panel for common tasks of a folder (mingw-w64)"
license=('LGPL')
arch=(any)
-url="http://qt-apps.org/content/show.php?content=79286"
+url="https://www.linux-apps.com/content/show.php?content=79286"
depends=('mingw-w64-crt' 'mingw-w64-qt4')
makedepends=('mingw-w64-gcc')
options=('!buildflags' '!strip' 'staticlibs')
-source=("https://dl.opendesktop.org/api/files/downloadfile/id/1466644899/s/97b93167ecee54b359b5644ccb1b177a/t/1515275776/79286-iistaskpanel-0.2.2-src.zip")
-sha256sums=('daaea72d5e06c5c694f0b657af49287ad611b4bfd96a7db7f7c6b2f888e8c353')
+source=("iistaskpanel-${pkgver}.tar.gz::https://github.com/xantares/iistaskpanel/archive/v${pkgver}.tar.gz")
+sha256sums=('047238dc70633c5b3ea732adaf52fdb4c886262b1571ea492e62e876492ebf55')
_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
build() {
- cd "$srcdir/iistaskpanel-${pkgver}-src"
+ cd "$srcdir/iistaskpanel-${pkgver}"
sed -i "s|SUBDIRS = src \\\\|SUBDIRS = src|g" taskpanel.pro
sed -i "s|tests|#tests|g" taskpanel.pro
sed -i "1iCONFIG += shared" taskpanel.pro
@@ -38,12 +38,12 @@ build() {
package() {
for _arch in ${_architectures}; do
- cd "$srcdir/iistaskpanel-${pkgver}-src/build-${_arch}"
+ cd "$srcdir/iistaskpanel-${pkgver}/build-${_arch}"
make INSTALL_ROOT="$pkgdir" install
install -d "$pkgdir"/usr/${_arch}/lib
install -d "$pkgdir"/usr/${_arch}/bin
install -d "$pkgdir"/usr/${_arch}/include/iistaskpanel
- install -m644 $srcdir/iistaskpanel-${pkgver}-src/src/*.h "$pkgdir"/usr/${_arch}/include/iistaskpanel
+ install -m644 $srcdir/iistaskpanel-${pkgver}/src/*.h "$pkgdir"/usr/${_arch}/include/iistaskpanel
install -m644 lib/*.a "$pkgdir"/usr/${_arch}/lib
install -m755 lib/*.dll "$pkgdir"/usr/${_arch}/bin
install -m644 ../build-${_arch}-static/lib/*.a "$pkgdir"/usr/${_arch}/lib