summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichel Zou2021-11-02 18:51:06 +0100
committerMichel Zou2021-11-02 18:51:06 +0100
commitdfd2cbdbbf403bd5840e784e173986107b98f197 (patch)
tree971aa3e852de0ed605c77068537ee8ce048b54a0
downloadaur-mingw-w64-libb2.tar.gz
0.98.1
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD37
2 files changed, 53 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7512abeb1c5e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = mingw-w64-libb2
+ pkgdesc = C library providing BLAKE2b, BLAKE2s, BLAKE2bp, BLAKE2sp hash functions
+ pkgver = 0.98.1
+ pkgrel = 1
+ url = https://blake2.net/
+ arch = any
+ license = custom:CC0
+ makedepends = mingw-w64-configure
+ depends = mingw-w64-crt
+ options = !buildflags
+ options = staticlibs
+ options = !strip
+ source = https://github.com/BLAKE2/libb2/releases/download/v0.98.1/libb2-0.98.1.tar.gz
+ sha256sums = 53626fddce753c454a3fea581cbbc7fe9bbcf0bc70416d48fdbbf5d87ef6c72e
+
+pkgname = mingw-w64-libb2
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f028e6d57f67
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+pkgname=mingw-w64-libb2
+pkgver=0.98.1
+pkgrel=1
+pkgdesc="C library providing BLAKE2b, BLAKE2s, BLAKE2bp, BLAKE2sp hash functions"
+arch=('any')
+url='https://blake2.net/'
+license=('custom:CC0')
+depends=('mingw-w64-crt')
+makedepends=('mingw-w64-configure')
+options=('!buildflags' 'staticlibs' '!strip')
+source=("https://github.com/BLAKE2/libb2/releases/download/v$pkgver/libb2-$pkgver.tar.gz")
+sha256sums=('53626fddce753c454a3fea581cbbc7fe9bbcf0bc70416d48fdbbf5d87ef6c72e')
+
+_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
+
+build() {
+ cd $srcdir/libb2-${pkgver}
+ for _arch in ${_architectures}; do
+ mkdir -p build-${_arch} && pushd build-${_arch}
+ ${_arch}-configure ax_cv_have_mmx_ext=yes \
+ ax_cv_have_sse_ext=yes ax_cv_have_sse2_ext=yes \
+ ax_cv_have_sse3_ext=no ax_cv_have_ssse3_ext=no \
+ ax_cv_have_sse41_ext=no ax_cv_have_sse42_ext=no \
+ ax_cv_have_avx_ext=no ..
+ make
+ popd
+ done
+}
+
+package() {
+ for _arch in ${_architectures}; do
+ cd "$srcdir/libb2-${pkgver}/build-${_arch}"
+ make install DESTDIR="$pkgdir"
+ ${_arch}-strip --strip-unneeded "$pkgdir"/usr/${_arch}/bin/*.dll
+ ${_arch}-strip -g "$pkgdir"/usr/${_arch}/lib/*.a
+ done
+}