summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichel Zou2025-01-23 17:04:58 +0100
committerMichel Zou2025-01-23 17:04:58 +0100
commita5da4b7bec3c3cff014946d72fca42102f331ef0 (patch)
tree6ee1ec70e1f1e3e6716fba3799393aa65c89f4e8
parentff0d027d61409d020b4960a153f2007539c0999c (diff)
downloadaur-mingw-w64-libsvm.tar.gz
fplt
-rw-r--r--PKGBUILD2
1 files changed, 1 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 718785ee485a..5389052bb0fe 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -18,7 +18,7 @@ build()
cd "$srcdir/libsvm-$pkgver"
for _arch in ${_architectures}; do
mkdir -p "build-${_arch}" && pushd "build-${_arch}"
- ${_arch}-c++ -D_FORTIFY_SOURCE=3 -O2 -pipe -fno-plt -fexceptions --param=ssp-buffer-size=4 -Wformat -Werror=format-security -fcf-protection -c ../svm.cpp
+ ${_arch}-c++ -D_FORTIFY_SOURCE=3 -O2 -pipe -fexceptions --param=ssp-buffer-size=4 -Wformat -Werror=format-security -fcf-protection -c ../svm.cpp
${_arch}-c++ -shared -o libsvm.dll svm.o -Wl,--out-implib,libsvm.dll.a -fstack-protector
${_arch}-ar cr libsvm.a svm.o
${_arch}-ranlib libsvm.a