summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNicola Murino2020-11-04 19:10:06 +0100
committerNicola Murino2020-11-04 19:10:06 +0100
commit40b5144c3c011887f6ed09179e0928d6fec54b75 (patch)
tree4c7f2770c3968a5675ca23a734f5b1cfc26611b7
parentf738247c821b57f3fc7839aa8f9f37de7de1515b (diff)
downloadaur-40b5144c3c011887f6ed09179e0928d6fec54b75.tar.gz
suppress warning with meson 0.56
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD4
-rwxr-xr-xtoolchain_generator.py10
3 files changed, 11 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index befaae75dbe4..194641141d01 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = mingw-w64-meson
pkgdesc = Meson wrapper for MinGW (mingw-w64)
pkgver = 1
- pkgrel = 19
+ pkgrel = 20
url = http://fedoraproject.org/wiki/MinGW
arch = any
license = GPL
@@ -13,7 +13,7 @@ pkgbase = mingw-w64-meson
optdepends = mingw-w64-cmake
source = toolchain_generator.py
source = meson-mingw-wrapper
- sha256sums = a598c4f27b4a03063c5515ee2ffb7213ea969f6c64d88979f55c0542729b6b80
+ sha256sums = 20b0c2add1182f2b8cdf53dea7c6fd870989a39abd7713acbce924cde716a85b
sha256sums = c91f2bbcafad7b742f13c6bd46324a03b70066b348621ce6a20f4a05005985ef
pkgname = mingw-w64-meson
diff --git a/PKGBUILD b/PKGBUILD
index fb2d72e14db9..38d3b0e48a8a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: drakkan <nicola.murino at gmail dot com>
pkgname=mingw-w64-meson
pkgver=1
-pkgrel=19
+pkgrel=20
arch=('any')
pkgdesc="Meson wrapper for MinGW (mingw-w64)"
depends=('meson' 'mingw-w64-gcc' 'mingw-w64-pkg-config')
@@ -12,7 +12,7 @@ license=("GPL")
url="http://fedoraproject.org/wiki/MinGW"
source=("toolchain_generator.py"
"meson-mingw-wrapper")
-sha256sums=('a598c4f27b4a03063c5515ee2ffb7213ea969f6c64d88979f55c0542729b6b80'
+sha256sums=('20b0c2add1182f2b8cdf53dea7c6fd870989a39abd7713acbce924cde716a85b'
'c91f2bbcafad7b742f13c6bd46324a03b70066b348621ce6a20f4a05005985ef')
_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
diff --git a/toolchain_generator.py b/toolchain_generator.py
index b9ebb5fcf867..d27550c7a173 100755
--- a/toolchain_generator.py
+++ b/toolchain_generator.py
@@ -24,6 +24,7 @@ class CrossFileGenerator:
config = configparser.ConfigParser()
config['binaries'] = self.get_binaries_section()
config['properties'] = self.get_properties_section()
+ config['built-in options'] = self.get_builtin_options_section()
config['host_machine'] = self.get_host_machine_section()
with open(self.output_file, 'w') as configfile:
config.write(configfile)
@@ -46,11 +47,14 @@ class CrossFileGenerator:
def get_properties_section(self):
return {'root':"'{}'".format(self.arch),
'sys_root':"'/usr/{}'".format(self.arch),
- 'c_args':[f for f in self.cflags.split(" ") if f],
+ 'needs_exe_wrapper':'true'
+ }
+
+ def get_builtin_options_section(self):
+ return {'c_args':[f for f in self.cflags.split(" ") if f],
'cpp_args':[f for f in self.cxxflags.split(" ") if f],
'c_link_args':[f for f in self.ldflags.split(" ") if f],
- 'cpp_link_args':[f for f in self.ldflags.split(" ") if f],
- 'needs_exe_wrapper':'true'
+ 'cpp_link_args':[f for f in self.ldflags.split(" ") if f]
}
def get_host_machine_section(self):