summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNicola Murino2018-04-23 12:40:19 +0200
committerNicola Murino2018-04-23 12:40:19 +0200
commitb241765eb80a11fce660db3dd097c09ce1e57881 (patch)
tree7b4ee59e6d85e6adb85b377521c87e5b0b044862
downloadaur-b241765eb80a11fce660db3dd097c09ce1e57881.tar.gz
Initial version
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD33
-rw-r--r--toolchain-mingw.meson19
3 files changed, 70 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0c65ba469b4b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+# Generated by mksrcinfo v8
+# Mon Apr 23 10:40:03 UTC 2018
+pkgbase = mingw-w64-meson
+ pkgdesc = Meson wrapper for MinGW (mingw-w64)
+ pkgver = 1
+ pkgrel = 1
+ url = http://fedoraproject.org/wiki/MinGW
+ arch = any
+ license = GPL
+ depends = meson
+ depends = mingw-w64-gcc
+ depends = mingw-w64-pkg-config
+ optdepends = wine: runtime support
+ source = toolchain-mingw.meson
+ sha256sums = c8392670b99692b6221efa7c553745f14e1824e0ae5081ad36bf003e83192b8c
+
+pkgname = mingw-w64-meson
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fc439de84dc9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: drakkan <nicola.murino at gmail dot com>
+pkgname=mingw-w64-meson
+pkgver=1
+pkgrel=1
+arch=('any')
+pkgdesc="Meson wrapper for MinGW (mingw-w64)"
+depends=('meson' 'mingw-w64-gcc' 'mingw-w64-pkg-config')
+optdepends=('wine: runtime support')
+license=("GPL")
+url="http://fedoraproject.org/wiki/MinGW"
+source=("toolchain-mingw.meson")
+sha256sums=('c8392670b99692b6221efa7c553745f14e1824e0ae5081ad36bf003e83192b8c')
+_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
+
+build() {
+ for _arch in ${_architectures}; do
+ if [ ${_arch} = "i686-w64-mingw32" ]; then
+ _cpu_family="x86"
+ else
+ _cpu_family="x86_64"
+ fi
+ sed "s|@TRIPLE@|${_arch}|g;s|@PROCESSOR@|${_arch::-12}|g;s|@CPU_FAMILY@|${_cpu_family}|g" toolchain-mingw.meson > toolchain-${_arch}.meson
+ done
+}
+
+package() {
+ install -d "${pkgdir}"/usr/share/mingw
+ for _arch in ${_architectures}; do
+ install -m 644 toolchain-${_arch}.meson "${pkgdir}"/usr/share/mingw/
+ done
+}
+
+# vim: ts=2 sw=2 et:
diff --git a/toolchain-mingw.meson b/toolchain-mingw.meson
new file mode 100644
index 000000000000..3d496a393ab2
--- /dev/null
+++ b/toolchain-mingw.meson
@@ -0,0 +1,19 @@
+[binaries]
+c = '@TRIPLE@-gcc'
+cpp = '@TRIPLE@-g++'
+fortran = '@TRIPLE@-gfortran'
+ar = '@TRIPLE@-ar'
+pkgconfig = '@TRIPLE@-pkg-config'
+ranlib = '@TRIPLE@-ranlib'
+strip = '@TRIPLE@-strip'
+windres = '@TRIPLE@-windres'
+
+[properties]
+root = '@TRIPLE@'
+needs_exe_wrapper = true
+
+[host_machine]
+system = 'windows'
+cpu_family = '@CPU_FAMILY@'
+cpu = '@PROCESSOR@'
+endian = 'little'