summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorkfg2023-05-24 18:22:54 +0200
committerkfg2023-06-09 21:53:02 +0200
commit83c742ecbab75d1e1210d73f42dc0ed6b92e2575 (patch)
tree1291a2a4c2f0d792e46cdc42cadfde9278bdd702
parent53f97e62596f862e5393496e45579bddc4f21999 (diff)
downloadaur-mingw-w64-mygui.tar.gz
upgpkg: mingw-w64-mygui 3.4.2-1
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD31
-rw-r--r--opengl3.patch18
3 files changed, 45 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 03643871684a..2627eda51e59 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = mingw-w64-mygui
pkgdesc = A multilayer and overlappable GUI System (mingw-w64)
- pkgver = 3.4.1
+ pkgver = 3.4.2
pkgrel = 1
url = http://mygui.info/
arch = any
@@ -11,6 +11,7 @@ pkgbase = mingw-w64-mygui
makedepends = doxygen
makedepends = graphviz
makedepends = ttf-dejavu
+ makedepends = ninja
depends = mingw-w64-crt
depends = mingw-w64-sdl2
depends = mingw-w64-sdl2_image
@@ -18,7 +19,9 @@ pkgbase = mingw-w64-mygui
options = !strip
options = !buildflags
options = staticlibs
- source = https://github.com/MyGUI/mygui/archive/MyGUI3.4.1.tar.gz
- sha512sums = 9d36272345b1a755db88848c8a0919feb6f8ae09d048efa3b8ed833bb5ddb9c65e1e7e0d26ad39eecd2a4de53fb654f4099c555e9ebd21ce9541a1a74580ef05
+ source = https://github.com/MyGUI/mygui/archive/MyGUI3.4.2.tar.gz
+ source = opengl3.patch
+ sha512sums = 202f3df35f0767778b5a91b71dbd1ad3409d0a1977d5fbe3f0d48db430276c71b84edc5a28dd1fdb8e60245b56f2bda99872a4d860b83585f08406b28fb850fe
+ sha512sums = 67a36e7424e7e0d8abf1aa3721cefb5f40da280447c68590cec0febb13330d7258a1034a9c9748bd954e529bd5062f311a91dda93074ac3fd8a2132bc88526dd
pkgname = mingw-w64-mygui
diff --git a/PKGBUILD b/PKGBUILD
index f4353c694d0a..572860f6493f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Karl-Felix Glatzer <karl.glatzer@gmx.de>
pkgbase=mingw-w64-mygui
pkgname=('mingw-w64-mygui')
-pkgver=3.4.1
+pkgver=3.4.2
pkgrel=1
pkgdesc="A multilayer and overlappable GUI System (mingw-w64)"
arch=('any')
@@ -9,18 +9,28 @@ url="http://mygui.info/"
license=('LGPL')
depends=('mingw-w64-crt' 'mingw-w64-sdl2' 'mingw-w64-sdl2_image' 'mingw-w64-pkg-config')
options=(!strip !buildflags staticlibs)
-makedepends=('mingw-w64-cmake' 'mingw-w64-gcc' 'mingw-w64-pkg-config' 'doxygen' 'graphviz' 'ttf-dejavu')
-source=("https://github.com/MyGUI/mygui/archive/MyGUI${pkgver}.tar.gz")
-sha512sums=('9d36272345b1a755db88848c8a0919feb6f8ae09d048efa3b8ed833bb5ddb9c65e1e7e0d26ad39eecd2a4de53fb654f4099c555e9ebd21ce9541a1a74580ef05')
+makedepends=('mingw-w64-cmake' 'mingw-w64-gcc' 'mingw-w64-pkg-config' 'doxygen' 'graphviz' 'ttf-dejavu' 'ninja')
+source=("https://github.com/MyGUI/mygui/archive/MyGUI${pkgver}.tar.gz"
+ "opengl3.patch")
+sha512sums=('202f3df35f0767778b5a91b71dbd1ad3409d0a1977d5fbe3f0d48db430276c71b84edc5a28dd1fdb8e60245b56f2bda99872a4d860b83585f08406b28fb850fe'
+ '67a36e7424e7e0d8abf1aa3721cefb5f40da280447c68590cec0febb13330d7258a1034a9c9748bd954e529bd5062f311a91dda93074ac3fd8a2132bc88526dd')
_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
+prepare()
+{
+ cd "${srcdir}/mygui-MyGUI${pkgver}"
+
+ patch -Np1 -i "${srcdir}/opengl3.patch"
+}
+
build() {
for _arch in ${_architectures}; do
# Static build
mkdir -p ${srcdir}/build-${_arch}-static && cd ${srcdir}/build-${_arch}-static
unset LDFLAGS CXXFLAGS
- ${_arch}-cmake .. \
+ ${_arch}-cmake \
+ -GNinja \
-DCMAKE_INSTALL_PREFIX=/usr/${_arch} \
-DMYGUI_INSTALL_SAMPLES=FALSE \
-DMYGUI_INSTALL_TOOLS=FALSE \
@@ -32,13 +42,14 @@ build() {
-DMYGUI_STATIC=TRUE \
-DMYGUI_RENDERSYSTEM=7 \
../mygui-MyGUI${pkgver}
- make
+ ninja
# Shared build
mkdir -p ${srcdir}/build-${_arch} && cd ${srcdir}/build-${_arch}
unset LDFLAGS CXXFLAGS
- ${_arch}-cmake .. \
+ ${_arch}-cmake \
+ -GNinja \
-DCMAKE_INSTALL_PREFIX=/usr/${_arch} \
-DMYGUI_INSTALL_SAMPLES=FALSE \
-DMYGUI_INSTALL_TOOLS=FALSE \
@@ -49,7 +60,7 @@ build() {
-DMYGUI_BUILD_TOOLS=FALSE \
-DMYGUI_RENDERSYSTEM=7 \
../mygui-MyGUI${pkgver}
- make
+ ninja
done
}
@@ -57,11 +68,11 @@ package() {
for _arch in ${_architectures}; do
# Install static binaries
cd ${srcdir}/build-${_arch}-static
- make DESTDIR=${pkgdir} install
+ DESTDIR=${pkgdir} ninja install
# Install shared binaries
cd ${srcdir}/build-${_arch}
- make DESTDIR=${pkgdir} install
+ DESTDIR=${pkgdir} ninja install
mv ${pkgdir}/usr/${_arch}/bin/Release/*.dll ${pkgdir}/usr/${_arch}/bin/
mv ${pkgdir}/usr/${_arch}/lib/Release/*.a ${pkgdir}/usr/${_arch}/lib/
diff --git a/opengl3.patch b/opengl3.patch
new file mode 100644
index 000000000000..a6174116d2de
--- /dev/null
+++ b/opengl3.patch
@@ -0,0 +1,18 @@
+diff -ruN mygui-MyGUI3.4.2/Platforms/OpenGL3/OpenGL3Platform/CMakeLists.txt patched/Platforms/OpenGL3/OpenGL3Platform/CMakeLists.txt
+--- mygui-MyGUI3.4.2/Platforms/OpenGL3/OpenGL3Platform/CMakeLists.txt 2023-05-09 11:46:12.000000000 +0200
++++ patched/Platforms/OpenGL3/OpenGL3Platform/CMakeLists.txt 2023-06-09 21:22:03.549989153 +0200
+@@ -26,8 +26,12 @@
+ if (APPLE)
+ target_link_libraries(${PROJECTNAME} ${OPENGL_gl_LIBRARY} MyGUIEngine)
+ else ()
+- # opengl instead of gl makes it compile and work in a libX11-free wayland setup
+- target_link_libraries(${PROJECTNAME} ${OPENGL_opengl_LIBRARY} MyGUIEngine)
++ if(MINGW)
++ target_link_libraries(${PROJECTNAME} ${OPENGL_gl_LIBRARY} MyGUIEngine)
++ else()
++ # opengl instead of gl makes it compile and work in a libX11-free wayland setup
++ target_link_libraries(${PROJECTNAME} ${OPENGL_opengl_LIBRARY} MyGUIEngine)
++ endif()
+ endif ()
+ if (MYGUI_USE_SYSTEM_GLEW)
+ target_link_libraries(${PROJECTNAME} ${GLEW_LIBRARIES})