summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichel Zou2016-10-25 19:48:16 +0200
committerMichel Zou2016-10-25 19:48:16 +0200
commit4402389084ec75741639dbbf4a4606bcd5e24185 (patch)
tree1c7ed108a65f49fdb16a178c1955760dc42bfca1
downloadaur-mingw-w64-nfft.tar.gz
First build
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD44
2 files changed, 63 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..603344f1045e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+# Generated by mksrcinfo v8
+# Tue Oct 25 17:48:16 UTC 2016
+pkgbase = mingw-w64-nfft
+ pkgdesc = Library for computing Non-uniform Fast Fourier Transforms. (mingw-w64)
+ pkgver = 3.3.2
+ pkgrel = 1
+ url = https://www-user.tu-chemnitz.de/~potts/nfft/
+ arch = any
+ license = GPL2
+ makedepends = mingw-w64-configure
+ depends = mingw-w64-fftw
+ options = staticlibs
+ options = !strip
+ options = !buildflags
+ source = https://github.com/NFFT/nfft/releases/download/3.3.2/nfft-3.3.2.tar.gz
+ md5sums = 13e48b923501ed6feb5130c3be115fc8
+
+pkgname = mingw-w64-nfft
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..297f9aa74865
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,44 @@
+pkgname=mingw-w64-nfft
+pkgver=3.3.2
+pkgrel=1
+pkgdesc="Library for computing Non-uniform Fast Fourier Transforms. (mingw-w64)"
+arch=('any')
+url="https://www-user.tu-chemnitz.de/~potts/nfft/"
+license=("GPL2")
+depends=('mingw-w64-fftw')
+makedepends=('mingw-w64-configure')
+options=(staticlibs !strip !buildflags)
+source=("https://github.com/NFFT/nfft/releases/download/$pkgver/nfft-$pkgver.tar.gz")
+md5sums=('13e48b923501ed6feb5130c3be115fc8')
+
+_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
+
+prepare() {
+ cd "${srcdir}/nfft-${pkgver}"
+
+ wget https://github.com/NFFT/nfft/pull/30.patch
+ patch -p1 -i 30.patch
+
+ autoreconf -vfi
+}
+
+build() {
+ cd "${srcdir}/nfft-${pkgver}"
+ for _arch in ${_architectures}; do
+ mkdir -p build-${_arch} && pushd build-${_arch}
+ ${_arch}-configure
+ make
+ popd
+ done
+}
+
+package() {
+ for _arch in ${_architectures}; do
+ cd "${srcdir}/nfft-${pkgver}/build-${_arch}"
+ make DESTDIR="$pkgdir" install
+ ${_arch}-strip --strip-unneeded "$pkgdir"/usr/${_arch}/bin/*.dll
+ ${_arch}-strip -g "$pkgdir"/usr/${_arch}/lib/*.a
+ rm -r "$pkgdir/usr/${_arch}/share"
+ done
+}
+