summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichel Zou2019-09-01 09:55:14 +0200
committerMichel Zou2019-09-01 09:55:14 +0200
commitb529ba36f8d29f3b2b8f56f6f58208835004e144 (patch)
treebcd2221c82a3d29bbbaa05a14bde81e88f0dff8c
parent13387bfeb16eee1b0d9d05470ba54548c7b79abb (diff)
downloadaur-mingw-w64-optpp.tar.gz
curl
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD14
2 files changed, 5 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4b82cb37e232..03166013a2dc 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -10,8 +10,6 @@ pkgbase = mingw-w64-optpp
options = staticlibs
options = !buildflags
options = !strip
- source = https://software.sandia.gov/opt++//downloads/optpp-2.4.tar.gz
- sha256sums = b452cdf8aa770088e26b49e07b5cf13ae5972832c032abcad07a56baa2a588ef
pkgname = mingw-w64-optpp
diff --git a/PKGBUILD b/PKGBUILD
index ddae30a3ef61..fafee33329ca 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,25 +9,21 @@ license=('LGPL2.1')
depends=('mingw-w64-blas')
makedepends=('mingw-w64-configure')
options=('staticlibs' '!buildflags' '!strip')
-source=("${url}/downloads/optpp-${pkgver}.tar.gz")
-sha256sums=('b452cdf8aa770088e26b49e07b5cf13ae5972832c032abcad07a56baa2a588ef')
+#source=("${url}/downloads/optpp-${pkgver}.tar.gz")
+#sha256sums=('b452cdf8aa770088e26b49e07b5cf13ae5972832c032abcad07a56baa2a588ef')
_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
prepare() {
- cd "${srcdir}/optpp-${pkgver}"
- sed -i "26i@top_builddir@_lib_libnewmat_la_LDFLAGS = -no-undefined" newmat11/Makefile.am
- sed -i "22i@top_builddir@_lib_libopt_la_LIBADD += @top_builddir@/lib/libnewmat.la" src/Makefile.am
- sed -i "22i@top_builddir@_lib_libopt_la_LIBADD += \$(BLAS_LIBS)" src/Makefile.am
- sed -i "24i@top_builddir@_lib_libopt_la_LDFLAGS = -no-undefined" src/Makefile.am
- autoreconf -vfi
+ # SSL certificate problem: unable to get local issuer certificate
+ curl -k https://software.sandia.gov/opt++//downloads/optpp-2.4.tar.gz | tar xz
}
build() {
cd "${srcdir}/optpp-${pkgver}"
for _arch in ${_architectures}; do
mkdir -p build-${_arch} && pushd build-${_arch}
- ${_arch}-configure --includedir=/usr/${_arch}/include/opt++
+ LDFLAGS="-Wl,-no-undefined" ${_arch}-configure --includedir=/usr/${_arch}/include/opt++
make
popd
done