summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichał Wojdyła2022-08-13 04:34:51 +0200
committerMichał Wojdyła2022-08-13 04:34:51 +0200
commit6abf4ab71dc484ef058721d7ca7016d3a4acc7c7 (patch)
treef3e8196de9ad98f8e0a6e99764ee807cabb61063
parente4b068ad3c840915d629321197f97e109a7bb285 (diff)
downloadaur-mingw-w64-xcb-proto.tar.gz
update to 1.15.2
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD38
2 files changed, 31 insertions, 22 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 98367ac174c4..168ebe1181e3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,18 @@
pkgbase = mingw-w64-xcb-proto
pkgdesc = XML-XCB protocol descriptions (mingw-w64)
- pkgver = 1.11.r95.g6b832a0
+ pkgver = 1.15.2
pkgrel = 1
- url = http://xcb.freedesktop.org/
+ url = https://xcb.freedesktop.org/
arch = any
license = custom
makedepends = python
makedepends = mingw-w64-libxml2
- makedepends = git
- source = xcb-proto::git://git.freedesktop.org/git/xcb/proto
- sha256sums = SKIP
+ source = https://xorg.freedesktop.org/archive/individual/proto/xcb-proto-1.15.2.tar.xz
+ source = https://xorg.freedesktop.org/archive/individual/proto/xcb-proto-1.15.2.tar.xz.sig
+ source = 0001_xcb-proto_revert_datarootdir.patch::https://gitlab.freedesktop.org/xorg/proto/xcbproto/-/commit/d849b9534a52b0199f26c1dd30ac11aba12db9dc.patch
+ validpgpkeys = 3BB639E56F861FA2E86505690FDD682D974CA72A
+ sha512sums = 9d0b2f0a4dbbf2d64e32ff4658d1663e13d7e5f1bffc1e8d45be7b9dd5bab46e29fc1c2f6e66a7a569e374ba6756faf3c39b0b5e5560df6d7f8b68beec97659d
+ sha512sums = SKIP
+ sha512sums = SKIP
pkgname = mingw-w64-xcb-proto
-
diff --git a/PKGBUILD b/PKGBUILD
index 6f2d2eb30a66..9332c045294b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,29 +1,35 @@
-# Maintainer Jens Staal <staal1978@gmial.com>
+# Maintainer: Michał Wojdyła < micwoj9292 at gmail dot com >
+# Contributor: Jens Staal <staal1978@gmial.com>
# adopted from official xcb-proto package:
# $Id$
-# Maintainer: Andreas Radke <andyrtr@archlinux.org>
+# Contributor: Andreas Radke <andyrtr@archlinux.org>
# Contributor: Jan de Groot <jgc@archlinux.org>
-
+_pkgname=xcb-proto
pkgname=mingw-w64-xcb-proto
-pkgver=1.11.r95.g6b832a0
+pkgver=1.15.2
pkgrel=1
pkgdesc="XML-XCB protocol descriptions (mingw-w64)"
arch=(any)
-url="http://xcb.freedesktop.org/"
+url="https://xcb.freedesktop.org/"
license=('custom')
-makedepends=('python' 'mingw-w64-libxml2' 'git')
-source=("xcb-proto::git://git.freedesktop.org/git/xcb/proto")
-sha256sums=('SKIP')
+makedepends=('python' 'mingw-w64-libxml2')
+source=(https://xorg.freedesktop.org/archive/individual/proto/$_pkgname-$pkgver.tar.xz{,.sig}
+0001_xcb-proto_revert_datarootdir.patch::https://gitlab.freedesktop.org/xorg/proto/xcbproto/-/commit/d849b9534a52b0199f26c1dd30ac11aba12db9dc.patch)
+sha512sums=('9d0b2f0a4dbbf2d64e32ff4658d1663e13d7e5f1bffc1e8d45be7b9dd5bab46e29fc1c2f6e66a7a569e374ba6756faf3c39b0b5e5560df6d7f8b68beec97659d'
+ 'SKIP'
+'SKIP')
+validpgpkeys=('3BB639E56F861FA2E86505690FDD682D974CA72A') # "Matt Turner <mattst88@gmail.com>"
+_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
-pkgver() {
- cd "$srcdir/xcb-proto"
- git describe --long | sed 's/-/.r/;s/-/./g'
+prepare() {
+ cd $_pkgname-$pkgver
+ # revert pkgfile back to /usr/lib
+ patch -Rp1 -i ../0001_xcb-proto_revert_datarootdir.patch
+ autoreconf -vfi
}
-_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
-
build() {
- cd xcb-proto
+ cd $_pkgname-$pkgver
./autogen.sh
make distclean
for _arch in ${_architectures}; do
@@ -35,9 +41,9 @@ build() {
}
package() {
- cd xcb-proto
+ cd $_pkgname-$pkgver
for _arch in ${_architectures}; do
- cd "${srcdir}/xcb-proto/build-${_arch}"
+ cd "${srcdir}/$_pkgname-$pkgver/build-${_arch}"
make DESTDIR="$pkgdir" install
done
}