summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrew Sun2020-05-31 21:45:45 -0400
committerAndrew Sun2020-05-31 21:45:45 -0400
commit0f5e5e004cbfa61e76fa01b95c7f4e72e1e216f1 (patch)
tree164dfb9db7b982dd78b3d3d41b2d86568e083d2f
parentb572c426d251fb59d17138fd1cef5e309d153ac6 (diff)
downloadaur-mingw-w64-zziplib.tar.gz
0.13.71
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD16
2 files changed, 12 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2e32bd78de73..aca2860459d3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,13 @@
pkgbase = mingw-w64-zziplib
pkgdesc = A lightweight library that offers the ability to easily extract data from files archived in a single zip file (mingw-w64)
- pkgver = 0.13.69
+ pkgver = 0.13.71
pkgrel = 1
url = http://zziplib.sourceforge.net
arch = any
license = LGPL, MPL
makedepends = mingw-w64-configure
makedepends = mingw-w64-sdl
- makedepends = python2
+ makedepends = python
makedepends = xmlto
makedepends = zip
depends = mingw-w64-crt
@@ -16,9 +16,9 @@ pkgbase = mingw-w64-zziplib
options = staticlibs
options = !strip
options = !buildflags
- source = zziplib-0.13.69.tar.gz::https://github.com/gdraheim/zziplib/archive/v0.13.69.tar.gz
+ source = zziplib-0.13.71.tar.gz::https://github.com/gdraheim/zziplib/archive/v0.13.71.tar.gz
source = configure.patch
- sha256sums = 846246d7cdeee405d8d21e2922c6e97f55f24ecbe3b6dcf5778073a88f120544
+ sha256sums = 2ee1e0fbbb78ec7cc46bde5b62857bc51f8d665dd265577cf93584344b8b9de2
sha256sums = 892162a8535575891663607b8fb5e3be518e8293e9b0f22cf437b1d83a58b008
pkgname = mingw-w64-zziplib
diff --git a/PKGBUILD b/PKGBUILD
index 73c6b9400c07..303cf2b65081 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,33 +1,33 @@
-# Maintainer: Andrew Sun <adsun701@gmail.com>
+# Maintainer: Andrew Sun <adsun701 at gmail dot com>
pkgname=mingw-w64-zziplib
-pkgver=0.13.69
+pkgver=0.13.71
pkgrel=1
pkgdesc="A lightweight library that offers the ability to easily extract data from files archived in a single zip file (mingw-w64)"
arch=(any)
url="http://zziplib.sourceforge.net"
license=("LGPL, MPL")
-makedepends=('mingw-w64-configure' 'mingw-w64-sdl' 'python2' 'xmlto' 'zip')
+makedepends=('mingw-w64-configure' 'mingw-w64-sdl' 'python' 'xmlto' 'zip')
depends=('mingw-w64-crt' 'mingw-w64-zlib')
optdepends=("mingw-w64-sdl: SDL_rwops for ZZipLib")
options=(staticlibs !strip !buildflags)
source=("zziplib-${pkgver}.tar.gz"::"https://github.com/gdraheim/zziplib/archive/v${pkgver}.tar.gz"
"configure.patch")
-sha256sums=('846246d7cdeee405d8d21e2922c6e97f55f24ecbe3b6dcf5778073a88f120544'
+sha256sums=('2ee1e0fbbb78ec7cc46bde5b62857bc51f8d665dd265577cf93584344b8b9de2'
'892162a8535575891663607b8fb5e3be518e8293e9b0f22cf437b1d83a58b008')
_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
prepare() {
- cd "${srcdir}/zziplib-${pkgver}"
- patch -Np1 -i ${srcdir}/configure.patch
+ cd "${srcdir}/zziplib-${pkgver}"
+ patch -Np1 -i ${srcdir}/configure.patch
autoreconf -fiv
}
build() {
cd "${srcdir}/zziplib-${pkgver}"
for _arch in ${_architectures}; do
- export PYTHON=/usr/bin/python2
+ export PYTHON=/usr/bin/python
export PERL=/usr/bin/perl
mkdir -p build-${_arch} && pushd build-${_arch}
${_arch}-configure \
@@ -43,7 +43,7 @@ package() {
for _arch in ${_architectures}; do
cd "${srcdir}/zziplib-${pkgver}/build-${_arch}"
make DESTDIR="$pkgdir" install
- ${_arch}-strip --strip-unneeded "$pkgdir"/usr/${_arch}/bin/*.exe
+ rm -rf "$pkgdir"/usr/${_arch}/bin/*.exe
${_arch}-strip --strip-unneeded "$pkgdir"/usr/${_arch}/bin/*.dll
${_arch}-strip -g "$pkgdir"/usr/${_arch}/lib/*.a
rm -rf "$pkgdir/usr/${_arch}/share"