summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorspider-mario2024-01-01 19:23:23 +0100
committerspider-mario2024-01-01 19:23:23 +0100
commit76ba422ef7dbfe9f910c35cde5b48b4e6b77035b (patch)
tree70418cbc90a77f21583891fa060b6dad73d83f0d
parent8930a4ca1c3100f551d9af2490900ceba80caf31 (diff)
downloadaur-mini-audicle.tar.gz
This is not actually needed
(Not bumping pkgrel because it does not affect the resulting package.)
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD13
-rw-r--r--rtaudio.patch13
3 files changed, 5 insertions, 24 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fbeb50c98d4b..e7f5ecf2e986 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -7,7 +7,6 @@ pkgbase = mini-audicle
groups = multimedia
license = GPL
makedepends = git
- makedepends = rtaudio
depends = qt6-base
depends = qscintilla-qt6
depends = libsndfile
@@ -17,11 +16,9 @@ pkgbase = mini-audicle
source = git+https://github.com/ccrma/chuck.git
source = git+https://github.com/ccrma/chugins.git
source = miniAudicle.desktop
- source = rtaudio.patch
b2sums = SKIP
b2sums = SKIP
b2sums = SKIP
b2sums = 44219938670cd42953c2e948702adea3a33efd99c858638c0b0f824defede799937cc0c49459c10820b44d9fce56c2a071c893fef4b8b27c7e08b348be5c9d7d
- b2sums = 1288e3aa8af0b5e09c00575344cf2142696e7e0c346d6a789aaa9fce7879d463cd876796d3641ca48d430c9fa5f137255bd1ea9b40e8bdc27b34b3daf6ac6f1c
pkgname = mini-audicle
diff --git a/PKGBUILD b/PKGBUILD
index 16c283108be5..270825abb332 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -15,22 +15,19 @@ depends=('qt6-base' 'qscintilla-qt6' 'libsndfile'
# 'alsa-lib'
# 'jack'
)
-makedepends=('git' 'rtaudio')
+makedepends=('git')
optdepends=('chuck: for documentation and command line interface')
source=('git+https://github.com/ccrma/miniAudicle.git#tag=de3c3a49816f77681e038fbcd13877ec92c01c07'
- 'git+https://github.com/ccrma/chuck.git'
- 'git+https://github.com/ccrma/chugins.git'
- 'miniAudicle.desktop'
- 'rtaudio.patch')
+ 'git+https://github.com/ccrma/chuck.git'
+ 'git+https://github.com/ccrma/chugins.git'
+ 'miniAudicle.desktop')
b2sums=('SKIP'
'SKIP'
'SKIP'
- '44219938670cd42953c2e948702adea3a33efd99c858638c0b0f824defede799937cc0c49459c10820b44d9fce56c2a071c893fef4b8b27c7e08b348be5c9d7d'
- '1288e3aa8af0b5e09c00575344cf2142696e7e0c346d6a789aaa9fce7879d463cd876796d3641ca48d430c9fa5f137255bd1ea9b40e8bdc27b34b3daf6ac6f1c')
+ '44219938670cd42953c2e948702adea3a33efd99c858638c0b0f824defede799937cc0c49459c10820b44d9fce56c2a071c893fef4b8b27c7e08b348be5c9d7d')
prepare() {
cd miniAudicle/src
- git apply -3 "$srcdir"/rtaudio.patch
git submodule init
git config submodule.src/chuck.url "$srcdir/chuck"
git config submodule.src/chugins.url "$srcdir/chugins"
diff --git a/rtaudio.patch b/rtaudio.patch
deleted file mode 100644
index 18993b267589..000000000000
--- a/rtaudio.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-diff --git a/src/util_rterror.h b/src/util_rterror.h
-index 72d6bf3..4072c05 100644
---- a/src/util_rterror.h
-+++ b/src/util_rterror.h
-@@ -8,7 +8,7 @@
- #pragma once
-
- #include <string>
--#include "RtAudio/RtAudio.h"
-+#include "rtaudio/RtAudio.h"
-
- void rtaudio_error(RtAudioErrorType type, const std::string &errorText);
- void rtaudio_error_clear();