summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorWiktor Kwapisiewicz2022-02-28 10:12:28 +0100
committerWiktor Kwapisiewicz2022-02-28 10:15:53 +0100
commitbf0264bf4f1fe877da0d14b491f6bbd87125d447 (patch)
treeb536e81b7c371e34186cf3d8b0fbbb8598e4ad09
downloadaur-minics-git.tar.gz
Add initial package for minics
-rw-r--r--.SRCINFO15
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD33
3 files changed, 52 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..609147336b51
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = minics-git
+ pkgdesc = Miniature certificate store for OpenPGP
+ pkgver = 0.1
+ pkgrel = 1
+ url = https://gitlab.com/wiktor/minics
+ arch = x86_64
+ license = LGPL
+ makedepends = cargo
+ makedepends = git
+ provides = minics
+ conflicts = minics
+ source = git+https://gitlab.com/wiktor/minics
+ sha512sums = SKIP
+
+pkgname = minics-git
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..d34aadd0c9cb
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+pkg
+minics
+src
+*.zst
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..85a0da58b232
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Wiktor Kwapisiewicz <wiktor@metacode.biz>
+
+pkgname=minics-git
+pkgver=0.1
+pkgrel=1
+pkgdesc="Miniature certificate store for OpenPGP"
+license=('LGPL')
+url="https://gitlab.com/wiktor/minics"
+arch=('x86_64')
+makedepends=(cargo git)
+source=("git+https://gitlab.com/wiktor/minics")
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+sha512sums=('SKIP')
+
+build() {
+ cd "${srcdir}/${pkgname%-git}"
+ export RUSTUP_TOOLCHAIN=stable
+ export CARGO_TARGET_DIR=target
+ cargo build --frozen --release --all-features
+}
+
+check() {
+ cd "${srcdir}/${pkgname%-git}"
+ export RUSTUP_TOOLCHAIN=stable
+ cargo test --frozen --all-features
+}
+
+package() {
+ cd "${srcdir}/${pkgname%-git}"
+ install -Dm0755 -t "$pkgdir/usr/bin/" "target/release/${pkgname%-git}"
+ install -Dm0644 -t "$pkgdir/usr/lib/systemd/user/" "contrib/${pkgname%-git}.service"
+}