summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorpeter-nebe2020-05-08 04:47:02 +0200
committerpeter-nebe2020-05-08 04:47:02 +0200
commit90120e6d7b2b9012dc9e6ca9637d2e5566a71c15 (patch)
tree1c6c5b27b99dfe79a708dcf29e83830bd7eaeb14
downloadaur-minidlna-mp34.tar.gz
First commit
-rw-r--r--.SRCINFO22
-rwxr-xr-xPKGBUILD39
-rwxr-xr-xpost_install.pacman4
3 files changed, 65 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4c52cbeae7e3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = minidlna-mp34
+ pkgdesc = Extended MiniDLNA server. A possible solution if the audio player of your DLNA client has a poor appearance.
+ pkgver = 1.0.0
+ pkgrel = 1
+ url = https://github.com/peter-nebe/minidlna-mp34
+ install = post_install.pacman
+ arch = x86_64
+ license = GPL3
+ makedepends = git
+ depends = qt5-webkit
+ depends = ffmpeg
+ depends = libid3tag
+ depends = libexif
+ source = https://ffmpeg.org/releases/ffmpeg-4.2.2.tar.bz2
+ source = https://downloads.sourceforge.net/project/minidlna/minidlna/1.2.1/minidlna-1.2.1.tar.gz
+ source = git+https://github.com/peter-nebe/minidlna-mp34.git
+ sha256sums = b620d187c26f76ca19e74210a0336c3b8380b97730df5cdf45f3e69e89000e5c
+ sha256sums = 67388ba23ab0c7033557a32084804f796aa2a796db7bb2b770fb76ac2a742eec
+ sha256sums = SKIP
+
+pkgname = minidlna-mp34
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100755
index 000000000000..6c74af7e0060
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: Peter Nebe <mail@peter-nebe.dev>
+pkgname=minidlna-mp34
+pkgver=1.0.0
+pkgrel=1
+pkgdesc="Extended MiniDLNA server. A possible solution if the audio player of your DLNA client has a poor appearance."
+arch=('x86_64')
+url="https://github.com/peter-nebe/minidlna-mp34"
+license=('GPL3')
+depends=('qt5-webkit' 'ffmpeg' 'libid3tag' 'libexif')
+makedepends=('git')
+install=post_install.pacman
+source=(
+ https://ffmpeg.org/releases/ffmpeg-4.2.2.tar.bz2
+ https://downloads.sourceforge.net/project/minidlna/minidlna/1.2.1/minidlna-1.2.1.tar.gz
+ git+https://github.com/peter-nebe/minidlna-mp34.git
+)
+sha256sums=(
+ b620d187c26f76ca19e74210a0336c3b8380b97730df5cdf45f3e69e89000e5c
+ 67388ba23ab0c7033557a32084804f796aa2a796db7bb2b770fb76ac2a742eec
+ SKIP
+)
+build() {
+ cd ffmpeg-4.2.2
+ ./configure
+ cd ../minidlna-1.2.1
+ ./configure
+ cd ../$pkgname
+ cmake -DCMAKE_INSTALL_PREFIX=/ .
+ make
+ cd mp3-to-mp4/src
+ cmake -DCMAKE_INSTALL_PREFIX=/ .
+ make
+}
+package() {
+ cd $pkgname/mp3-to-mp4/src
+ make DESTDIR="$pkgdir/" install
+ cd ../..
+ make DESTDIR="$pkgdir/" install
+}
diff --git a/post_install.pacman b/post_install.pacman
new file mode 100755
index 000000000000..335241fa30ad
--- /dev/null
+++ b/post_install.pacman
@@ -0,0 +1,4 @@
+# to be executed by pacman
+post_install() {
+ /etc/minidlna-mp34/post_install.sh
+}