summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarius Lindvall2020-12-05 00:31:02 +0100
committerMarius Lindvall2020-12-05 00:31:02 +0100
commitedaed80e4a4d1e5e63736e5b8a24785b6ee8575d (patch)
tree851dc197c8960efe58e4cb4321a60028d335a7f7
parent773fe7ee09177055f1a426b0549cf39fdaa51a90 (diff)
downloadaur-edaed80e4a4d1e5e63736e5b8a24785b6ee8575d.tar.gz
Allow launching with Java 8
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD4
-rw-r--r--miniongg.sh25
3 files changed, 19 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4ff6ebb13855..4119a9a227df 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = miniongg
pkgdesc = Elder Scrolls Online and World of Warcraft Addon Manager
pkgver = 3.0.7_SNAPSHOT.r1.12dbc95e
- pkgrel = 3
+ pkgrel = 4
url = https://minion.mmoui.com/
arch = any
license = custom
@@ -17,7 +17,7 @@ pkgbase = miniongg
md5sums = 977dcbe4914fe452055d092083960f4c
md5sums = 862307f1f506b42a576c8d49e90eccbf
md5sums = 0e439acd67fab9625deae97f657615ba
- md5sums = 4e4379da15949ba28dabc3dc2678aa37
+ md5sums = c758cbb772d9878451c51f1c5d8f8353
md5sums = cb92061ae2d15effbddc3b23600cfeaf
pkgname = miniongg
diff --git a/PKGBUILD b/PKGBUILD
index 80cdbe9099a8..342ef0567f41 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=miniongg
pkgver=3.0.7_SNAPSHOT.r1.12dbc95e
-pkgrel=3
+pkgrel=4
pkgdesc="Elder Scrolls Online and World of Warcraft Addon Manager"
arch=('any')
url='https://minion.mmoui.com/'
@@ -20,7 +20,7 @@ source=("https://cdn.mmoui.com/minion/v3/MinionClientUpdate-12dbc95eff5898a64f58
md5sums=("977dcbe4914fe452055d092083960f4c"
"862307f1f506b42a576c8d49e90eccbf"
"0e439acd67fab9625deae97f657615ba"
- "4e4379da15949ba28dabc3dc2678aa37"
+ "c758cbb772d9878451c51f1c5d8f8353"
"cb92061ae2d15effbddc3b23600cfeaf")
package() {
diff --git a/miniongg.sh b/miniongg.sh
index 978d2a97dcb6..33d195c96c34 100644
--- a/miniongg.sh
+++ b/miniongg.sh
@@ -1,11 +1,16 @@
#!/bin/sh
-java --module-path=/usr/lib/jvm/default/lib/javafx.web.jar:/usr/lib/jvm/default/lib/javafx.graphics.jar:/usr/lib/jvm/default/lib/javafx.base.jar:/usr/lib/jvm/default/lib/javafx.swing.jar:/usr/lib/jvm/default/lib/javafx.fxml.jar:/usr/lib/jvm/default/lib/javafx.controls.jar:/usr/lib/jvm/default/lib/javafx-swt.jar:/usr/lib/jvm/default/lib/javafx.media.jar \
- --add-modules=javafx.swing,javafx.graphics,javafx.fxml,javafx.media,javafx.web \
- --add-reads javafx.graphics=ALL-UNNAMED \
- --add-opens javafx.controls/com.sun.javafx.charts=ALL-UNNAMED \
- --add-opens javafx.graphics/com.sun.javafx.iio=ALL-UNNAMED \
- --add-opens javafx.graphics/com.sun.javafx.iio.common=ALL-UNNAMED \
- --add-opens javafx.graphics/com.sun.javafx.css=ALL-UNNAMED \
- --add-opens javafx.graphics/javafx.scene.image=ALL-UNNAMED\
- --add-opens javafx.base/com.sun.javafx.runtime=ALL-UNNAMED \
- -jar /usr/share/java/minion/Minion-jfx.jar
+VERSION=$(java -version 2>&1 | awk -F '"' '/version/ {print $2}')
+if [ $(vercmp 1.9 "$VERSION") -le 0 ]; then
+ java --module-path=/usr/lib/jvm/default/lib/javafx.web.jar:/usr/lib/jvm/default/lib/javafx.graphics.jar:/usr/lib/jvm/default/lib/javafx.base.jar:/usr/lib/jvm/default/lib/javafx.swing.jar:/usr/lib/jvm/default/lib/javafx.fxml.jar:/usr/lib/jvm/default/lib/javafx.controls.jar:/usr/lib/jvm/default/lib/javafx-swt.jar:/usr/lib/jvm/default/lib/javafx.media.jar \
+ --add-modules=javafx.swing,javafx.graphics,javafx.fxml,javafx.media,javafx.web \
+ --add-reads javafx.graphics=ALL-UNNAMED \
+ --add-opens javafx.controls/com.sun.javafx.charts=ALL-UNNAMED \
+ --add-opens javafx.graphics/com.sun.javafx.iio=ALL-UNNAMED \
+ --add-opens javafx.graphics/com.sun.javafx.iio.common=ALL-UNNAMED \
+ --add-opens javafx.graphics/com.sun.javafx.css=ALL-UNNAMED \
+ --add-opens javafx.graphics/javafx.scene.image=ALL-UNNAMED\
+ --add-opens javafx.base/com.sun.javafx.runtime=ALL-UNNAMED \
+ -jar /usr/share/java/minion/Minion-jfx.jar
+else
+ java -jar /usr/share/java/minion/Minion-jfx.jar
+fi