summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorrtkay1232023-11-14 11:13:44 +0200
committerrtkay1232023-11-14 11:13:44 +0200
commit51507fe93297aade6e2c522fe4c6a029f85a8755 (patch)
tree21395b70e2b2ed6a1bc98112030995cbb4948dee
parentec075d231f2674bced9683d34aa6f84e0762781d (diff)
downloadaur-mirro-rs-git.tar.gz
chore: update pkg metadata
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD12
2 files changed, 11 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 57c561ddefc9..837fbbe7aded 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
pkgbase = mirro-rs-git
pkgdesc = An Arch Linux mirrorlist management tool with a TUI
- pkgver = r99.3ba7d2b
+ pkgver = r158.d3c3066
pkgrel = 1
- url = https://github.com/kawaki-san/mirro-rs
+ url = https://github.com/rtkay123/mirro-rs
arch = i686
arch = x86_64
arch = armv6h
@@ -11,9 +11,7 @@ pkgbase = mirro-rs-git
license = Apache
makedepends = git
makedepends = cargo
- depends = openssl
- depends = gcc-libs
- source = git+https://github.com/kawaki-san/mirro-rs
+ source = git+https://github.com/rtkay123/mirro-rs
md5sums = SKIP
pkgname = mirro-rs-git
diff --git a/PKGBUILD b/PKGBUILD
index fba65ebedc82..2f0aa612eb85 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,11 +1,10 @@
-# Maintainer: Kawaki <dev at kanjala dot com>
+# Maintainer: rtkay <dev at kanjala dot com>
_pkgname="mirro-rs"
pkgname="${_pkgname}-git"
-pkgver=r99.3ba7d2b
+pkgver=r158.d3c3066
pkgrel=1
makedepends=('git' 'cargo')
-depends=('openssl' 'gcc-libs')
-url=https://github.com/kawaki-san/mirro-rs
+url=https://github.com/rtkay123/mirro-rs
arch=('i686' 'x86_64' 'armv6h' 'armv7h')
pkgdesc="An Arch Linux mirrorlist management tool with a TUI"
source=("git+$url")
@@ -23,6 +22,11 @@ prepare() {
cargo fetch --locked
}
+check() {
+ cd "$_pkgname"
+ cargo test --frozen --all-features
+}
+
build() {
cd "$_pkgname"
cargo build --frozen --release --features toml