summarylogtreecommitdiffstats
diff options
context:
space:
mode:
author5chdn2016-08-25 10:02:41 +0200
committer5chdn2016-08-25 10:02:41 +0200
commit14f0d09c54509cf546c3e9f26a7193eea3a1ff37 (patch)
tree6e0bcecb04aaf4e994efc8559d630e750a00e5af
parent5e69d01fbfaab4a968e3a6e5d9b3e18b0cc5767b (diff)
downloadaur-mist-git.tar.gz
Release Beta 0.8.2
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD15
2 files changed, 7 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e9be9b69ed9b..30865347ebed 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Sat Jul 9 08:58:17 UTC 2016
+# Thu Aug 25 08:02:37 UTC 2016
pkgbase = mist-git
pkgdesc = Mist dapp browser and Ethereum wallet (git version).
- pkgver = 0.8.r1.g83b87bf
+ pkgver = 0.8.2.r6.g18fa764
pkgrel = 1
url = https://github.com/ethereum/mist
arch = i686
@@ -14,6 +14,7 @@ pkgbase = mist-git
makedepends = meteor-build-client
makedepends = gulp
depends = gmp
+ depends = geth
depends = leveldb
depends = qt5-base
depends = qt5-declarative
@@ -22,14 +23,9 @@ pkgbase = mist-git
depends = readline
depends = gconf
depends = libnotify
- optdepends = ethereum: The cpp-ethereum commandline client.
- provides = geth
+ optdepends = parity: The fast, light, robust Ethereum client.
provides = mist
provides = libnode
- conflicts = geth
- conflicts = geth-git
- conflicts = go-ethereum
- conflicts = go-ethereum-git
conflicts = mist
conflicts = libnode
conflicts = libnode-git
diff --git a/PKGBUILD b/PKGBUILD
index 0a9f402d0f0b..f825ab86480a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,12 +2,13 @@
pkgname=mist-git
_pkgname=mist
-pkgver=0.8.r1.g83b87bf
+pkgver=0.8.2.r6.g18fa764
pkgrel=1
pkgdesc="Mist dapp browser and Ethereum wallet (git version)."
arch=('i686' 'x86_64')
depends=(
'gmp'
+ 'geth'
'leveldb'
'qt5-base'
'qt5-declarative'
@@ -25,21 +26,16 @@ makedepends=(
'gulp'
)
provides=(
- 'geth'
'mist'
'libnode'
)
conflicts=(
- 'geth'
- 'geth-git'
- 'go-ethereum'
- 'go-ethereum-git'
'mist'
'libnode'
'libnode-git'
)
optdepends=(
- 'ethereum: The cpp-ethereum commandline client.'
+ 'parity: The fast, light, robust Ethereum client.'
)
url="https://github.com/ethereum/mist"
license=('GPL')
@@ -70,10 +66,7 @@ build() {
git pull
git submodule update --init
git apply "${srcdir}/mist-pathfix.patch"
- npm install meteor-build-client
- npm install gulp
npm install
- gulp update-nodes
gulp mist --platform linux
}
@@ -93,7 +86,6 @@ package() {
install -d "${pkgdir}/usr/bin"
ln -s "/usr/share/${_pkgname}/Mist" "${pkgdir}/usr/bin/mist"
- ln -s "/usr/share/${_pkgname}/resources/node/geth/geth" "${pkgdir}/usr/bin/geth"
install -Dm644 "${pkgdir}/usr/share/${_pkgname}/LICENSE" "${pkgdir}/usr/share/licenses/${_pkgname}/LICENSE"
rm "${pkgdir}/usr/share/${_pkgname}/LICENSE"
@@ -109,5 +101,4 @@ package() {
find "${pkgdir}" -type f -exec chmod 644 {} +
chmod 755 "${pkgdir}/usr/share/${_pkgname}/Mist"
chmod 755 "${pkgdir}/usr/share/${_pkgname}/libnode.so"
- chmod 755 "${pkgdir}/usr/share/${_pkgname}/resources/node/geth/geth"
}